LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   wxWidgets not installed? (http://www.linuxquestions.org/questions/slackware-14/wxwidgets-not-installed-4175429811/)

688a 09-30-2012 11:44 PM

wxWidgets not installed?
 
Hi there everyone.
I am a fresh newbie to Linux and just installed the Slackware(running xfce) in my laptop. It's running just perfect on it, and LOVE IT.

However, when I tried to install the software aMule in my machine, I got a message from slackbuild:

configure: error:
wxWidgets must be installed on your system but wx-config script couldn't be found. Please check that wx-config is in path or specified by --with-wx-config=path flag, the directory where wxWidgets libraries are installed (returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH or equivalent variable and wxWidgets version is 2.8.12 or above.

So, I downloaded the wxWidgets 2.9 and recompiled / ldconfiged it. And re-installed the aMule again. But still, I got the same error message! I am sure the wxWidgets has been installed because I could run wx-config command and it is in the $PATH!

What else should I do to fix it?

Thank guys.

Didier Spaier 10-01-2012 12:34 AM

Hi,

welcome to LQ and this Slackware forum.

I suppose that you use a SlackBuild from slackbuilds.org, and that you are running Slackware 14, right?

Did you install the the dependencies mentioned on this page?

Also, Some SlackBuilds for 13.37 don't work for 14.0 and that could be the case for this one (I didn't try). Then better simply wait for the SlackBuilds intended for Slackware 14.0 to be released, this could take a few days.

Now if you are running Slackware 13.37, better inform the maintainer of the script or post in slackbuild.org's mailing list.

willysr 10-01-2012 02:24 AM

Use wxGTK 2.8.x instead of going with the development release of 2.9.x

688a 10-01-2012 09:15 PM

Quote:

Originally Posted by Didier Spaier (Post 4793656)
Hi,

welcome to LQ and this Slackware forum.

I suppose that you use a SlackBuild from slackbuilds.org, and that you are running Slackware 14, right?

Did you install the the dependencies mentioned on this page?

Also, Some SlackBuilds for 13.37 don't work for 14.0 and that could be the case for this one (I didn't try). Then better simply wait for the SlackBuilds intended for Slackware 14.0 to be released, this could take a few days.

Now if you are running Slackware 13.37, better inform the maintainer of the script or post in slackbuild.org's mailing list.

Thx dude. Yes mine is 14. I am pretty new and don't really understand how to set all these variables in the link you mentioned. And more questions are coming along when I start using it, such as no audio etc... I think I need to read the SlackDocs again more carefully.
Thx anyway.

688a 10-01-2012 09:16 PM

Quote:

Originally Posted by willysr (Post 4793716)
Use wxGTK 2.8.x instead of going with the development release of 2.9.x

I got no luck on 2.8.x!

688a 10-01-2012 09:22 PM

Oh.... btw, I've found that the amule installation is looking for wxWidgets in /user/bin. But the slackbuild put the wxWidgets in /usr/local/bin. How can I tell slackbuild to install the lib in the right place?

Thx.

bnguyen 10-01-2012 11:07 PM

Where did you get the SlackBuild for wxWidgets?

Ilgar 10-01-2012 11:42 PM

You should pass the option --prefix=/usr to the configure script.

willysr 10-02-2012 12:16 AM

Quote:

Originally Posted by 688a (Post 4794494)
I got no luck on 2.8.x!

what do you mean no luck?
it builds fine with SlackBuilds

fgcl2k 10-02-2012 02:41 AM

Quote:

Originally Posted by 688a (Post 4794497)
But the slackbuild put the wxWidgets in /usr/local/bin. How can I tell slackbuild to install the lib in the right place?
Thx.

As others have already asked, are you using the wxGTK package from SlackBuild.org( http://slackbuilds.org/repository/13...braries/wxGTK/)? I have wxGTK 2.8.12 on 13.37; it installed flawlessly in /usr; I don't think that SlackBuilds from SlackBuild.org install using the /usr/local prefix.
Code:

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --enable-shared \
  --with-opengl \
  --${_do_unicode}able-unicode \
  --build=$ARCH-slackware-linux$ARCHQUADLET


688a 10-02-2012 11:56 AM

Quote:

Originally Posted by Ilgar (Post 4794572)
You should pass the option --prefix=/usr to the configure script.

I'll try later.

Quote:

Originally Posted by bnguyen (Post 4794557)
Where did you get the SlackBuild for wxWidgets?

I got mine from slackbuilds.org!


Quote:

Originally Posted by willysr (Post 4794587)
what do you mean no luck?
it builds fine with SlackBuilds

Sorry about my English and it got you guys confused.
My problem isn't the wxWidgets installation. It installed just fine to me(I guess). But when I installed the application aMule from slackbuild, it said no wxWidgets installed. I think the problem should be aMule installation, not wxWidgets.



Quote:

Originally Posted by fgcl2k (Post 4794651)
As others have already asked, are you using the wxGTK package from SlackBuild.org( http://slackbuilds.org/repository/13...braries/wxGTK/)? I have wxGTK 2.8.12 on 13.37; it installed flawlessly in /usr; I don't think that SlackBuilds from SlackBuild.org install using the /usr/local prefix.
Code:

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --enable-shared \
  --with-opengl \
  --${_do_unicode}able-unicode \
  --build=$ARCH-slackware-linux$ARCHQUADLET


I don't know. I didn't change any codes anything. I just followed the instruction and installed the software. I don't know why the slackbuild put the things in the /usr/local! When I used "which wx-config", it showed /usr/local/bin. Is that meant to be in there?!


Thx guys.

ponce 10-02-2012 12:12 PM

can it be you got a previous install of wxWidgets from sources laying around?

can you show us the content of the wx* package you have installed? Its file list is in /var/log/packages/wx*

bnguyen 10-02-2012 01:06 PM

Quote:

Originally Posted by 688a (Post 4795103)
I'll try later.
I got mine from slackbuilds.org!

Please be specific, did you use wxX11, wxGTK or wxPython?

Also, post the link on slackbuilds.org where you downloaded it from.

willysr 10-02-2012 06:55 PM

Quote:

Originally Posted by ponce (Post 4795123)
can it be you got a previous install of wxWidgets from sources laying around?

I'm thinking the same idea, but even with source installation, the aMule should be able to find wxWidgets
Did you use the latest version of aMule?

688a 10-02-2012 09:56 PM

Quote:

Originally Posted by bnguyen (Post 4795217)
Please be specific, did you use wxX11, wxGTK or wxPython?

Also, post the link on slackbuilds.org where you downloaded it from.

I just did the searching on the SlackBuilds.org.
I installed the wxGTK this morning and things seemed ok for wxWidgets.



Quote:

Originally Posted by ponce (Post 4795123)
can it be you got a previous install of wxWidgets from sources laying around?

can you show us the content of the wx* package you have installed? Its file list is sin /var/log/packages/wx*

Quote:

Originally Posted by willysr (Post 4795505)
I'm thinking the same idea, but even with source installation, the aMule should be able to find wxWidgets
Did you use the latest version of aMule?

OK guys. I've got this through. I installed 14.0 verison of the wxGTK from SlackBuilds.org and it's now ok. (14.0 version can't be searched yesterday, must be newly added)

But there is another error:

checking for crypto++ version >= 5.1... no
configure: error:
Could not find crypto++ header file "cryptlib.h".
Please try again with --with-crypto-prefix=/my_crypto_prefix
(replace /my_crypto_prefix with a valid path to your crypto++
installation directory).


I googled the error message and it seems like something about GCC compiler. Should I install avr-gcc from SlackBuilds? Or should I apply the new gcc patch (and how to do it in Slackware)?

Thx guys.


All times are GMT -5. The time now is 05:38 PM.