LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-24-2010, 10:32 AM   #1
sniff
Member
 
Registered: Jan 2003
Location: Durham UK
Distribution: openSUSE 12.2/3 x86_64, Debian
Posts: 307

Rep: Reputation: 42
Question wxWidgets plotctrl not installed by Opensuse package manager.


Hello,

I am trying to install a program (snoopy2 petri net editor) under Opensuse 11.3 that requires libwxcode_gtk2u_plotctrl-2.8.so.0. This part of wxWidgets doesn't seem to be installed by Opensuse. Can I install it from source separately? Or is there a compatible binary somewhere?

Any help gratefully received.
Phil
 
Old 11-25-2010, 12:01 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,565

Rep: Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513Reputation: 2513
'snoopy2' http://www-dssz.informatik.tu-cottbus.de/snoopy.html
Code:
# rpm -Uvh snoopy-stable-linux-suse-2010-09-28.rpm
Failed dependencies:
        libwxcode_gtk2u_ogl-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        libwxcode_gtk2u_plotctrl-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        libwxcode_gtk2u_things-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by snoopy-3.01.1-1.i586
# 'rpm -Uvh --nodeps snoopy-stable-linux-suse-2010-09-28.rpm' will do.
The three missing files are included in the Fedora 13 package,
snoopy-stable-linux-fedora-2010-09-28.rpm
'rpm2cpio snoopy-stable-linux-fedora-2010-09-28.rpm | cpio -idmv' to open it.
Suse 11.2 : I did try with a copy to /usr/lib/ :
# cp libwxcode* /usr/lib/ , but the files are not compatible with Suse 11.2.

It may work in Suse 11.3 - 32, please try it out yourself.

I only have 11.3 - 64bits : No snoopy test possible, I think.

You may need this for your bug report ..
Contact: snoopy@informatik.tu-cottbus.de
..

P.S. : 'snoopy2' will open the GUI application OK on Fedora 13 - 32.
..

Last edited by knudfl; 11-25-2010 at 12:44 AM.
 
Old 11-26-2010, 07:05 AM   #3
sniff
Member
 
Registered: Jan 2003
Location: Durham UK
Distribution: openSUSE 12.2/3 x86_64, Debian
Posts: 307

Original Poster
Rep: Reputation: 42
The snoopy team added the libraries to the rpm. Thanks snoopy team.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSuSE 10.0 Package Manager? msound Suse/Novell 1 01-10-2007 05:11 PM
LXer: openSUSE 10.1 package manager fix due this week LXer Syndicated Linux News 0 07-20-2006 02:03 PM
LXer: OpenSUSE releases package manager fix LXer Syndicated Linux News 0 06-15-2006 06:21 AM
LXer: OpenSUSE package manager upgrade goes awry LXer Syndicated Linux News 0 05-24-2006 02:21 PM
RPM package manager says package needs to be installed. But I already installed it! nick623 Linux - Software 2 05-24-2005 02:15 AM


All times are GMT -5. The time now is 09:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration