LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-23-2012, 02:44 AM   #1
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Rep: Reputation: 90
Thunar 1.4.0 and Fluxbox on -current: no trash or automount usb devices


Just synced the latest -current updates and received xfce 4.10, thanks PV and crew! On my machine, using Fluxbox, Thunar does not have a trash can and cannot automouont usb sticks. When using xfce rather than fluxbox both of these features work as expected. Anybody else finding this or have I done something stupid?
 
Old 07-23-2012, 02:55 AM   #2
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 288

Rep: Reputation: 51
Yep, same thing here.
 
Old 07-23-2012, 05:59 AM   #3
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 140

Rep: Reputation: 47
Have you been able to automount USB-sticks using Thunar under Fluxbox before? I usually mount USB-sticks using the command line under Fluxbox (ie # mount -t vfat -o rw,users /dev/sdb1 /media/memory)

Update:
Same here, no automount.

Last edited by mats_b_tegner; 07-23-2012 at 06:11 AM.
 
Old 07-23-2012, 06:03 AM   #4
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by mats_b_tegner View Post
Have you been able to automount USB-sticks using Thunar under Fluxbox before?
Certainly could.
 
Old 07-23-2012, 06:29 AM   #5
walecha
LQ Newbie
 
Registered: Jan 2010
Location: Malang
Distribution: slackware
Posts: 11

Rep: Reputation: 0
I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.
 
Old 07-23-2012, 06:31 AM   #6
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 288

Rep: Reputation: 51
gvfs is installed.
 
Old 07-23-2012, 06:34 AM   #7
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by walecha View Post
I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.
But when I use xfce as an environment thunar has trash and automounting, on the same system fluxbox + thunar does not. Very curious....
 
Old 07-23-2012, 06:35 AM   #8
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 140

Rep: Reputation: 47
Quote:
Originally Posted by walecha View Post
I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.
I don't think gvfs is the problem. I checked and I have gvfs installed, but I can't automount USB-sticks using Thunar under Fluxbox or Xfce as a regular user.
 
Old 07-23-2012, 06:42 AM   #9
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Original Poster
Rep: Reputation: 90
OK looks like modifying ~/.xinitrc to:

Code:
# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi
fixes the issue here, perhaps there is a better way?
 
2 members found this post helpful.
Old 07-23-2012, 06:59 AM   #10
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 288

Rep: Reputation: 51
Quote:
Originally Posted by andrew.46 View Post
OK looks like modifying ~/.xinitrc to:

Code:
# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi
fixes the issue here, perhaps there is a better way?
Yep, that worked, thank you.
 
Old 07-23-2012, 08:57 AM   #11
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 140

Rep: Reputation: 47
Quote:
Originally Posted by andrew.46 View Post
Certainly could.
Have you added any groups to your user account? I have:
users lp floppy audio video cdrom plugdev power netdev
 
Old 07-23-2012, 10:01 AM   #12
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,547

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
try running xwmconfig twice because the xinitrc script has been changed
on newly install system, automount and trash does work
 
Old 07-23-2012, 10:17 AM   #13
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 140

Rep: Reputation: 47
Quote:
Originally Posted by willysr View Post
try running xwmconfig twice because the xinitrc script has been changed
on newly install system, automount and trash does work
I re-ran xwmconfig and I have trash and network when running Xfce as a normal user but no automount yet I have enabled automount in thunar-volman and it works as root. When automounted in Xfce as root, USB-sticks are mounted on /run/media/root/KINGSTON. How the heck do I solve this?

Update:
Automounting an USB stick in KDE works for both root and user (i.e /media/KINGSTON)

Last edited by mats_b_tegner; 07-23-2012 at 04:15 PM.
 
Old 07-23-2012, 10:51 AM   #14
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by andrew.46 View Post
OK looks like modifying ~/.xinitrc to:

Code:
# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi
fixes the issue here, perhaps there is a better way?
I don't think there is a better way. Have you perhaps tested the other non-XDG window managers to see if they work similarly? That would be nice :-)
 
Old 07-23-2012, 10:51 AM   #15
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,547

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
so weird... i have automount working on my old laptop using XFCE 4.10
no special tunning, just install fresh
probably it's because a new installation. The bug only occurred when upgrading from previous version?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trash can thunar Tripsun Linux - Desktop 1 03-08-2011 09:33 AM
How to automount USB devices read-write in Ubuntu 9.10 fmbulah Linux - Desktop 1 05-30-2010 11:51 PM
How to automount usb flash drives in Thunar (openbox) iamthat Linux - Newbie 1 05-12-2010 12:56 AM
can't delete (send to trash) files on usb devices. vacuman Ubuntu 4 01-27-2007 05:33 AM
Preventing Automount for USB Devices on Ubuntu phyx Linux - Newbie 2 02-13-2006 06:01 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration