LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Thunar 1.4.0 and Fluxbox on -current: no trash or automount usb devices (http://www.linuxquestions.org/questions/slackware-14/thunar-1-4-0-and-fluxbox-on-current-no-trash-or-automount-usb-devices-4175418186/)

andrew.46 07-23-2012 03:44 AM

Thunar 1.4.0 and Fluxbox on -current: no trash or automount usb devices
 
Just synced the latest -current updates and received xfce 4.10, thanks PV and crew! On my machine, using Fluxbox, Thunar does not have a trash can and cannot automouont usb sticks. When using xfce rather than fluxbox both of these features work as expected. Anybody else finding this or have I done something stupid?

Bindestreck 07-23-2012 03:55 AM

Yep, same thing here.

mats_b_tegner 07-23-2012 06:59 AM

Have you been able to automount USB-sticks using Thunar under Fluxbox before? I usually mount USB-sticks using the command line under Fluxbox (ie # mount -t vfat -o rw,users /dev/sdb1 /media/memory)

Update:
Same here, no automount.

andrew.46 07-23-2012 07:03 AM

Quote:

Originally Posted by mats_b_tegner (Post 4735743)
Have you been able to automount USB-sticks using Thunar under Fluxbox before?

Certainly could.

walecha 07-23-2012 07:29 AM

I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.

Bindestreck 07-23-2012 07:31 AM

gvfs is installed.

andrew.46 07-23-2012 07:34 AM

Quote:

Originally Posted by walecha (Post 4735760)
I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.

But when I use xfce as an environment thunar has trash and automounting, on the same system fluxbox + thunar does not. Very curious....

mats_b_tegner 07-23-2012 07:35 AM

Quote:

Originally Posted by walecha (Post 4735760)
I think you haven't installing gvfs as Thunar using it for mounting (via udisks) and accessing virtual FS such as trash:// and network FS.

I don't think gvfs is the problem. I checked and I have gvfs installed, but I can't automount USB-sticks using Thunar under Fluxbox or Xfce as a regular user.

andrew.46 07-23-2012 07:42 AM

OK looks like modifying ~/.xinitrc to:

Code:

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi

fixes the issue here, perhaps there is a better way?

Bindestreck 07-23-2012 07:59 AM

Quote:

Originally Posted by andrew.46 (Post 4735776)
OK looks like modifying ~/.xinitrc to:

Code:

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi

fixes the issue here, perhaps there is a better way?

Yep, that worked, thank you.

mats_b_tegner 07-23-2012 09:57 AM

Quote:

Originally Posted by andrew.46 (Post 4735745)
Certainly could.

Have you added any groups to your user account? I have:
users lp floppy audio video cdrom plugdev power netdev

willysr 07-23-2012 11:01 AM

try running xwmconfig twice because the xinitrc script has been changed
on newly install system, automount and trash does work

mats_b_tegner 07-23-2012 11:17 AM

Quote:

Originally Posted by willysr (Post 4735936)
try running xwmconfig twice because the xinitrc script has been changed
on newly install system, automount and trash does work

I re-ran xwmconfig and I have trash and network when running Xfce as a normal user but no automount yet I have enabled automount in thunar-volman and it works as root. When automounted in Xfce as root, USB-sticks are mounted on /run/media/root/KINGSTON. How the heck do I solve this?

Update:
Automounting an USB stick in KDE works for both root and user (i.e /media/KINGSTON)

rworkman 07-23-2012 11:51 AM

Quote:

Originally Posted by andrew.46 (Post 4735776)
OK looks like modifying ~/.xinitrc to:

Code:

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi

fixes the issue here, perhaps there is a better way?

I don't think there is a better way. Have you perhaps tested the other non-XDG window managers to see if they work similarly? That would be nice :-)

willysr 07-23-2012 11:51 AM

so weird... i have automount working on my old laptop using XFCE 4.10
no special tunning, just install fresh
probably it's because a new installation. The bug only occurred when upgrading from previous version?


All times are GMT -5. The time now is 11:29 PM.