LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-23-2012, 11:52 AM   #16
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,973

Rep: Reputation: Disabled

Quote:
Originally Posted by willysr View Post
so weird... i have automount working on my old laptop using XFCE 4.10
no special tunning, just install fresh
probably it's because a new installation. The bug only occurred when upgrading from previous version?
It's fine in xfce - the trouble is with fluxbox (and probably a few other non-(kde|xfce) environments).
 
Old 07-23-2012, 01:16 PM   #17
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
seems that the "dbus-launch --exit-with-session" addition is needed also with blackbox, wmaker, fvwm2 and openbox.
twm, i3 and wmii don't work with thunar even with the addition.
 
Old 07-23-2012, 01:19 PM   #18
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 877

Rep: Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827
Quote:
Originally Posted by ponce View Post
seems that the "dbus-launch --exit-with-session" addition is needed also with blackbox, wmaker, fvwm2 and openbox.
twm, i3 and wmii don't work with thunar even with the addition.
NOOOO! Not twm!
 
Old 07-23-2012, 01:27 PM   #19
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Sorry Pat, I got it wrong: I launched thunar from one of the pre-started xterms, and it hadn't got the consolekit session.
Starting it from a newly created xterm from the twm environment, it works
I have to add to the twm invocation in xinitrc "ck-launch-session dbus-launch --exit-with-session"
 
Old 07-23-2012, 01:40 PM   #20
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 145

Rep: Reputation: 47
If I launch Thunar in Fluxbox with "ck-launch-session dbus-launch --exit-with-session" added to .xinitrc Thunar freezes and spits out the following in a terminal window/console:

Code:
(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.453 for volume monitor org.gtk.Private.UDisks2VolumeMonitor connected to the bus; seeding drives/volumes/mounts

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorUDisks2: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.455 for volume monitor org.gtk.Private.UDisks2VolumeMonitor connected to the bus; seeding drives/volumes/mounts

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorUDisks2: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
What causes that?

Update: I've reinstalled Xfce and dbus, but I've yet to find where the problem lies...

Last edited by mats_b_tegner; 07-23-2012 at 05:17 PM.
 
Old 07-23-2012, 03:00 PM   #21
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
reverified also with wmii and i3 (sorry I don't them that much and I had made a similar error as with twm): it works fine also there adding the "dbus-launch --exit-with-session".

mats, just FYI, I just tried here with fluxbox with the same addition and I don't have those errors (it works).
 
Old 07-25-2012, 04:59 AM   #22
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 651

Original Poster
Rep: Reputation: 92
Looks like the fix is being rolled out for slackware 14 so I shall mark this solved
 
Old 07-26-2012, 03:02 AM   #23
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 505

Rep: Reputation: 84
Quote:
Originally Posted by mats_b_tegner View Post
If I launch Thunar in Fluxbox with "ck-launch-session dbus-launch --exit-with-session" added to .xinitrc Thunar freezes and spits out the following in a terminal window/console:

Code:
(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.453 for volume monitor org.gtk.Private.UDisks2VolumeMonitor connected to the bus; seeding drives/volumes/mounts

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorUDisks2: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: New owner :1.455 for volume monitor org.gtk.Private.UDisks2VolumeMonitor connected to the bus; seeding drives/volumes/mounts

(Thunar:7622): GVFS-RemoteVolumeMonitor-WARNING **: invoking List() failed for type GProxyVolumeMonitorUDisks2: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
What causes that?

Update: I've reinstalled Xfce and dbus, but I've yet to find where the problem lies...
I had that same problem. Try setting your locale to UTF-8.
 
1 members found this post helpful.
Old 07-26-2012, 05:22 AM   #24
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 145

Rep: Reputation: 47
Quote:
Originally Posted by BrZ View Post
I had that same problem. Try setting your locale to UTF-8.
Setting the locale to UTF-8 solved the problem. Thanks. Reverting to locale en-US also works.

Last edited by mats_b_tegner; 07-26-2012 at 06:06 AM.
 
Old 09-01-2012, 07:11 PM   #25
htitan
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Rep: Reputation: 0
still doesn't work for me

I updated to current again today. My xinitrc files all have the added dbus-launch stuff--Thunar works fine in XFCE but not in windowmaker. No errors appear when run from a terminal. What else could it be?

If I run: dbus-launch thunar
then it works fine. I never needed to do that before, but launching it this way works.

Last edited by htitan; 09-01-2012 at 11:51 PM. Reason: solved problem
 
Old 09-03-2012, 11:07 PM   #26
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
Upgraded to RC4 and Thunar automounting of hard drive partitions and usb sticks works fine in Xfce, Windowmaker, and Fluxbox. If you are having issues, you might want to consider removing some things from ~/.cache -- perhaps the Thunar and any Xfce related directories. I would also remove ~/.gvfs and then try again.
 
Old 09-04-2012, 11:07 PM   #27
htitan
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Rep: Reputation: 0
I deleted .dbus, .cache, .gvfs and maybe some more. Still only works if I launch with dbus-launch.

Running thunar alone now now produces an error message:
thunar-volman: Unsupported USB device type.
 
Old 09-04-2012, 11:15 PM   #28
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
@htitan - is your user a member of the plugdev group? That is required for the 20-plugdev-group-mount-override.pkla file in /etc/polkit/localauthority/50-local.d/.
 
Old 09-05-2012, 12:44 AM   #29
htitan
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Rep: Reputation: 0
Yes, user is a member of:

lp, audio, video, cdrom, plugdev and scanner.
 
Old 09-05-2012, 03:59 AM   #30
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 651

Original Poster
Rep: Reputation: 92
Quote:
Originally Posted by chess View Post
@htitan - is your user a member of the plugdev group? That is required for the 20-plugdev-group-mount-override.pkla file in /etc/polkit/localauthority/50-local.d/.
Hmmm..... my own file is in a slightly different location:

Code:
root@skamandros/home/andrew# find /etc -iname 20-plugdev-group-mount-override.pkla
/etc/polkit-1/localauthority/50-local.d/20-plugdev-group-mount-override.pkla
and I have had to alter ~/.xintirc to:

Code:
# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session /usr/bin/startfluxbox
else
  exec /usr/bin/startfluxbox
fi
to achieve auto-mounting. Not sure if this is relevant?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trash can thunar Tripsun Linux - Desktop 1 03-08-2011 10:33 AM
How to automount USB devices read-write in Ubuntu 9.10 fmbulah Linux - Desktop 1 05-31-2010 12:51 AM
How to automount usb flash drives in Thunar (openbox) iamthat Linux - Newbie 1 05-12-2010 01:56 AM
can't delete (send to trash) files on usb devices. vacuman Ubuntu 4 01-27-2007 06:33 AM
Preventing Automount for USB Devices on Ubuntu phyx Linux - Newbie 2 02-13-2006 07:01 PM


All times are GMT -5. The time now is 01:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration