LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-21-2006, 03:36 PM   #1
dx0r515t
Member
 
Registered: Jan 2005
Location: USA
Distribution: Slackware 10.2 & 11.0
Posts: 155

Rep: Reputation: 30
System time correct for root, wrong for normal user?


My system time for root is correct, but for my normal user account it is wrong. The time in the BIOS is correct as well. I ran timeconfig as root and set the hardware clock to localtime and then set the correct timezone. Again as root the time is correct, when I run date as root I get this:

Quote:
bash-3.00# date
Fri Jul 21 16:26:16 EDT 2006
But when I run date as my normal user account I get this:

Quote:
bash-3.00$ date
Fri Jul 21 20:26:58 UTC 2006
I did notice that when I run as root and type "date" it says "EDT" next to the time (which is correct) but as a normal user it says "UTC". How do I change the time for my normal user so it's the same time as it is for root?

As root I can change the time with date -s xx:xx but when I try as a normal user I get "operation not permitted". I understand I am probably getting this error becuase I am trying to change the global system time as a normal user.. so how do I go about setting the correct time for my normal user account? It seems like there should be some kind of a command I can enter as root that will change the time for all users.

Last edited by dx0r515t; 07-21-2006 at 03:41 PM.
 
Old 07-21-2006, 04:51 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,775

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Take a look at /etc/localtime:
Code:
ls -l /etc/localtime
and if the permissions are rw--- change it to rw-r-r.
Or as root run:
Code:
echo $TZ
to see if you've defined somehow the TIMEZONE and use that TZ in /etc/profile, so it's the same for all users. I.e. edit your /etc/profile and at the end add a line like this:
Code:
export TZ=EDT
Of course change EDT with the root's TZ.

Regards
 
Old 07-21-2006, 05:30 PM   #3
dx0r515t
Member
 
Registered: Jan 2005
Location: USA
Distribution: Slackware 10.2 & 11.0
Posts: 155

Original Poster
Rep: Reputation: 30
Thanks

Thanks bathory I did chmod 644 /etc/localhost as root and now the time is correct as a normal user.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is the difference between real root system and normal root system zameer_india Linux - Newbie 17 07-04-2012 12:18 PM
My system time goes twince as fast as normal!!! robin.w Linux - Software 5 03-21-2006 06:50 AM
System time goes twince as fast as normal robin.w Linux - Laptop and Netbook 1 03-19-2006 10:23 AM
Games runs slow as normal user, but fast as root user mcore Linux - Software 2 06-07-2004 11:11 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM


All times are GMT -5. The time now is 03:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration