LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2011, 04:05 PM   #1
jeremy-passarelli
LQ Newbie
 
Registered: May 2011
Location: USA
Distribution: Chakra
Posts: 17

Rep: Reputation: 10
Unhappy slapt-get error on first run


Hello! I get an error when running slapt-get.

The error is: "slapt-get: error while loading shared libraries: libsas.so.2: cannot open shared object file: No such file or directory".

Can you help me? I've booted the Slackware disk # 1 and unchecked everything except the libraries category and installed them. I rebooted and it still says this. I get this same error before I put the disk in and rebooted to install ALL libraries. I really need help. BTW, I can't load KDE :-(.

I found a pkg manager already installed called "slackpkg". But I really need help on this library issue!! I uninstalled it (slapt-get) anyway, so forget that!

Last edited by jeremy-passarelli; 05-22-2011 at 05:09 PM.
 
Old 05-22-2011, 05:54 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I'm confused now, are we supposed to be forgetting the problem this topic is actually about? If you need to resolve an issue with KDE, you are better off making a new topic that fully describes that problem, rather than derailing an existing one.

So to be clear, what issue are we working on now?
 
Old 05-22-2011, 06:28 PM   #3
jeremy-passarelli
LQ Newbie
 
Registered: May 2011
Location: USA
Distribution: Chakra
Posts: 17

Original Poster
Rep: Reputation: 10
We are working on the library issues and KDE. When I start xorg, it says something about D-BUS. BTW, how do I get the Xorg output into a text file?

Last edited by jeremy-passarelli; 05-22-2011 at 06:56 PM.
 
Old 05-22-2011, 07:40 PM   #4
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 226Reputation: 226Reputation: 226
Do a full install unless you know how to handle the consequences of missing deps.

You can probably skip the kdei/ and e/ (if you don't plan on using emacs).

X outputs a log file already /var/log/Xorg.0.log
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post your slapt-getrc for slapt-get/gslapt uppman Slackware 16 05-19-2009 08:03 AM
slapt-get not calling /etc/slapt-getrc halfpower Slackware 1 04-09-2009 03:49 PM
Some programs don't run after slapt-get ? glore2002 Slackware 3 08-04-2008 07:23 PM
slapt-get problem slack10.2 cannot run wetnose23 Slackware 4 01-09-2006 01:13 PM
/etc/slapt-getrc modification fails to influence slapt-get timsch75 Slackware 1 04-07-2004 08:48 AM


All times are GMT -5. The time now is 07:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration