LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-04-2008, 03:49 PM   #1
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Rep: Reputation: 32
Some programs don't run after slapt-get ?


Hello!

I am really confused and want to share this with you. After updating my system with slapt-get --update and slapt-get --upgrade some of the programs (specially games) don't run anymore. They don't even start.

Games that don't run anymore are: Extreme tux racer, Emilia Pinball, Brutal Chess and FooBillard. They were running perfectly well before the update.

The mirrors I've for slapt-get are:

Code:
SOURCE = http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.1/
SOURCE = http://slacky.uglyplace.org/repository/slackware-12.1/
I can't realize what happened. Maybe some programs, scripts or I don't know what where deleted during the upgrade. I reinstalled the games but they don't run anymore. If any of you can help me or tell me what to do, I will appreciate that.

Thanks,
glore2002.-

Last edited by glore2002; 08-04-2008 at 03:52 PM.
 
Old 08-04-2008, 04:33 PM   #2
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
I solved it but ...

As my title says, I solved it. How? Well maybe it wasn't the best way to do it but it works now. As I shared the problem, let me also share the solution I've found.

What I did was to uninstall through pkgtool both: nvidia-kernel and nvidia-driver (I installed them from slackbuilds.org). After uninstalling, I'ver rebooted my system and then installed them again.

Now, everything seems to work but... Why did this happened? As far as I can see, slapt-get can update things but it can also modify some settings. At least, this happened to me.

When should I use nvidia-switch --xorg and nvidia-switch --nvidia?

Thank you,
Glore2002.-
 
Old 08-04-2008, 05:33 PM   #3
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Not knowing how long it's been since you upgraded I can only guess that perhaps the xorg-server update on July 1 is the culprit.

Code:
+--------------------------+
 Tue Jul 1 13:30:57 CDT 2008
 patches/packages/xorg-server-1.4.2-i486-1_slack12.1.tgz:
        Upgraded xorg-server to address denial of service and possible arbitrary
        code execution flaws reported in xorg-server 1.4 prior to 1.4.2.
        For more information about the issues patched, please refer to:
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1377
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1379
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2360
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2361
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2362
        (* Security fix *)
 patches/packages/xorg-server-xnest-1.4.2-i486-1_slack12.1.tgz:
        Security fixes (see CVE entries above).
        (* Security fix *)
 patches/packages/xorg-server-xvfb-1.4.2-i486-1_slack12.1.tgz:
        Security fixes (see CVE entries above).
        (* Security fix *)
 +--------------------------+
These might have over-written the nvidia OpenGL libraries requiring you to reinstall the nVidia drivers.

Just a guess.
 
Old 08-04-2008, 07:23 PM   #4
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Thanks Franklin!

I guess you're right Franklin. That should have been the reason.

Thanks again,
Glore2002.-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slapt-get problem slack10.2 cannot run wetnose23 Slackware 4 01-09-2006 01:13 PM
can't run my programs blackman890 Linux - Software 11 11-01-2004 01:41 PM
how to run programs? matejj Linux - Newbie 6 05-06-2004 08:16 AM
/etc/slapt-getrc modification fails to influence slapt-get timsch75 Slackware 1 04-07-2004 08:48 AM
How to run programs? timberwolf Mandriva 3 12-08-2003 09:06 AM


All times are GMT -5. The time now is 11:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration