LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-09-2012, 07:47 AM   #1
spaghettios
LQ Newbie
 
Registered: Jul 2012
Location: UK
Distribution: Ubuntu, Slackware
Posts: 17

Rep: Reputation: Disabled
Slackware startx not working


Hi,
Google hasn't returned anything relevant for this.

Fresh install of Slackware 13.37, when i enter startx the prompt basically does nothing, it doesn't return an error message at all it just goes to another prompt line.

Code:
root@darkstar:~# startx
root@darkstar:~#
Am i missing something?

I've tried it as root, as well as created a new user to try it. Both no joy.
Any ideas?
 
Old 08-09-2012, 07:48 AM   #2
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,413

Rep: Reputation: Disabled
Firstly, why are you attempting to startx as root?
 
Old 08-09-2012, 07:53 AM   #3
spaghettios
LQ Newbie
 
Registered: Jul 2012
Location: UK
Distribution: Ubuntu, Slackware
Posts: 17

Original Poster
Rep: Reputation: Disabled
Because i tried as user. It should work as root as well. That is not the issue.
 
Old 08-09-2012, 08:00 AM   #4
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,413

Rep: Reputation: Disabled
Do startx again as a normal user
Code:
$ startx
Post some outputs
Code:
$ cat ~/.xsession-errors
Code:
$ grep 'WW\|EE' /var/log/Xorg.0.log
 
Old 08-09-2012, 08:22 AM   #5
spaghettios
LQ Newbie
 
Registered: Jul 2012
Location: UK
Distribution: Ubuntu, Slackware
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by caravel View Post
Post some outputs
Code:
$ cat ~/.xsession-errors
Code:
$ grep 'WW\|EE' /var/log/Xorg.0.log
hmmm in both of those it just returns No such file or directory

Code:
cat: /home/rp/.xsession-errors: No such file or directory
grep: /var/log/Xorg.0.log
I definitely had all of the XWindows stuff selected on install, the only thing left out was the foreign languages pack.
 
Old 08-09-2012, 09:29 AM   #6
wigry
Member
 
Registered: Jul 2004
Distribution: slackware
Posts: 218

Rep: Reputation: 52
There is specific Slackware are in this forum. As Slack is quite special distro, this newbie section is not the best place to find solutions.

http://www.linuxquestions.org/questions/slackware-14/

however you can go to /var/log/packages and see there, what packages are installed? how many "xorg-server-*" packages are there? You really need to install basically everything under x and selectively under xap (or all if HD space permits). The language packages you are referring to are probably the KDE ones.

Last edited by wigry; 08-09-2012 at 09:34 AM.
 
Old 08-09-2012, 09:50 AM   #7
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,607
Blog Entries: 1

Rep: Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047Reputation: 1047
Please do not startx as root.

Was it a full install?

It shouldn't happen on a fresh install, but make sure there's a desktop environment / window manager selected in xwmconfig.
 
Old 08-09-2012, 01:36 PM   #8
spaghettios
LQ Newbie
 
Registered: Jul 2012
Location: UK
Distribution: Ubuntu, Slackware
Posts: 17

Original Poster
Rep: Reputation: Disabled
OK thanks for your input everyone, this definitely shouldn't happen with a fresh install so i must have done something wrong in setup, will start over again. I just wanted to check like i wasn't missing something obvious. Will post to slackers forum in future.

Cheers
 
Old 08-09-2012, 08:47 PM   #9
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Moved: This thread is more suitable in <SLACKWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 08-09-2012, 09:53 PM   #10
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,836
Blog Entries: 15

Rep: Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188
You actually can start an X session in root, but beware that as root your system is more vulnerable, so try not to mess around as a root user unless absolutely needed. Root is for system administration, not normal work. If you do need root access just use the "sudo" or "su" tools to run things as with root privileges or as root through user.

You probably have an installation that may or may not have everything installed from the installation disk if that's the route you went. You could try to navigate to /etc/slackpkg and see if the "mirrors" file is editable with the text editor "nano", uncomment a choice file server, save the file and the run slackpkg with upgrade-all and install-new to see if it can remote install and repair your system.
 
1 members found this post helpful.
Old 08-09-2012, 10:16 PM   #11
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Check if your user(s) are in the correct groups?
 
Old 08-09-2012, 10:44 PM   #12
dxtrpn
LQ Newbie
 
Registered: Oct 2011
Location: New York
Distribution: Slackware64
Posts: 20

Rep: Reputation: Disabled
For fun, you could've tried booting into runlevel 4 [via /etc/inittab]... my guess is X was not installed.
 
Old 08-09-2012, 10:50 PM   #13
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Wouldn't make sense, [X] contains xinit which is what what contains /usr/bin/startx. He didn't get "startx: No such file or directory", but it is likely he hasn't done a full install, or isn't a part of the necessary groups since startx generally works out of the box.
 
Old 08-09-2012, 10:51 PM   #14
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,836
Blog Entries: 15

Rep: Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188
The groups for the user(s) should include the "video" group in order to access x11 correctly, which is normally a default, however he ran startx as root which has full permissions systemwide.

Running slackpkg or even pkgtool to check the packages should at least see if packages were or weren't installed.
 
Old 08-10-2012, 12:00 AM   #15
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
If X wasn't installed a "startx" would yield:
bash: startx: command not found

No?
 
  


Reply

Tags
slackware 13.37, startx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
StartX Not Working + Slackware 12.2 TeenyLemon Linux - Newbie 1 02-04-2010 05:48 AM
startx not working Anden008 Linux - Hardware 4 11-22-2005 01:37 PM
startx not working, help! ajbrouwe Slackware 3 07-11-2004 06:12 PM
Help! startx not working any more! dominik81 Linux - Newbie 0 10-02-2003 11:01 AM
startX not working sathish Linux - Hardware 3 02-07-2003 07:14 AM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration