LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2012, 01:45 PM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,125

Rep: Reputation: 46
Slackware 14.0 (x86_64): alsaconf nowhere to be seen.


Hi:
I've just installed Slackware 14.0 (x86_64). I installed all series, except for the series for international languages which the installer always unselects by default.

Now, when booting I get
Code:
amixer: Mixer default load error: Invalid argument
Storing default alsamixer settings: /usr/sbin/alsactl store
/usr/bin/alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument
And when invoking alsamixer I get
Code:
$ alsamixer
Cannot load mixer controls: Invalid argument
$
What can possibly be the cause? I tried to run alsaconf, but after doing 'updatedb', locate could not find it.

EDIT:
(a) Nor is alsaconf in the installation CD /extra / directory.

(b) Unfortunately /usr/doc/Linux-HOWTOs/Sound-HOWTO is obsolete (dated July 2001, it is still speaking of kernel 2.5 development).

(c) lspci gives
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

Last edited by stf92; 12-29-2012 at 02:48 PM.
 
Old 12-29-2012, 02:56 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
I remember I've read something to say that alsaconf is obsolete because it's broken in many places and is has only something to do with ISA sound cards.
 
Old 12-29-2012, 03:03 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Try alsactl init.
 
Old 12-29-2012, 03:27 PM   #4
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,125

Original Poster
Rep: Reputation: 46
Thanks. alsactl init tambien se quejaba... but not any longer. I created /etc/modprobe.d/alsa.conf:
Code:
$ cat alsa.conf
alias snd-card-0 snd_hda_intel
alias sound-slot-0 snd_hda_intel
options snd_hda_intel model=auto
Then 'alsactl init'. Problem solved.

I found snd_hda_intel with lsmod. In fact, I could not have done it if I had not read this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Slackware 13.1 x86_64 SavoTU Slackware 4 10-02-2010 10:37 AM
ipm timed out error on Red Hat 2.6.9-67.0.22.ELsmp #1 SMP x86_64 x86_64 x86_64 GNU/L bellnarm Linux - Newbie 0 07-07-2009 04:36 PM
Getting Sound to work with intel8x0 in Slackware 12 - alsaconf finds hda-intel thethinker Slackware 11 01-26-2008 07:30 PM
Slackware 10, sound works only with alsaconf SyBorg Slackware 10 09-08-2004 04:48 PM
alsaconf fails in Slackware 10, worked in 9.1 MDesigner Slackware 8 06-25-2004 05:28 PM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration