LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-13-2004, 01:13 PM   #1
SyBorg
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware 10 KDE 3.2.3
Posts: 7

Rep: Reputation: 0
Slackware 10, sound works only with alsaconf


Strange problem here

I installed Slackware 10.0 doing FULL install.

Launched 'alsaconf', sound working ok with shell (with 'mpg123 somemusic.mp3')
Launched KDE, sound is off
Launched konsole, made the 'alsaconf' again, sound working in KDE.

Now I'm in KDE as user, no sound, make alsaconf as root in konsole, sound working again.

I tried checking the files&links permissions in /dev/, but all seems ok to me, mixer*, dsp*, midi* and other are all owned by root,audio

Motherboard Asus A7V8X-X
Soundcard Sound Blaster Audigy (rev 03)
Linux Slackware 10, 2.4.26

TIA for any tip, I already looked in the forum but found nothing like this
 
Old 07-13-2004, 02:19 PM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Did you try alsamixer to set your audio channels ?
 
Old 07-13-2004, 02:27 PM   #3
SyBorg
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware 10 KDE 3.2.3
Posts: 7

Original Poster
Rep: Reputation: 0
Yes I did, all volumes are up : sounds comes up only by running 'alsaconf' (with 4 'Enter' keypress).

Now I'm checking the /dev/dsp* and mixer* again, I saw that the stat says '662' opposed to '666' as per the sticky post about Slack installation.

Update :
Just tried it, no chance. Still I have to 'alsaconf' and nothing else to get sounds in KDE.

I saw this in X :

kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

Last edited by SyBorg; 07-13-2004 at 02:35 PM.
 
Old 07-13-2004, 02:42 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Try copy all alsa modules parameters in your /etc/modules.conf to your /etc/modprobe.conf as modprobe looks in modprobe.conf with kernel 2.6.

Try rm /etc/asound.state if that helps.

Look at the output of lsmod to see if are modules are loaded. Is your /etc/rc.d/rc.hotplug file executable ?
 
Old 07-13-2004, 05:43 PM   #5
drxsmurf
Member
 
Registered: Oct 2003
Location: Texas
Distribution: Mandrake 9.2, Slackware 10.0
Posts: 51

Rep: Reputation: 15
Quote:
Originally posted by SyBorg
I saw this in X :
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
kmixctrl: ERROR: Alsa mixer cannot be found.
Please check that the soundcard is installed and the
soundcard driver is loaded.
kmixctrl:
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe [/B]
Where did you see that in X?
I have the exact same problem that you are having. I also use KDE and am unable to keep sound working after a reboot or reloading X.
 
Old 07-14-2004, 12:51 AM   #6
SyBorg
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware 10 KDE 3.2.3
Posts: 7

Original Poster
Rep: Reputation: 0
Now I'm confused, my sound is working again

Here's what I did

- started X, no sound
- ran alsaconf, sound's back
- listened to some music, checked some video while playing with the mixer/alsa tools
- went to bed (Italy here)

This morning I started KDE (as user, not as root) to see if there was any hint for me.... bingo?!? Sound works without forcing alsaconf?!? Maybe I have set up something 'magic' in the mixer?



drxsmurf : startx &> ~/x.log then open up x.log with kedit/kwrite/yourfavoriteeditor
 
Old 07-14-2004, 04:48 AM   #7
drxsmurf
Member
 
Registered: Oct 2003
Location: Texas
Distribution: Mandrake 9.2, Slackware 10.0
Posts: 51

Rep: Reputation: 15
Quote:
Originally posted by SyBorg
This morning I started KDE (as user, not as root) to see if there was any hint for me.... bingo?!? Sound works without forcing alsaconf?!? Maybe I have set up something 'magic' in the mixer?
Nothing wrong with good luck

I notice that whenever I run 'alsaconf', the last window presented during the configuration mentions a program called 'rcalsasound start'. Maybe this should be added to rc.d or something like that? I don't really know. Congrats on your success, though
 
Old 07-14-2004, 10:20 AM   #8
hkctr
Member
 
Registered: Sep 2003
Posts: 106

Rep: Reputation: 15
Run 'alsactl store' after alsamixer to store your sound settings. alsactl restore is run automatically (/etc/rc.d/rc.alsa) when you boot and restores your previously saved sound settings.
 
Old 08-03-2004, 07:12 AM   #9
rekcals
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Have a look at /dev/dsp and /dev/audio, my old ones pointed to /dev/dsp0 etc which no longer worked, I needed /dev/dsp1.
 
Old 09-08-2004, 04:44 PM   #10
khellendros
LQ Newbie
 
Registered: Sep 2004
Posts: 5

Rep: Reputation: 0
What I had to do, was go into kmixer and tell it not to reload its settings on startup. It kept overwriting my alsa defined settings. Works well now!
 
Old 09-08-2004, 05:48 PM   #11
THEHERO
Member
 
Registered: Aug 2003
Distribution: Debian Testing
Posts: 165

Rep: Reputation: 30
Quote:
Originally posted by khellendros
What I had to do, was go into kmixer and tell it not to reload its settings on startup. It kept overwriting my alsa defined settings. Works well now!


Exactly what I did except I turned off Kmixer completely.

Last edited by THEHERO; 09-08-2004 at 05:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound works with knoppix CD but not Slackware bgryderclock Slackware 11 08-23-2005 10:01 AM
ALSA works only when I run alsaconf aneeshm Linux - Software 11 08-10-2004 02:58 PM
Sound only works as root in Slackware DiscoGranny Linux - Software 9 06-14-2004 10:11 PM
Sound works until restart (Slackware 9.0) nwhite Linux - Hardware 7 05-21-2004 05:58 PM
Slackware sound works only every other time, what the heck? bobthebat Linux - General 3 11-01-2001 08:29 PM


All times are GMT -5. The time now is 03:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration