LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2005, 07:38 AM   #1
murphy23
LQ Newbie
 
Registered: Mar 2004
Location: Yorkshire, England
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Perl CPAN Problem


I recently did a

swaret --update

swaret --upgrade

Which upgraded my Perl installation to 5.8.6.

This broke my Apache mod perl and spam assassin because of non matching version numbers.

I've tried to use

perl -MCPAN -e shell

to upgrade these, but my CPAN install can no longer connect to the net using LWP, and keeps falling back to a package list from October last year. What can I do to get CPAN online once again?

Thanx in advance
 
Old 01-19-2005, 10:45 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Did you try to run cpan without arguments from your root account (su -) ?

[edit]
Maybe more luck with (from your root account) :
perl -MCPAN -e 'install Bundle::CPAN'

See if this fixes your mod problems

Last edited by keefaz; 01-19-2005 at 11:06 AM.
 
Old 01-21-2005, 04:58 AM   #3
murphy23
LQ Newbie
 
Registered: Mar 2004
Location: Yorkshire, England
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 0
Stange.

I tried the

perl -MCPAN -e 'install Bundle::CPAN'

as root, but it just sits there, unable to connect and eventually falls back to the old package list. Maybe I need to reinstall perl.
 
Old 01-21-2005, 06:35 AM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Did you install lynx package ?
 
Old 01-24-2005, 07:03 AM   #5
murphy23
LQ Newbie
 
Registered: Mar 2004
Location: Yorkshire, England
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 0
Yes, lynx and links installed. It seems that CPAN cannot access the network at all.

Going to reinstall perl i think...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
perl modules problems CPAN tardigrade Linux - Software 6 09-02-2004 12:29 PM
perl -MCPAN -e shell # PROBLEM FINDING CPAN site Louis_Carole Linux - Software 1 08-26-2004 05:55 PM
Canīt download perl modules with cpan emilioestevezz Linux - Networking 1 08-25-2004 09:51 AM
perl CPAN LinFreak! Slackware 3 01-03-2004 08:16 AM
Perl:CPAN problem on startup jester_69 Linux - Software 0 10-04-2003 08:29 PM


All times are GMT -5. The time now is 07:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration