Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 07-17-2006, 11:23 AM   #1
LQ Newbie
Registered: Jul 2006
Posts: 3

Rep: Reputation: 0
Unhappy PC does not power-off after shutdown

Hi there.

When i shutdown my notebook it does not power off automatically. Everytime i have to turn it off seperatly with the power-button.

Does somebody know what to change, so that it will work corectly?

Old 07-17-2006, 11:29 AM   #2
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
What distribution are you using? You may try booting with the kernel argument acpi=off or acpi=force to see if those help. (Some notebooks have buggy acpi that require these)
Old 07-17-2006, 11:34 AM   #3
LQ Guru
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
In Slackware, you have to edit /etc/rc.d/rc.modules to enable APM.

Specifically, uncomment the last line of this section:

#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
#/sbin/modprobe apm
Old 07-17-2006, 11:40 AM   #4
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Oops, sorry that I missed that this was the slack forum. Got to the thread via the Zero-replies search.
Old 07-18-2006, 09:07 AM   #5
Registered: Jul 2006
Location: Suburbs of Lisbon, Portugal
Distribution: Slackware, FreeBSD
Posts: 70

Rep: Reputation: 16

If you didn't compile the kernel yourself, then chances are you chose 'bare.i' for the installation and for booting afterwards. 'bare.i' carries only APM support and needs '/sbin/modprobe apm' to be enabled in '/etc'rc.modules' .

The ideal, though, would be to have used 'bareacpi.i' or else recompile your kernel with ACPI support - assuming your hardware supports it, which is the case for almost everything from pIII and over.

I hope this info helps...



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power off after shutdown dukeem Slackware 15 11-30-2010 10:08 AM
Shutdown and power off bwtoh Linux - Newbie 4 11-02-2006 02:48 PM
Shutdown does not power off Richie55 Mandriva 9 07-03-2006 02:33 AM
Shutdown could not power off satimis Debian 13 02-14-2004 11:05 AM
Shutdown with power button hriosm Linux - Hardware 4 06-06-2003 02:43 PM

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration