LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-21-2003, 07:22 AM   #1
dukeem
LQ Newbie
 
Registered: Jul 2003
Posts: 3

Rep: Reputation: 0
Power off after shutdown


I run: "shutdown -h now"; I get the message "power down" (or power off) but my computer doesn't turn off - I have to shut down it manually. Can someone tell me, how to get my slackware9-box to turn off?

dukeem
 
Old 07-21-2003, 07:29 AM   #2
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Re: Power off after shutdown

Quote:
Originally posted by dukeem
I run: "shutdown -h now"; I get the message "power down" (or power off) but my computer doesn't turn off - I have to shut down it manually. Can someone tell me, how to get my slackware9-box to turn off?

dukeem
You need to enable the APM module. Do a 'modprobe apm' and then it should work. To enable the apm permanently, look for the line in /etc/rc.d/rc.modules which refers to apm (its something like #/sbin/modprobe apm and remove the #. 'lsmod' should show the apm module running if all is well. Good luck and happy slacking.

munkeh
 
Old 07-21-2003, 07:56 AM   #3
mason75
LQ Newbie
 
Registered: Jul 2003
Location: Cologne, Germany
Distribution: slack 9
Posts: 11

Rep: Reputation: 0
on my system i'd got the same error. it seems that apm doesn't function, so i decided to compile a new kernel using acpi which works pretty good for me.
 
Old 07-23-2003, 05:33 AM   #4
dukeem
LQ Newbie
 
Registered: Jul 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Re: Re: Power off after shutdown

Quote:
Originally posted by reclusivemonkey
You need to enable the APM module. Do a 'modprobe apm' and then it should work. To enable the apm permanently, look for the line in /etc/rc.d/rc.modules which refers to apm (its something like #/sbin/modprobe apm and remove the #. 'lsmod' should show the apm module running if all is well. Good luck and happy slacking.
I tried it and it works! Thx!
 
Old 07-23-2003, 08:44 AM   #5
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Same here. APM wouldn't work, but ACPI with a new kernel works.
 
Old 07-24-2003, 09:07 AM   #6
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
root@linux:~# modprobe apm
/lib/modules/2.4.20/kernel/arch/i386/kernel/apm.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/arch/i386/kernel/apm.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/arch/i386/kernel/apm.o.gz: insmod /lib/modules/2.4.20/kernel/arch/i386/kernel/apm.o.gz failed
/lib/modules/2.4.20/kernel/arch/i386/kernel/apm.o.gz: insmod apm failed

What should I do?
 
Old 07-24-2003, 11:53 PM   #7
labr@
Member
 
Registered: May 2003
Location: Dallas, TX
Distribution: Slackware. (There are others?)
Posts: 46

Rep: Reputation: 16
rc.modules

vi /etc/rc.d/rc.modules
uncomment the line for the APM (save and close rc.modules)
insmod apm
lsmod (it should be listed apm)
shutdown -h now
It will power off on its' own now.

Regards,
 
1 members found this post helpful.
Old 07-24-2003, 11:53 PM   #8
labr@
Member
 
Registered: May 2003
Location: Dallas, TX
Distribution: Slackware. (There are others?)
Posts: 46

Rep: Reputation: 16
rc.modules

vi /etc/rc.d/rc.modules
uncomment the line for the APM (save and close rc.modules)
insmod apm
lsmod (it should be listed apm)
shutdown -h now
It will power off on its' own now.

Regards,
 
1 members found this post helpful.
Old 07-25-2003, 01:54 AM   #9
C++freak
Member
 
Registered: Apr 2002
Location: NB, Canada
Distribution: Gentoo
Posts: 180

Rep: Reputation: 30
I am curious, what does apmd do, and is it in the init scripts by default, and do I need it to have my machine power down?
Thanks
 
Old 07-25-2003, 03:24 AM   #10
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Quote:
Originally posted by C++freak
I am curious, what does apmd do, and is it in the init scripts by default, and do I need it to have my machine power down?
Thanks
As far as I recall, APM stands for Advanced Power Management??? apmd is the daemon, i.e. the program that monitors the apm from your computer's BIOS. All that means is that if you want your PC to power itself off when you shutdown, it needs to be running! Its more vital on laptops where it also helps with battery management.

I think I've got that right...
 
Old 11-30-2010, 05:51 AM   #11
MPRT
Member
 
Registered: Apr 2010
Location: Rio de Janeiro
Distribution: Ubuntu, Fedora, Slackware
Posts: 30

Rep: Reputation: 0
Dear,

I have the same problem mentioned here.

I verified the line (#/sbin/modprobe apm) for APM in rc.modules (/etc/rc.d/rc.modules) and it really was commented. I uncommented it and tried to use the following command:

“insmod apm”

And the result I got is:

"insmod: can't read 'apm': No such file or directory"

How can I deal with? Because I guess I need to do it before use the command "modprobe apm". Could you help me please?

Thanks in advance!

Best regards,
MPRT
 
Old 11-30-2010, 05:57 AM   #12
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by MPRT View Post
Dear,

tried to use the following command:
“insmod apm”

And the result I got is:
"insmod: can't read 'apm': No such file or directory"

Because I guess I need to do it before use the command "modprobe apm".
Er no.

insmod requires you to give the full path to the module and you must have any modules that the module depends on loaded already

modprobe is the magic baby that does all the hard work for you

tl;dr use modprobe
 
1 members found this post helpful.
Old 11-30-2010, 06:19 AM   #13
MPRT
Member
 
Registered: Apr 2010
Location: Rio de Janeiro
Distribution: Ubuntu, Fedora, Slackware
Posts: 30

Rep: Reputation: 0
modprobe doesn't work

Dear Wildwizard,

thank you for the post!

In fact, I would like to use the command “shutdown –h now” to turn off the computer and power it down without need to handle it.

However it doesn’t work in Slackware 13 with the single board computer I’ve been using.

So, I tried to use the command “modprobe apm” but the result is:
"FATAL: Error inserting apm (/lib/modules/2.6.29.6-pm/kernel/arch/x86/kernel/apm.ko): No such device”

After that I verified the line for APM was commented in rc.modules. I uncommented it and tried to use “insmod apm” but it also doesn’t work.

I’m learning about Linux and I like it very much but I still don’t have the knowledge to solve this problem.

After the FATAL error what can I do?

Thanks!
MPRT
 
Old 11-30-2010, 08:50 AM   #14
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I don't think APM is supported anymore, try instead to put 'pci=nomsi' in your /etc/lilo.conf append line, then run 'lilo' as root then reboot, then try shutting down.

Code:
append=" vt.default_utf8=0 pci=nomsi"
Do you have the nvidia driver installed ? Just wondering.
 
1 members found this post helpful.
Old 11-30-2010, 09:52 AM   #15
MPRT
Member
 
Registered: Apr 2010
Location: Rio de Janeiro
Distribution: Ubuntu, Fedora, Slackware
Posts: 30

Rep: Reputation: 0
Dear H_TeXMeX_H,

thank you for the post!

I did append=" vt.default_utf8=0 pci=nomsi" in lilo.conf file, then I run lilo.

After that, when I try to use the command "shutdown -h now", the last lines are showed:

md: stopping all md devices.
Shutdown: hdb
System halted.


Just to be clear, the system uses hdb instead hda.

After system halted, I need to handle it by button.

In any case, thanks for all information!

Regards,

MPRT
 
Old 11-30-2010, 09:56 AM   #16
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331

On Intel standard architecture machines the power off function is handled by acpi. (Advanced Configuration and Power Interface). This is the replacement for apm. (Advanced Power Management).

So your kernel needs to load the acpi module or have it compiled into it.

http://www.linux.org/docs/ldp/howto/...WTO/index.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown and power off bwtoh Linux - Newbie 4 11-02-2006 02:48 PM
No power down after shutdown (Mandrake) JohnA Linux - Hardware 14 02-24-2005 01:47 AM
Shutdown could not power off satimis Debian 13 02-14-2004 11:05 AM
Power Button for Shutdown gokul Linux - Hardware 4 01-24-2004 12:40 PM
Shutdown with power button hriosm Linux - Hardware 4 06-06-2003 02:43 PM


All times are GMT -5. The time now is 11:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration