LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-29-2007, 10:12 AM   #1
Denisius
Member
 
Registered: Aug 2007
Location: Israel
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Mouse scrolling problem


I'm trying to get my mouse to use the middle button to scroll, i added 'Option "ZAxisMapping" "4 5"' to my xorg.conf, but it still doesn't work.

Here is the relevant xorg.conf:

Quote:
Section "InputDevice"

# Identifier and driver
# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:
# Option "Protocol" "Auto"
# The available mouse protocols types that you can set below are:
# Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
# Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
# MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
# ThinkingMouse ThinkingMousePS/2 Xqueue
# which is usually a symbolic link to the real device.
# Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/ttyS1"
# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
# Option "Protocol" "Xqueue"
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
# Option "BaudRate" "9600"
# Option "SampleRate" "150"
# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"
# ChordMiddle is an option for some 3-button Logitech mice
# Option "ChordMiddle"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
# The mouse device. The device is normally set to /dev/mouse,
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
# Option "Device" "/dev/psaux"
EndSection
 
Old 10-29-2007, 10:18 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,910

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Quote:
Option "Protocol" "PS/2"
You must change the above to:
Code:
Option "Protocol"    "imps/2"
 
Old 10-29-2007, 10:29 AM   #3
Denisius
Member
 
Registered: Aug 2007
Location: Israel
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
Alright, it works now. Thanks!

One more question, how can i shut down my computer in KDE?
 
Old 10-29-2007, 10:35 AM   #4
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
I think you would need to start KDE from kdm to accomplish that.
 
Old 11-01-2007, 10:30 AM   #5
$in
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware current
Posts: 27

Rep: Reputation: 15
edit this line in /etc/inittab

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

you probably have 3 instead of 4, if so change it to 4. that way your system will boot up in X and you'll see kdm. so when you wanna log out of kde you'll get the shutdown and reboot options.
 
Old 11-02-2007, 08:06 AM   #6
Unr3a164
Member
 
Registered: Apr 2007
Distribution: Slackware 13.1 + Ubuntu 9.04
Posts: 143

Rep: Reputation: 16
Quote:
Originally Posted by Denisius View Post
Alright, it works now. Thanks!

One more question, how can i shut down my computer in KDE?

Go to Konsole and type in:

init 0

Hit enter, and watch your computer shut down.
 
Old 11-02-2007, 09:03 AM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, the more conventional way is 'shutdown -h now'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Side scrolling Apple mouse problem. slackergate5 Slackware 1 08-20-2006 06:23 AM
KDE Mouse / Scrolling Problem PeterKlancic Linux - General 2 02-15-2005 01:11 PM
Mouse not scrolling? xtremcoder Linux - Hardware 2 12-11-2003 12:59 AM
No scrolling for mouse :( GloVe Linux - Hardware 1 10-09-2003 02:45 PM
Mouse Scrolling problem (I have searched the threads too) ShibbyLinux Linux - General 6 04-12-2002 09:52 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration