Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 08-19-2006, 05:41 PM   #1
LQ Newbie
Registered: Jul 2005
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
Side scrolling Apple mouse problem.

I just got a new mouse that has the side scrolling function. The mouse is none other than Apple's "mighty mouse." Anyway regular scrolling works fine, but side scrolling doesn't. To remedy this problem I added
Option "Buttons" "7" and Option "ZaxisMapping" "6 7"
to my xorg.conf file, But no success. Then I tried to manually set the buttons on the mouse with
xmodmap -e "pointer = 1 2 3 6 7 4 5"
Then I used xev to check the button assignments, but buttons 6 and 7 still didn't work. The thing is that xev doesn't register any button events when I use the side scroll buttons. It seems unlikely that this is a driver problem because other mice with several "extra" buttons work fine in Linux. Does anyone have a working configuration for this mouse?

My xorg.conf:
Option "Protocol" "IMPS/2"
Option "Buttons" "7"
Option "ZaxisMapping" "4 5"
Option "ZaxisMapping" "6 7"
Device info:
kernel: usb 1-2: USB disconnect, address 3
kernel: usb 1-2: new low speed USB device using uhci_hcd and address 5
kernel: usb 1-2: Product: Apple Optical USB Mouse
kernel: usb 1-2: Manufacturer: Mitsumi Electric
kernel: input: USB HID v1.10 Mouse [Mitsumi Electric Apple Optical USB Mouse] on usb-0000:00:1d.0-2
and lsusb:
Bus 001 Device 005: ID 05ac:0304 Apple Computer, Inc.
Old 08-20-2006, 07:23 AM   #2
Senior Member
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
A quick google turned up this


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scrolling Help squee23 Linux - Hardware 1 03-07-2006 11:34 PM
Mouse Scrolling nin881 Slackware 2 06-02-2005 11:46 PM
KDE Mouse / Scrolling Problem PeterKlancic Linux - General 2 02-15-2005 02:11 PM
Mouse not scrolling richcoosa19 Linux - Hardware 4 11-11-2002 09:23 AM
Mouse Scrolling problem (I have searched the threads too) ShibbyLinux Linux - General 6 04-12-2002 10:52 AM

All times are GMT -5. The time now is 04:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration