LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2012, 02:30 PM   #1
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Rep: Reputation: 40
Mouse not working on xfce slackware 14


I have googled this for many hours and can not find an answer, I am using xfce slack 14. This is my wife's computer, when she logs into slack the mouse is very jumpy and the keyboard does not work at all. I have switched the mouse, kboard, etc and tried so many things found on the net that I can not even remember them all. I can log in as root or guest and everything works as normal. I have used slackware for many years but I have had very poor luck tracing this down. If anyone has a suggestion I would sure appreciate the help. Hp 51 pentium 4 at 2.53 768 meg memory Slackware 14
 
Old 11-07-2012, 02:58 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hi,

does the computer boot to runlevel 3 or 4? Can your wife use the mouse with another windowmanager e.g. fluxbox? Which files are in /etc/X11/xorg.conf.d/?
Are there any mousesettings configured with XFCE?

Markus
 
Old 11-07-2012, 03:12 PM   #3
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
Thanks for the quick reply! It boots into run level 3 and the mouse and kboard works fine as root xfce & guest xfce. I am not at home now but will check the other in a few minutes. I do not see any errors with dmesg or system log.
 
Old 11-07-2012, 03:35 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
When the computer boots to runlevel 4, there are different scripts sourced (by the login-manager). You could in runlevel 3 as root execute "telinit 4" and then start an XFCE-session. If it works this way, it is very likely that the configuration in your wife's homedirectory is messed up.

Markus
 
Old 11-07-2012, 04:24 PM   #5
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
Which files are in /etc/X11/xorg.conf.d/?
It is empty

You could in runlevel 3 as root execute "telinit 4" and then start an XFCE-session.
When I do that and log in with her login it is just the same Jumpy mouse & no keyboard
 
Old 11-07-2012, 04:30 PM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, one can copy the files from /usr/Share/X11/xorg.conf.d/ into /etc/X11/xorg.conf.d/
Normally this is useful if one needs another keyboard-layout, but there are also configfiles for the mouse and evdev. But note that if you have a /etc/X11/xorg.conf file, it will override the settings in /etc/X11/xorg.conf.d/

I'd try out another windowmanager, when logged in as your wife, use xwmconfig and select for example fluxbox or twm or what ever.

Markus
 
Old 11-07-2012, 06:00 PM   #7
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
I set the wm to fluxbox and it works fine, no problems whatsoever. I copied all files from usr/share/x11/xorg.conf.d over
to /etc/X11/xorg.conf.d/ and renamed xorg.conf to xorg.conf.old and still had the same results. I believe it is something
to do with xfce.
 
Old 11-08-2012, 01:06 AM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
The configuration for XFCE resides in ~/.config/xfce4. One could delete (or rename) this folder and then (if hopefully the problems with keyboard and mouse are gone) configure XFCE from scratch.

If you've upgraded from earlier versions of XFCE (or Slackware) and use still the old configuration, couldn't it be possible, that the configuration is no longer working?

Markus
 
Old 11-08-2012, 08:30 AM   #9
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
I sure appreciate your help on this, I will try that when I get home this afternoon . My wife is using it with fluxbox so everything will be ok until it is repaired.
 
Old 11-09-2012, 08:10 PM   #10
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
I did as Marcus suggested except I went to /home/wife/.config/xfce4 and erased xfce4 and copied the xfce4 from guest over to
/home/wife/.config/. As of now the thing is working fine, but I am not ready to consider in solved. The first thing I tried was just renaming the /home/wife/.config/xfce4 to xfce.old and letting it write a new one, but that failed to work any better.
I sure appreciate the help on this, I will try it a day or two and see if it is ok.

Last edited by zrdc28; 11-09-2012 at 08:12 PM. Reason: add on
 
Old 11-11-2012, 11:05 PM   #11
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Original Poster
Rep: Reputation: 40
Everything seems to be working, so I will mark this one solved, thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount of audio CD and play not working Slackware 13.37 64, XFCE and KDE saycheese Slackware 7 03-10-2012 06:55 AM
Slackware 13.37 xfce not working on Old PC rashv Linux - Desktop 7 03-08-2012 12:48 PM
Mouse cursor corruption problem xfce Slackware 64 bit current (and older versions) Ook Slackware 5 02-15-2012 03:53 PM
My mouse cursor is half gone and there is no toolbar in Slackware 13.1 with XFCE ? ducksong Slackware 5 08-27-2010 08:10 AM
Slackware 13.0 + radeon - mouse cursor corruption problem in xfce dragon_cb_cz Slackware 10 11-02-2009 01:21 PM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration