LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-23-2011, 09:58 AM   #1
LQ Guru
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Minor problem with SlackBuilds E17 upgrade for Edje

Got the new upgrades to E17 today
But Edje would not build complaining that there was no "ecore-evas" and "ecore-file".
Found this here

added "--enable-ecore-evas" and "--enable-ecore-file" to Slackbuild and tried to build it, but it quit saying error no such options available, etc

then I manually did the ./configure blah blah from terminal and it configured fine, don't know why editing the Slackbuild didnt work, maybe I edited it wrong??

Code: line 65: --enable-ecore-file: command not found
checking for EDJE... no
configure: error: Package requirements (
    eina >= 1.1.0
    eet >= 1.5.0
    evas >= 1.1.0
    ecore >= 1.1.0
    ecore-evas >= 1.1.0
    ecore-file >= 1.1.0
    embryo >= 1.1.0
   ) were not met:

No package 'ecore-evas' found
any help appreciated!
Old 12-23-2011, 05:09 PM   #2
Registered: Nov 2011
Posts: 78

Rep: Reputation: 11
Those (evas & ecore) are dependencies of edje.

You have to build them before building edje. You can't just enable them in the build file because they don't exist on your system.
Old 12-23-2011, 09:11 PM   #3
LQ Guru
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Original Poster
Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
OK, seems it's been fixed and updated

@R3V0LV3R, the problem was that ecore was not set by default in ./configure options to enable ecore-evas and ecore-file, both of which are required by edje
and yes, obviously they must be in the build file for ecore to be built with those options, they aren't separate packages.
anyway, problem solved!

Last edited by linus72; 12-23-2011 at 09:13 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
e17: source install, edje cannot find lua, ./ fails. Sum1 Linux - Desktop 8 07-28-2010 04:18 AM
e17: EFL's are built/installed but e17-svn complains no Sum1 Linux - Desktop 6 08-24-2009 07:29 PM
E17 compile error edje cannot find "brushed.png" inkysplat Linux - Software 1 01-06-2006 01:48 AM
upgrade slackware build e17 enlightenment phatbastard Slackware 1 12-03-2005 06:11 PM
Minor kernel upgrade kaon Linux - Software 1 08-18-2004 09:34 AM

All times are GMT -5. The time now is 04:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration