LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-16-2009, 08:15 AM   #1
Sum1
Member
 
Registered: Jul 2007
Distribution: Slackware and Gentoo
Posts: 235

Rep: Reputation: 25
e17: source install, edje cannot find lua, ./autogen.sh fails.


1. Trying to install e17 core using e17 installation wiki: http://wiki.enlightenment.org/index....rce_Repository

2. Installing all the svn sources in order as stated in wiki.

3. I get to installing edje and upon ./autogen.sh it fails due to not finding lua

4. I installed lua 5.1.4 from source and I can start lua by doing ~$/usr/local/bin/lua

5. I try again to ./autogen.sh edje-svn and it fails -- cannot find lua path or installation

6. How do I tell edje-svn configuration script where lua is installed.

Thanks for your time and help.
 
Old 08-16-2009, 12:15 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,910

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Since you have installed a dependency (lua) from source, you have to change the default PATH and LD_LIBRARY_PATH accordingly, so it can be found by the autogen script.
Code:
PATH=/usr/local/bin:$PATH
LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
export PATH LD_LIBRARY_PATH
./autogen.sh
 
Old 08-16-2009, 04:46 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
What OS are you using ? Most ( if not all) current home systems do not use /usr/local

when you built lua you needed to add "--prefix=/usr" to ./configure. This will cause lua to beinstalled in the system default path
see : from the lua build folder
Code:
./configure --help
for the configure options
 
Old 08-16-2009, 07:08 PM   #4
Sum1
Member
 
Registered: Jul 2007
Distribution: Slackware and Gentoo
Posts: 235

Original Poster
Rep: Reputation: 25
Quote:
Originally Posted by bathory View Post
Since you have installed a dependency (lua) from source, you have to change the default PATH and LD_LIBRARY_PATH accordingly, so it can be found by the autogen script.
Code:
PATH=/usr/local/bin:$PATH
LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
export PATH LD_LIBRARY_PATH
./autogen.sh
Thanks Mr. Bathory.
I tried this using /usr/local/bin and /usr/local/lib and still no go.
I continue to receive the following error:


checking whether to build edje_cc... yes
checking for location of Vim data files... /usr/share/vim
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking whether to build documentation... yes
checking for doxygen... yes
checking for a Python interpreter with version >= 2.5... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LUA... no
checking for LUA... no
checking for LUA... no
checking for LUA... no
configure: error: unable to find Lua
bash-3.1#
 
Old 08-16-2009, 07:17 PM   #5
Sum1
Member
 
Registered: Jul 2007
Distribution: Slackware and Gentoo
Posts: 235

Original Poster
Rep: Reputation: 25
Quote:
Originally Posted by John VV View Post
What OS are you using ? Most ( if not all) current home systems do not use /usr/local

when you built lua you needed to add "--prefix=/usr" to ./configure. This will cause lua to beinstalled in the system default path
see : from the lua build folder
Code:
./configure --help
for the configure options
Thanks for the reply Mr. VV.
I'm using Slackware linux ver. 12.2.

I was looking for exactly what you mentioned regarding the ./configure options, and I thought it was very strange too, there was no mention of ./configure in the INSTALL instructions that unpacked with Lua 5.1.4 tarball.

The INSTALL file states only:
Building Lua on Unix systems should be very easy. First do "make" and
see if your platform is listed. If so, just do "make xxx", where xxx
is your platform name. The platforms currently supported are:
aix ansi bsd freebsd generic linux macosx mingw posix solaris

. . . .
If you want to build and install Lua in one step, do "make xxx install",
where xxx is your platform name.
- - - - - - - - - - - -

I let Lua install to the default directories it has set in the make file. I tested the Lua install by doing ~$make test and it looked fine:

bash-3.1# make test
src/lua test/hello.lua
Hello world, from Lua 5.1!
bash-3.1#


Any other ideas.
All suggestions followed up on and greatly appreciated.
 
Old 08-16-2009, 08:32 PM   #6
Sum1
Member
 
Registered: Jul 2007
Distribution: Slackware and Gentoo
Posts: 235

Original Poster
Rep: Reputation: 25
SOLVED
------

Built Lua using package from Slackbuilds.org
I was able to install the edje library for e17.

Of course, my luck did not last very long....upon trying to build e17 from source I got a compilation error about, guess what -- /usr/lib/liblua.so

But now we're on to a new thread so I'll end this one.
 
Old 08-16-2009, 11:00 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
when ever i build from source( most of the time ) i read the output of " ./configure --help " . Even on code i build all the time -- to see what has changed--
A lot of code defaults to /usr/local ( good for the office or a home network , but not so good on a single system) -- google the subject--

i always add --prefix=/usr if i am installing it to / .most times i install it on a different partition so mine dose very

also it is a VERY GOOD habit to get into to check "configure --help" , README , and INSTALL .
Some code has a premade Makefile , if that is the case then READ THE MAKEFILE . and edit the makefile to your system.
 
Old 10-19-2009, 12:10 PM   #8
knott
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Rep: Reputation: 1
Hi, i struggled with the exact problem myself.. after a bit of asking and a big thanks to "Sachiel". It was not more worse then to move/copy the lua.pc file created inside the src directory when you have compiled lua. Then move it to /usr/lib/pkgconfig
 
1 members found this post helpful.
Old 07-28-2010, 03:18 AM   #9
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 408

Rep: Reputation: 30
thanks knott, not to dig up an old thread but since building mysql workbench requiring lua i figured i would comment. lua.pc is in the etc directory of the lua sources not the src directory, but the jist of your post fixed my issue of pkgconfig flipping out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling GLUT binding for Lua from source on ubuntu gvp87 Linux - Software 1 02-07-2008 10:56 AM
autogen.sh fails: libtool.m4 / ltmain.sh version mismatch jrtayloriv Linux - Software 1 01-09-2008 01:06 PM
E17 compile error edje cannot find "brushed.png" inkysplat Linux - Software 1 01-06-2006 12:48 AM
Compiling Evas (E17) - /usr/bin/ld: cannot find -lvga victorhooi Linux - Software 1 10-20-2005 04:33 PM
./autogen.sh Sheepshaver fails to detect xorg DGA extension Cogvos Linux - Software 1 04-01-2005 10:52 PM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration