LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Closed Thread
 
Search this Thread
Old 01-09-2011, 06:01 PM   #1
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Rep: Reputation: 101Reputation: 101
mic seems to be there, but wont record for some reason


Tried to use my laptop's built-in mic for the first time today, and it doesn't seem to be working. First tried to record with guvcview, which will capture video but no audio. It's dropdown box for audio input device shows an item named
Code:
HDA Intel: ALC663 Analog (hw:0,0)
In alsamixer I've set mic to max volume and unmuted. And I tried launching audacity as root to record, and again got nothing. This is as far as I was able to get with Google. Anyone able to offer some advice on how to turn on my mic?
 
Old 01-09-2011, 10:12 PM   #2
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
Try using rexima.

In Rexima, boost "Mic" and "IGain"
 
Old 01-10-2011, 03:12 AM   #3
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 682

Rep: Reputation: 279Reputation: 279Reputation: 279
Sound Support

Greetz
From anything I see this is reported as a bug(s) as of late 2009. It seems some have been fixed but others have not. In my experience this is a common problem with all Linux sound servers and open source. Hardware support can be difficult and though it is improving, still many manufacturers are slow to release needed information. This is especially problematic when fundamental changes in hardware take place such as the increased adoption of HDMI. Certainly it is still true that "given enough eyes all bugs are shallow" but in very specific hardware support the process can be slow.

IMHO The best an average user can do is
1) look for an "asound.rc" file at alsa-projects that addresses the problem
2) upgrade kernel (if a newer one has a newer alsa release)
or
3) upgrade alsa from source
or
4) keep track of OSS4 progress and switch if support comes to it first

Good luck

Last edited by enorbet; 01-10-2011 at 03:15 AM.
 
Old 01-10-2011, 03:21 AM   #4
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 241

Rep: Reputation: 86
Quote:
Originally Posted by Cultist View Post
In alsamixer I've set mic to max volume and unmuted.
Set mic to min volume and muted. Instead, put CAPTURE to max and set INPUT SOURCE to MIC.
 
Old 01-10-2011, 03:23 AM   #5
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 241

Rep: Reputation: 86
Quote:
Originally Posted by Gavin Harper View Post
Try using rexima.
rexima is for oss.
 
Old 01-10-2011, 06:15 AM   #6
unclejed613
Member
 
Registered: Mar 2009
Posts: 322

Rep: Reputation: 26
my alsa mixer has a CAPTURE button for the mic, make sure that's clicked if you don't have a capture button for the mic, you may have to enable it in the mixer setup.
 
Old 01-10-2011, 06:50 AM   #7
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Original Poster
Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by Petri Kaukasoina View Post
Set mic to min volume and muted. Instead, put CAPTURE to max and set INPUT SOURCE to MIC.

k, how do I set input source? I don't see that anywhere
 
Old 01-10-2011, 11:04 AM   #8
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 241

Rep: Reputation: 86
In alsamixer, press Tab to change view until it is Capture. Keep hitting Cursor Right to cycle through the controls. Is there "Input source"?

If you can't find it then you don't have that control. Maybe you could give command amixer and attach its output here so we can see what controls you have.
 
Old 01-10-2011, 12:45 PM   #9
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,247

Rep: Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625
Turn up all volumes in alsamixer (and unmute everything) and turn up all capture controls (by pressing tab in alsamixer, as stated) and try recording. If it doesn't work, try muting the mic(s) in case ALSA is detecting the controls incorrectly. If that still doesn't work, you may have to try passing model options to the snd-hda-intel module. See /usr/src/linux-2.6.33.4/Documentation/sound/alsa/HD-Audio-Models.txt (in the ALC662/663/272 section). The possible models for your card:
Code:
ALC662/663/272
==============
  3stack-dig    3-stack (2-channel) with SPDIF
  3stack-6ch     3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig     6-stack with SPDIF
  lenovo-101e    Lenovo laptop
  eeepc-p701    ASUS Eeepc P701
  eeepc-ep20    ASUS Eeepc EP20
  ecs           ECS/Foxconn mobo
  m51va         ASUS M51VA
  g71v          ASUS G71V
  h13           ASUS H13
  g50v          ASUS G50V
  asus-mode1    ASUS
  asus-mode2    ASUS
  asus-mode3    ASUS
  asus-mode4    ASUS
  asus-mode5    ASUS
  asus-mode6    ASUS
  dell          Dell with ALC272
  dell-zm1      Dell ZM1 with ALC272
  samsung-nc10  Samsung NC10 mini notebook
  auto          auto-config reading BIOS (default)
Search the forums for "snd-hda-intel model" -- you should get *tons* of threads that deal with this. Google led me here -- a simple thread, but there are others that go into greater detail. This one goes into more detail. Autodetection is getting better with each ALSA release (and thus each kernel release), but sometimes it misses the mark and you need to specify the model manually. My old PC had to have the model specified manually for the mic to work (though the sound itself worked using most model options including the default). If it still doesn't work after trying each of those model options, then we will probably need a little more information, but this should get you started anyway.
 
Old 01-10-2011, 01:18 PM   #10
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 211

Rep: Reputation: 43
In alsamixer you need to press F5 to see needed settings.
 
Old 01-10-2011, 02:01 PM   #11
x-alien
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 39

Rep: Reputation: 21
On my Slackware 13.1 (kernel 2.6.37, sound card nVidia HDA) I have the following situation:

Skype identifies the microphone as alsa://default
MEncoder identifies the microphone as alsa://hw:0,0
VLC identifies the microphone as oss://dev/audio

VLC also accepts alsa://hw:0,0, but there is no sound.
 
Old 01-10-2011, 02:03 PM   #12
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Original Poster
Rep: Reputation: 101Reputation: 101
the only settings I can cantrol in alsamixer are Master, PCM, Mic, Capture, and Digital. All of which do nothing for my mic even when at max. There are two others that have no bar, both named S/PDIF. They aren't set to mute though.
 
Old 01-10-2011, 02:29 PM   #13
impert
Member
 
Registered: Feb 2009
Posts: 282

Rep: Reputation: 53
Hi,
I had a bit of trouble with microphones. Here's what works for me:
Quote:
Plug microphone into blue socket (line in) *******************IMPORTANT

Settings for recording:
Alsamixer:
Select F5: All
Master: 100
Line in: Doesn't matter
Mic: ~88% ***************Mic is the only input sliding control that matters.
Phone: Does not matter (?)
IEC958:MM *******************IMPORTANT
IEC958 C, F, R, U: Will all be 0 because of above.
Aux: Does not sem to affect recording.
Analog C, Analog F R S 80% or thereabouts **probably only C matters
Analog Source: Mic *************IMPORTANT Even though the mic is plugged into line in (blue)
Capture feedback: 0 **at any rate, less than about 70
Digital Source: i2s in ***************IMPORTANT
Shared Mic/Line in: Mic in ***************IMPORTANT
Mic is the only sliding control that matters.
Others: Analog Source: Mic Digital Source i2s in Shared Mic Mic in
Microphone MUST BE IN LINE IN in spite of the above.

Sound recorder.
Record as CD quality, lossy .ogg
In Sound preferences/Input:
Output Volume: 100%
Input Volume: unamplified can be 100%
Connector: Analog Microphone/Microphone
choose a device for Sound input: CA0106

/Output:
Choose a device for output: CA0106

In Audacity:
Preferences/Devices:
Host: ALSA
Playback Device: default
Recording Device: default
Channels: 2 (stereo)
Preferences/Playback: (times) 3 1 1 1 15
Preferences/Recording:Overdub ticked, Latency Audio to buffer 100 ms. Latency correction -130 ms.
Sound activated recording not ticked.
Note that my sound card uses the snd_ca0106 module - you seem to use hda_intel; and that I only have analog input and output. The counter-intuitive bit is the fact that the microphone must be plugged into the line in socket, and the "analog source" must be MIC.
Hope this helps.
 
Old 01-10-2011, 02:35 PM   #14
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,247

Rep: Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625Reputation: 625
In any normal circumstance the line in connector should *not* be used for an analog microphone...the signal produced from microphones is very low and must be amplified for it to be usable (and mic inputs usually undergo hardware amplification). Line in inputs are for sources that do not need amplification. If you use a line in input for a microphone you will likely have to use software amplification to boost the signal, which will result in worse quality than simply using the microphone input and setting it up ALSA correctly to use it.
 
Old 01-10-2011, 02:35 PM   #15
Skaperen
Senior Member
 
Registered: May 2009
Location: WV, USA
Distribution: Slackware, CentOS, Ubuntu, Fedora, Timesys, Linux From Scratch
Posts: 1,777
Blog Entries: 20

Rep: Reputation: 115Reputation: 115
Quote:
Originally Posted by enorbet View Post
Greetz
From anything I see this is reported as a bug(s) as of late 2009. It seems some have been fixed but others have not. In my experience this is a common problem with all Linux sound servers and open source. Hardware support can be difficult and though it is improving, still many manufacturers are slow to release needed information. This is especially problematic when fundamental changes in hardware take place such as the increased adoption of HDMI. Certainly it is still true that "given enough eyes all bugs are shallow" but in very specific hardware support the process can be slow.

IMHO The best an average user can do is
1) look for an "asound.rc" file at alsa-projects that addresses the problem
2) upgrade kernel (if a newer one has a newer alsa release)
or
3) upgrade alsa from source
or
4) keep track of OSS4 progress and switch if support comes to it first

Good luck
The many layers of software don't make it any easier. I have a need which involves writing my own program to capture sound samples in real time. Too many APIs makes this a challenge to figure out what to do. It REALLY should have been just a matter of opening the right device, doing some fcntl calls to set it up (that's where a library could help), and then many reads in a loop. If an API would be at least that simple, it would be good enough.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] no record with Mic / Etch ? stu7 Linux - Hardware 2 12-12-2009 01:16 AM
microphone problem mic is rear mic and when i rebooted after repair wont work adb0434 Linux - Newbie 2 10-02-2006 12:37 AM
Can't record from Mic sabre307 Linux - Hardware 10 05-27-2006 06:06 PM
how to record from mic ginda Linux - Newbie 1 05-24-2006 02:57 AM
Unable to record mic-in with SoundBlaster Live! while able to record other sources max76230 Linux - Newbie 2 03-14-2005 04:31 AM


All times are GMT -5. The time now is 11:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration