LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-23-2003, 03:09 AM   #1
Elemuy
LQ Newbie
 
Registered: Dec 2003
Location: Madrid (Spain)
Distribution: Slackware 9.1
Posts: 3

Rep: Reputation: 0
kde start script not found


Hi!

I've just installed slack 9.1 yesterday, with KDE an GNOME, If I use GNOME as my default WM, It works fine, and other ones too but if I try KDE as default WM the X system crashes with startkde not found (or kdestart not found I'm not sure about the command).

Could be that I have forgotten to install any package, do you know any easy fix for it?

Best regards and Merry Christmas!

Ignacio
 
Old 12-23-2003, 03:18 AM   #2
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 33
Try 'kdm'........
 
Old 12-23-2003, 03:34 AM   #3
Elemuy
LQ Newbie
 
Registered: Dec 2003
Location: Madrid (Spain)
Distribution: Slackware 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
kdm

First of all thanks for you fast answer!

But, kdm is for graphical login on linux (level 5) and I would prefer the console login (level 3) and startx, have I to install kdm package to have installed the startkde script?


Best regards

Ignacio
 
Old 12-23-2003, 07:28 AM   #4
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Rep: Reputation: 15
Re: kde start script not found

Quote:
Originally posted by Elemuy
Hi!

I've just installed slack 9.1 yesterday, with KDE an GNOME, If I use GNOME as my default WM, It works fine, and other ones too but if I try KDE as default WM the X system crashes with startkde not found (or kdestart not found I'm not sure about the command).

Could be that I have forgotten to install any package, do you know any easy fix for it?

Best regards and Merry Christmas!

Ignacio
Maybe you didn't install KDE or you've got a corrupted CD...
Try doing:

$ls /var/log/packages | grep kde
 
Old 12-23-2003, 03:57 PM   #5
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 33
Re: kdm

Quote:
Originally posted by Elemuy
....But, kdm is for graphical login on linux (level 5) and I would prefer the console login (level 3) and startx, have I to install kdm package to have installed the startkde script?....
Sorry, I didn't fully understand what you wanted....

My default runlevel is 3, but I found that you need to be root to use kdm from the tty console......this will call up KDE's login interface where you can log in as a user or root.......

What I did while in kde is started up the Control Panel and went to System Administration -> Login Manager, clicked on the last tab (Convenience) and made sure 'Automatic Login' was deselected and 'Preselect User' was set to 'Specify' and selected my username with the 'Focus password' option enabled. This means when I login, the username will already be entered and all I need to do is supply the password.

I like the kdm login interface, cause I can also use it to login to different window managers with it as well..........not to mention that I'm a kde freak

HTH
---thegeekster


-------------------------------------------------------------------
PS: Since I mostly use the KDE GUI and call up shell terminals (Konsole in KDE) when using the command line, I've automated the process by starting kdm automatically.......I'm still in runlevel 3, but have bypassed the tty login.....What I did is added these lines (as the very last lines) to /etc/rc.d/rc.local:
Code:
# Start KDE login automatically
 /opt/kde/bin/kdm
And I can still go to the tty console from here by simply hitting Alt+N, which will take me to the tty (command line) login....

Last edited by thegeekster; 12-23-2003 at 04:16 PM.
 
Old 12-24-2003, 02:22 AM   #6
Elemuy
LQ Newbie
 
Registered: Dec 2003
Location: Madrid (Spain)
Distribution: Slackware 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
Thumbs up Problem Solved!!!

Thanks a lot guys!

The problem was that PATH hadn't properly updated (perhaps I launched startx from a different virtual console that was logged on) now It works perfectly with the proper path

Best regards and merry christmas!

Ignacio
 
Old 12-24-2003, 06:05 AM   #7
sapaaja
LQ Newbie
 
Registered: Dec 2003
Posts: 1

Rep: Reputation: 0
more precise

I'm a newbie, could anybody give more precies answer ? I can't get the point how to solve it.

Thank you.

Zul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I create a script to start up in .kde/Autostart? Slovak Slackware 11 11-30-2004 07:21 PM
How to start a Tcl/Tk script by simply invoking the script file itself ? cyu021 Programming 2 10-10-2004 12:00 PM
Start up messages found where? pgte3 Linux - Newbie 14 09-09-2004 01:12 PM
Can't start enlightenment...libttf.so.2 not found !! frenchi Linux - Newbie 4 12-26-2003 10:44 AM
KDE auto start script problem Coolrunr Programming 2 09-08-2003 10:55 PM


All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration