LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-13-2013, 06:44 PM   #1
scarrs
Member
 
Registered: Sep 2013
Location: Thunder Bay, Ontario
Distribution: Slackware 14.1 x86_64
Posts: 33

Rep: Reputation: Disabled
jack - how to run as a user?


hello all
I have a little problem. I am running slackware 14 and installed jack, qjackctl and all the dependencies. I can run qjackctl successfully as root but not as my user.

I am a musician and am running the program guitarix (awesome software) and would love to be able to run this program as a normal user.

please help

--scarrs
 
Old 09-14-2013, 02:22 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,976

Rep: Reputation: Disabled
Where did you put the binary? Normally it should go in /usr/bin. Assuming that's where it is, then post the output for this:
Code:
ls -l /usr/bin/qjackctl
If it's not in /usr/bin (or perhaps, /bin) then find out where it is and check on the permissions using the command suggested above.
jdk
 
Old 09-14-2013, 05:49 AM   #3
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware, Slackware 64, Slackware ARM, Gentoo, Fedora
Posts: 160

Rep: Reputation: Disabled
http://slackbuilds.org/repository/14...onnection-kit/

This page suggests that you use
Code:
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl
See if that works.
 
Old 09-15-2013, 11:48 AM   #4
scarrs
Member
 
Registered: Sep 2013
Location: Thunder Bay, Ontario
Distribution: Slackware 14.1 x86_64
Posts: 33

Original Poster
Rep: Reputation: Disabled
nope

that command totally killed qjackctl I can't even start it now. please help

Quote:
Originally Posted by turtleli View Post
http://slackbuilds.org/repository/14...onnection-kit/

This page suggests that you use
Code:
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl
See if that works.
 
Old 09-15-2013, 12:48 PM   #5
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware, Slackware 64, Slackware ARM, Gentoo, Fedora
Posts: 160

Rep: Reputation: Disabled
Reading the page again it seems you also need to set jackd to have the same capabilities.

So you also need
Code:
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd
But if that doesn't work, you can remove the capabilities with

Code:
setcap -r /usr/bin/qjackctl
setcap -r /usr/bin/jackd
 
Old 09-15-2013, 04:14 PM   #6
scarrs
Member
 
Registered: Sep 2013
Location: Thunder Bay, Ontario
Distribution: Slackware 14.1 x86_64
Posts: 33

Original Poster
Rep: Reputation: Disabled
Smile still no luck...

I tried both of those commands and I can't get qjackctl running as a user. I reverted the qjackctl line and qjackctl starts again but fails to run when I try to start the server. qjackctl still continues to run perfectly as the root user. I am so close, don't give up guys. I need a little help with one.

Quote:
Originally Posted by turtleli View Post
Reading the page again it seems you also need to set jackd to have the same capabilities.

So you also need
Code:
setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd
But if that doesn't work, you can remove the capabilities with

Code:
setcap -r /usr/bin/qjackctl
setcap -r /usr/bin/jackd
 
Old 09-17-2013, 09:11 AM   #7
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware, Slackware 64, Slackware ARM, Gentoo, Fedora
Posts: 160

Rep: Reputation: Disabled
Perhaps the people in the Slackware section would be able to help you out more. If you think it'll help solve your problem then use the report button and ask for your thread to be moved.
 
Old 09-17-2013, 09:46 AM   #8
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Moved: This thread is more suitable in Slackware and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 09-22-2013, 10:44 AM   #9
scarrs
Member
 
Registered: Sep 2013
Location: Thunder Bay, Ontario
Distribution: Slackware 14.1 x86_64
Posts: 33

Original Poster
Rep: Reputation: Disabled
Thumbs up update: working

I reinstalled slackware and installed all my programs again. setting those 2 commands provides the help I was looking for.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start JACK with KDE 4? (and which JACK should I use?) Wintershade Linux - Software 0 03-24-2011 06:56 AM
[SOLVED] start jack sound server as normal user hoodooman Linux - Software 1 10-27-2010 07:17 AM
How do I run jack well as normal user instead of root? NO /etc/security/limits.conf! el_b Linux - Software 4 09-24-2009 08:02 PM
Jack-Audio-Control-Kit will not display midi devices as regular user: animehair Linux - Software 3 05-03-2008 03:17 PM
LXer: Jack Write Linux, Jack Go Bankrupt... LXer Syndicated Linux News 0 09-09-2007 07:20 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration