LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   jack - how to run as a user? (http://www.linuxquestions.org/questions/slackware-14/jack-how-to-run-as-a-user-4175477053/)

scarrs 09-13-2013 05:44 PM

jack - how to run as a user?
 
hello all
I have a little problem. I am running slackware 14 and installed jack, qjackctl and all the dependencies. I can run qjackctl successfully as root but not as my user.

I am a musician and am running the program guitarix (awesome software) and would love to be able to run this program as a normal user.

please help

--scarrs

jdkaye 09-14-2013 01:22 AM

Where did you put the binary? Normally it should go in /usr/bin. Assuming that's where it is, then post the output for this:
Code:

ls -l /usr/bin/qjackctl
If it's not in /usr/bin (or perhaps, /bin) then find out where it is and check on the permissions using the command suggested above.
jdk

turtleli 09-14-2013 04:49 AM

http://slackbuilds.org/repository/14...onnection-kit/

This page suggests that you use
Code:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl
See if that works.

scarrs 09-15-2013 10:48 AM

nope
 
that command totally killed qjackctl I can't even start it now. please help

Quote:

Originally Posted by turtleli (Post 5027520)
http://slackbuilds.org/repository/14...onnection-kit/

This page suggests that you use
Code:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/qjackctl
See if that works.


turtleli 09-15-2013 11:48 AM

Reading the page again it seems you also need to set jackd to have the same capabilities.

So you also need
Code:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd
But if that doesn't work, you can remove the capabilities with

Code:

setcap -r /usr/bin/qjackctl
setcap -r /usr/bin/jackd


scarrs 09-15-2013 03:14 PM

still no luck...
 
I tried both of those commands and I can't get qjackctl running as a user. I reverted the qjackctl line and qjackctl starts again but fails to run when I try to start the server. qjackctl still continues to run perfectly as the root user. I am so close, don't give up guys. I need a little help with one.

Quote:

Originally Posted by turtleli (Post 5028041)
Reading the page again it seems you also need to set jackd to have the same capabilities.

So you also need
Code:

setcap cap_ipc_lock,cap_sys_nice=ep /usr/bin/jackd
But if that doesn't work, you can remove the capabilities with

Code:

setcap -r /usr/bin/qjackctl
setcap -r /usr/bin/jackd



turtleli 09-17-2013 08:11 AM

Perhaps the people in the Slackware section would be able to help you out more. If you think it'll help solve your problem then use the report button and ask for your thread to be moved.

colucix 09-17-2013 08:46 AM

Moved: This thread is more suitable in Slackware and has been moved accordingly to help your thread/question get the exposure it deserves.

scarrs 09-22-2013 09:44 AM

update: working
 
I reinstalled slackware and installed all my programs again. setting those 2 commands provides the help I was looking for.


All times are GMT -5. The time now is 03:12 AM.