LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2012, 09:33 PM   #1
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Rep: Reputation: 21
I think I hosed my machine....


After debating weather to leave well enough alone, or up grade to -current, curiosity got the best of me...
I decided to upgrade my laptop to -current.
Now when I boot-up my keyboard and mouse (touch pad) don't work at all. I have no input what so ever.
The computer is a Dell XPS 17 (L702X) It was set to boot to runlevel 4 using GDM with xfce as the WM.

Will it be possible to revert to 13.37 or, will I need to reinstall?

If it is possible to revert back to 13.37, what is the best approach?
 
Old 07-11-2012, 10:12 PM   #2
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
Damn, I think I had this same problem when upgrading my desktop to -current. I forget how I solved it.

Is /etc/rc.d/rc.hald set executable?
 
Old 07-11-2012, 10:22 PM   #3
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by apeitheo View Post
Is /etc/rc.d/rc.hald set executable?
At this point I'm not sure...I need to figure out how to boot to run level 1 to see if I can use the keyboard.
 
Old 07-11-2012, 10:27 PM   #4
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,868
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
Whenever you upgrade from a preset release to -Current you should revert to the basic runlevel 3 just to be safe because often you may have to rerun several configuration scripts again to reset the system like xorgsetup, alsaconf, netconfig, etc.

Perform the upgrade commands in this order (reconfirmed from AlienBOB) after switching your FTP/HTTP mirror over to a Current mirror:

1. slackpkg update
2. slackpkg install-new
3. slackpkg upgrade-all
4. slackpkg clean-system

At present you MAY be able to boot the system using the rescue command from the install disk and get some functionality before reattempting to see what is wrong:

Code:
huge.s root=/dev/sda# noinitrd=ro
# = whatever number your Linux boot partition is.

Last edited by ReaperX7; 07-11-2012 at 10:28 PM.
 
Old 07-11-2012, 10:38 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,242

Rep: Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614
You can try forcing runlevel 3 at boot-time by passing 3 as a parameter at the lilo boot screen (assuming you use lilo). For example, if the menu entry is called Linux, you would type "Linux 3" (without quotes) and press enter (I think you have to press Tab to get to the prompt but I cannot remember). If it still doesn't work then you can try booting into single user mode by passing 1 instead of 3. And of course if that still doesn't work then you can always use ReaperX7's above-mentioned trick when booting using the install CD/DVD.
 
Old 07-11-2012, 10:54 PM   #6
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,140

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Originally Posted by ceh383 View Post
It was set to boot to runlevel 4 using GDM with xfce as the WM.
I'm guessing you installed GDM from a third party as that is not part of a standard Slackware install. Are you running GSB or just GDM from a repository? Just curious. I'm not sure if that has anything to do with your upgrade getting hosed.
 
Old 07-11-2012, 10:57 PM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,411
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
I had that problem some time ago, just because I forgot the mandatory
Code:
slackpkg install-new
After that it worked like a charm (and still does).

Original thread was here: http://www.linuxquestions.org/questi...orking-943408/

Last edited by TobiSGD; 07-11-2012 at 11:00 PM. Reason: added link
 
Old 07-12-2012, 09:00 AM   #8
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by ReaperX7 View Post
Whenever you upgrade from a preset release to -Current you should revert to the basic runlevel 3 just to be safe because often you may have to rerun several configuration scripts again to reset the system like xorgsetup, alsaconf, netconfig, etc.

Perform the upgrade commands in this order (reconfirmed from AlienBOB) after switching your FTP/HTTP mirror over to a Current mirror:

1. slackpkg update
2. slackpkg install-new
3. slackpkg upgrade-all
4. slackpkg clean-system

At present you MAY be able to boot the system using the rescue command from the install disk and get some functionality before reattempting to see what is wrong:

Code:
huge.s root=/dev/sda# noinitrd=ro
# = whatever number your Linux boot partition is.
Live and learn, next time I attempt an upgrade I will switch to runlevel 3 before hand.
I did run the upgrade commands in that order, however when it came to slackpkg upgrade-all I got an error saying I needed to update the gpg key.
I ran slackpkg update-gpg, it failed...I don't remember the exact message.

Quote:
Originally Posted by T3slider View Post
You can try forcing runlevel 3 at boot-time by passing 3 as a parameter at the lilo boot screen (assuming you use lilo). For example, if the menu entry is called Linux, you would type "Linux 3" (without quotes) and press enter (I think you have to press Tab to get to the prompt but I cannot remember).
This worked, I can get into the system...Thanks for that

Quote:
Originally Posted by hitest View Post
Are you running GSB or just GDM from a repository?
I installed GDM and its dependencies from slackbuilds.org.

Quote:
Originally Posted by TobiSGD View Post
I had that problem some time ago, just because I forgot the mandatory
Code:
slackpkg install-new
After that it worked like a charm (and still does).

Original thread was here: http://www.linuxquestions.org/questi...orking-943408/
I did run slackpkg install-new, and that seemingly went well...As stated above I did have a problem with slackpkg upgrade-all.

I'll give that thread a read over...

Thanks all...
 
Old 07-12-2012, 03:22 PM   #9
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,868
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
The GPG key should be updated when you run slackpkg update. I don't see why it didn't.
 
Old 07-12-2012, 05:11 PM   #10
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by ReaperX7 View Post
The GPG key should be updated when you run slackpkg update. I don't see why it didn't.
Me either, I'll try again tonight and see if I get the error again...
 
Old 07-12-2012, 06:14 PM   #11
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,140

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Originally Posted by ceh383 View Post
Me either, I'll try again tonight and see if I get the error again...
When I do a clean install I run:

# slackpkg update gpg

then:

# slackpkg update
 
Old 07-12-2012, 11:37 PM   #12
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by hitest View Post
When I do a clean install I run:

# slackpkg update gpg

then:

# slackpkg update
Well, I will note that for future use....
Given the time I've spent trying to get this back up and getting nowhere, I decided to reinstall...It just takes less time...
 
Old 07-13-2012, 12:20 AM   #13
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,868
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
let us know if you attempt it again and how it goes.
 
Old 07-13-2012, 12:21 AM   #14
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Ok, I reinstalled 13.37, ran slackpkg update gpg, then updated using slackpkg in the order given above.
when I got to slackpkg upgrade-all I got this...

Code:
bash-4.1# slackpkg upgrade-all

You need the GPG key of Slackware Linux Project <security@slackware.com>.
To download and install that key, run:

	# slackpkg update gpg

You can disable GPG checking too, but it is not a good idea.
To disable GPG, edit slackpkg.conf and change the value of the CHECKGPG
variable to off - you can see an example in the original slackpkg.conf.new
file distributed with slackpkg.
I ran "slackpkg update gpg" again and got the same message again....WTF....

Here goes a reboot....hope it works....

Last edited by ceh383; 07-13-2012 at 12:26 AM.
 
Old 07-13-2012, 12:28 AM   #15
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Well, it's still the same as before....

Right now time is at a premium for me, I guess 13.37 will have to do...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS is hosed, machine disappears from net RileyTheWiley Linux - Networking 1 09-13-2009 06:12 AM
Is my reiser fs hosed? Hypnotoad Linux - Software 2 01-19-2005 12:01 AM
Am I hosed ? lostboy Linux - Hardware 14 03-10-2003 11:45 PM
Hosed once again Cichlid Linux - Hardware 3 11-02-2002 09:21 PM
hosed MBR lacrimae Linux - Software 11 07-27-2002 11:14 PM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration