LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   I think I hosed my machine.... (http://www.linuxquestions.org/questions/slackware-14/i-think-i-hosed-my-machine-4175416251/)

ceh383 07-11-2012 09:33 PM

I think I hosed my machine....
 
After debating weather to leave well enough alone, or up grade to -current, curiosity got the best of me...
I decided to upgrade my laptop to -current.
Now when I boot-up my keyboard and mouse (touch pad) don't work at all. I have no input what so ever.
The computer is a Dell XPS 17 (L702X) It was set to boot to runlevel 4 using GDM with xfce as the WM.

Will it be possible to revert to 13.37 or, will I need to reinstall?

If it is possible to revert back to 13.37, what is the best approach?

apeitheo 07-11-2012 10:12 PM

Damn, I think I had this same problem when upgrading my desktop to -current. I forget how I solved it.

Is /etc/rc.d/rc.hald set executable?

ceh383 07-11-2012 10:22 PM

Quote:

Originally Posted by apeitheo (Post 4725641)
Is /etc/rc.d/rc.hald set executable?

At this point I'm not sure...I need to figure out how to boot to run level 1 to see if I can use the keyboard.

ReaperX7 07-11-2012 10:27 PM

Whenever you upgrade from a preset release to -Current you should revert to the basic runlevel 3 just to be safe because often you may have to rerun several configuration scripts again to reset the system like xorgsetup, alsaconf, netconfig, etc.

Perform the upgrade commands in this order (reconfirmed from AlienBOB) after switching your FTP/HTTP mirror over to a Current mirror:

1. slackpkg update
2. slackpkg install-new
3. slackpkg upgrade-all
4. slackpkg clean-system

At present you MAY be able to boot the system using the rescue command from the install disk and get some functionality before reattempting to see what is wrong:

Code:

huge.s root=/dev/sda# noinitrd=ro
# = whatever number your Linux boot partition is.

T3slider 07-11-2012 10:38 PM

You can try forcing runlevel 3 at boot-time by passing 3 as a parameter at the lilo boot screen (assuming you use lilo). For example, if the menu entry is called Linux, you would type "Linux 3" (without quotes) and press enter (I think you have to press Tab to get to the prompt but I cannot remember). If it still doesn't work then you can try booting into single user mode by passing 1 instead of 3. And of course if that still doesn't work then you can always use ReaperX7's above-mentioned trick when booting using the install CD/DVD.

hitest 07-11-2012 10:54 PM

Quote:

Originally Posted by ceh383 (Post 4725620)
It was set to boot to runlevel 4 using GDM with xfce as the WM.

I'm guessing you installed GDM from a third party as that is not part of a standard Slackware install. Are you running GSB or just GDM from a repository? Just curious. I'm not sure if that has anything to do with your upgrade getting hosed.

TobiSGD 07-11-2012 10:57 PM

I had that problem some time ago, just because I forgot the mandatory
Code:

slackpkg install-new
After that it worked like a charm (and still does).

Original thread was here: http://www.linuxquestions.org/questi...orking-943408/

ceh383 07-12-2012 09:00 AM

Quote:

Originally Posted by ReaperX7 (Post 4725649)
Whenever you upgrade from a preset release to -Current you should revert to the basic runlevel 3 just to be safe because often you may have to rerun several configuration scripts again to reset the system like xorgsetup, alsaconf, netconfig, etc.

Perform the upgrade commands in this order (reconfirmed from AlienBOB) after switching your FTP/HTTP mirror over to a Current mirror:

1. slackpkg update
2. slackpkg install-new
3. slackpkg upgrade-all
4. slackpkg clean-system

At present you MAY be able to boot the system using the rescue command from the install disk and get some functionality before reattempting to see what is wrong:

Code:

huge.s root=/dev/sda# noinitrd=ro
# = whatever number your Linux boot partition is.

Live and learn, next time I attempt an upgrade I will switch to runlevel 3 before hand.
I did run the upgrade commands in that order, however when it came to slackpkg upgrade-all I got an error saying I needed to update the gpg key.
I ran slackpkg update-gpg, it failed...I don't remember the exact message.

Quote:

Originally Posted by T3slider (Post 4725655)
You can try forcing runlevel 3 at boot-time by passing 3 as a parameter at the lilo boot screen (assuming you use lilo). For example, if the menu entry is called Linux, you would type "Linux 3" (without quotes) and press enter (I think you have to press Tab to get to the prompt but I cannot remember).

This worked, I can get into the system...Thanks for that

Quote:

Originally Posted by hitest (Post 4725662)
Are you running GSB or just GDM from a repository?

I installed GDM and its dependencies from slackbuilds.org.

Quote:

Originally Posted by TobiSGD (Post 4725665)
I had that problem some time ago, just because I forgot the mandatory
Code:

slackpkg install-new
After that it worked like a charm (and still does).

Original thread was here: http://www.linuxquestions.org/questi...orking-943408/

I did run slackpkg install-new, and that seemingly went well...As stated above I did have a problem with slackpkg upgrade-all.

I'll give that thread a read over...

Thanks all...

ReaperX7 07-12-2012 03:22 PM

The GPG key should be updated when you run slackpkg update. I don't see why it didn't.

ceh383 07-12-2012 05:11 PM

Quote:

Originally Posted by ReaperX7 (Post 4726350)
The GPG key should be updated when you run slackpkg update. I don't see why it didn't.

Me either, I'll try again tonight and see if I get the error again...

hitest 07-12-2012 06:14 PM

Quote:

Originally Posted by ceh383 (Post 4726463)
Me either, I'll try again tonight and see if I get the error again...

When I do a clean install I run:

# slackpkg update gpg

then:

# slackpkg update

ceh383 07-12-2012 11:37 PM

Quote:

Originally Posted by hitest (Post 4726489)
When I do a clean install I run:

# slackpkg update gpg

then:

# slackpkg update

Well, I will note that for future use....
Given the time I've spent trying to get this back up and getting nowhere, I decided to reinstall...It just takes less time...

ReaperX7 07-13-2012 12:20 AM

let us know if you attempt it again and how it goes.

ceh383 07-13-2012 12:21 AM

Ok, I reinstalled 13.37, ran slackpkg update gpg, then updated using slackpkg in the order given above.
when I got to slackpkg upgrade-all I got this...

Code:

bash-4.1# slackpkg upgrade-all

You need the GPG key of Slackware Linux Project <security@slackware.com>.
To download and install that key, run:

        # slackpkg update gpg

You can disable GPG checking too, but it is not a good idea.
To disable GPG, edit slackpkg.conf and change the value of the CHECKGPG
variable to off - you can see an example in the original slackpkg.conf.new
file distributed with slackpkg.

I ran "slackpkg update gpg" again and got the same message again....WTF....

Here goes a reboot....hope it works....

ceh383 07-13-2012 12:28 AM

Well, it's still the same as before....

Right now time is at a premium for me, I guess 13.37 will have to do...


All times are GMT -5. The time now is 02:53 PM.