LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-24-2014, 08:50 PM   #1
moisespedro
Member
 
Registered: Nov 2013
Location: Brazil
Distribution: Slackware and LFS
Posts: 893

Rep: Reputation: 94
Having trouble on properly setting the locale


Hi, I just reinstalled my slackware and I did the exact same thing I did before (edited lang.sh and lang.csh) and rc.local (to set unicode)

Here is how each one of them look like:
Code:
lang.sh
export LANG=pt_BR
export LANG=pt_BR.UTF-8
Code:
lang.csh
setenv LANG pt_BR
setenv LANG pt_BR.UTF-8
Code:
rc.local
unicode_start
However it is not working as it was before, on tty it is but not on X.
Example:
http://i.imgur.com/cGNAirS.png (that is portuguese for "Command not found")

On tty and on my previous system it was working fine and display "comando não encontrado" (the correct way).

Any thoughts?

EDIT: My bad, guys. It was just on rxvt. I only realised it when I've tried xfce terminal. It is working fine
Damn I am such a noob

Last edited by moisespedro; 01-24-2014 at 08:55 PM.
 
Old 01-24-2014, 10:19 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,260

Rep: Reputation: 1051Reputation: 1051Reputation: 1051Reputation: 1051Reputation: 1051Reputation: 1051Reputation: 1051Reputation: 1051
Preferably just write
Code:
lang.sh
export LANG=pt_BR.utf8
Code:
lang.csh
setenv LANG pt_BR.utf8
Rationale:
  • this is how it is expected to be written
  • in what you wrote only the second line export is considered anyway as it replaces the previous one

Last edited by Didier Spaier; 01-25-2014 at 02:36 AM. Reason: Typo fixed
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't get Bulgarian locale to work properly Jotto Slackware 8 10-31-2012 01:35 AM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
[SOLVED] Locale trouble. illusionoflife Linux From Scratch 5 04-17-2011 11:41 AM
setting locale tommosa Linux - Newbie 2 11-06-2007 05:22 AM
trouble grokking LOCALE stabu Linux - Newbie 1 05-04-2004 01:02 PM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration