LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Hal and XFCE in Slackware 12.1 (http://www.linuxquestions.org/questions/slackware-14/hal-and-xfce-in-slackware-12-1-a-657594/)

budman85 07-23-2008 12:38 AM

Hal and XFCE in Slackware 12.1
 
Hi

I've noticed this odd issue since updating to 12.1. It ran fine in 12.0. I've been through all the FAQs and topics I could find, but none of them mention this issue.

My id is plugdev, and the other related groups. The entries in /etc/fstab have user option, tried users as well.

The rules I created for the two card readers work fine, I added GROUP=users to each line.

Here is the issue.

If a memory card is installed in the reader when XFCE starts up - the icon of the card reader will appear and I can mount and unmount fine.

However, if the card reader is empty when XFCE starts up, unplugging the device, or adding a memory card does not add the icon to the desktop.

I've tried toggling the "allow xfce to manage desktop" option, the icons refresh but the new drive icon never appears.

I checked to see if hald is working, I see it polling every 2 secs. When the card is added, the mounts are created and symlinks are created. It seems they are all working fine. I can mount the card reader under root and then access as the user.

The only thing I've found that works are these steps:
rc.messagebus reload
rc.hald restart
toggle the "allow xfce to manage desktop"
bingo - the icon appears and I can mount the card.

BTW, restarting X has no effect. Message bus must be reloaded and hald restarted so the icon will appear on the desktop.

Does anyone know how XFCE checks to see if anything was changed? I saw mention of the famd daemon, but its no longer on my system. Is this related to the xfdesktop?

I also try renaming the .config under my home dir, same results. I also tried as root, same results.

I then renamed the my custom rules file, and commented the lines in fstab. Restarted everything, same results.

In 12.0, when I unplugged the device, the icon disappeared. When I plugged it in, it reappeared. This no longer happens. The icons remain whether the device is plugged in or not.

Any ideas I can check or try?


Thanks
Rich

granth 07-24-2008 09:56 AM

Quote:

My id is plugdev, and the other related groups
I'm guessing you are a member of the plugdev group?

Code:

cat /etc/group | grep username

Quote:

The entries in /etc/fstab have user option, tried users as well.
Please post your fstab.

Did you try removing the entries from your fstab?
Does your cdrom auto-mount?

budman85 07-24-2008 11:22 PM

Quote:

Originally Posted by granth (Post 3225012)
I'm guessing you are a member of the plugdev group?

Code:

cat /etc/group | grep username



Please post your fstab.

Did you try removing the entries from your fstab?
Does your cdrom auto-mount?


Thanks for replying.
I started tracing what was loaded. XFCE uses libgamin now, and dropped the famd support. I was comparing files in /lib, /usr/bin, and /usr/lib. Decided to rename the usr dir and try a reload of software.

It worked. Whatever was in /usr/bin or /usr/lib caused hald/messagebus gamin to break in Xfce. I've been comparing directories, file by file - so far I cannot see anything that may have caused it.

Since I have the dirs, I'll keep on checking. Maybe something will stick out. The only thing I saw on libgamin was a slight lib address change.

ldd /usr1/lib/libgamin-1.so.0.1.9
linux-gate.so.1 => (0xffffe000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7ee4000)
libc.so.6 => /lib/libc.so.6 (0xb7d98000)
/lib/ld-linux.so.2 (0x80000000)

ldd /usr/lib/libgamin-1.so.0.1.9
linux-gate.so.1 => (0xffffe000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7fa2000)
libc.so.6 => /lib/libc.so.6 (0xb7e56000)
/lib/ld-linux.so.2 (0x80000000)

Really strange. Maybe libc or libpthread caused it. Works like a charm now.

oh well.


All times are GMT -5. The time now is 07:49 AM.