LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-01-2009, 06:35 AM   #1
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
Firefox/Thunderbird not starting - glibc issue?


I recently upgraded to current ( incl .kde4 ) but I might have caused a problem with my glibc install as Firefox and Thunderbird refuse to start using the normal icon method - /var/log/messages issues the following error:

kernel: firefox-bin[4572]: segfault at ffffffff ip b68c9c42 sp b61fe968 error 4 in libc-2.9.so[b6851000+15a000]

I get a variety of other errors when trying to start some other apps incl:

kernel: dvdrip-splash[4924]: segfault at 0 ip b739273d sp bfee9010 error 4 in libgtk-x11-2.0.so.0.1400.7[b7225000+385000]
kernel: dvdrip[4923]: segfault at 0 ip b739873d sp bff790b0 error 4 in libgtk-x11-2.0.so.0.1400.7[b722b000+385000]

Strange though all these apps start fine from a konsole term ... I've followed R Workman's glibc recovery howto without any improvement.

Any assistance would be appreciated. Robby
 
Old 04-02-2009, 03:16 PM   #2
kandiru
Member
 
Registered: Mar 2009
Location: Genoa, Italy
Distribution: Slackware
Posts: 33

Rep: Reputation: 16
Hi,

something similar with firefox happened to me some months ago: I upgraded firefox to the latest version and it refused to work, causing a crash when I tried to make it start.

The only thing to do, after some unsuccessful recovery attempts, was a massive upgrade of the system using swaret.

Probably this also put the new libraries at the right place.

I'm sorry I can't give you any more details.

Bye, David
 
Old 04-03-2009, 01:48 AM   #3
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Original Poster
Rep: Reputation: 27
Thanks David - appreciate the reply. I'm heading into a reinstall this weekend so this should be fixed. Just not looking forward to all the compiling I need to do to get my av stuff working again ( avidemux, ffmped, transcode, etc ... ). Regards Robby
 
Old 04-03-2009, 09:22 AM   #4
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 542

Rep: Reputation: 74
it could also be your java library, have had this issue in the past. Make sure you have a java version that is compiled with the right glibc and such. That might just fix the problem as well... no harm on upgrading your machine anyway :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X not starting due to not having GCC/GLIBC... but I have them installed? a10waveracer Slackware 3 01-22-2007 05:43 AM
Thunderbird and firefox hraposo Ubuntu 3 11-11-2006 07:09 PM
Thunderbird Not Starting? Maxplayer14 Mandriva 1 02-28-2005 01:58 PM
Please!!!!Help with Firefox-Thunderbird Lier Linux - Software 3 01-27-2005 08:32 AM
Thunderbird and Firefox, Thunderbird doesnt launch firefox? sovietpower Slackware 1 11-01-2004 12:51 PM


All times are GMT -5. The time now is 08:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration