LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-20-2013, 02:19 AM   #1
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
Firefox file associations again


Hi there.
After upgrading to firefox 18 the file associations under "downloads" dialog are wrong again. The workaround from Alien's blog doesn't work anymore. It uses audacious to open directory containing a file, and gimp for pdfs.
Any ideas?
 
Old 02-20-2013, 02:55 AM   #2
animeresistance
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 191

Rep: Reputation: 20
Hi ..

Hmmm, i hope this helps, i use the xfce desktop in slackware. When you select a file (for example, pdf file), use right click and then properties, you should see a legend that says "Open with" you can select what application you want to handle the pdf files. I think this should work with KDE desktop, honestly i haven't tried it. With audacious opening directories, that's kinda weird but i think it can be solved with the file association i mentioned before.

Hope this can help you.

Greeting
 
Old 02-20-2013, 03:13 AM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,915

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
firefox "should" be grabbing the desktop defaults for "opening a file"

set them there .
 
1 members found this post helpful.
Old 02-20-2013, 03:38 AM   #4
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by John VV View Post
firefox "should" be grabbing the desktop defaults for "opening a file"

set them there .
KDE, Slackware 14 here. I think it "should" but it does not.
 
Old 02-20-2013, 04:02 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,915

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
Slack 14 ? i do not know
but it dose on kde4 running on opensuse12.2

and the now current firefox is 19.0
18.0.2 was updated today
19 did reset pdf's to use the NEW "display in firefox"
they added a pdf reader to the browser

Quote:
the file associations under "downloads" dialog are wrong again.
you are referring to
-- in firefox --

edit > preferences
then the "applications" tab
---------
Right ?
 
Old 02-20-2013, 04:16 PM   #6
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Original Poster
Rep: Reputation: 17
I ment Tools > Downloads or Ctrl+Shift+Y. Try right clicking on a downloaded file and choose Open or Open folder
 
Old 02-20-2013, 04:29 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,915

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
so the download manager

if ff is set to clear history on shutdown then it will clear

to change from the download manager window to the download manager notification
set that under
edit > preferences
under the "general" tab

uncheck "Show the Downloads window when downloading a file"
and to change the "ask" option
check "Always ask me where to save files "
 
Old 02-21-2013, 07:48 PM   #8
qweasd
Member
 
Registered: May 2010
Posts: 439

Rep: Reputation: Disabled
I don't know about Firefox, but I seem to be experiencing this with icecat. For me, rebuilding with GIO support made it possible to write sane settings in
Code:
~/.local/share/applications/mimeapps.list
May be your Firefox is also somehow defaulting to settings in
Code:
/usr/share/applications/mimeinfo.cache

Last edited by qweasd; 02-21-2013 at 08:41 PM.
 
Old 02-22-2013, 07:17 AM   #9
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
Hi, alekow

In my system Firefox respects the default file manager, which I set using
Code:
exo-preferred-applications
and I don't even have to restart the browser for the change to take effect.

Last edited by elesmod; 02-22-2013 at 07:22 AM.
 
1 members found this post helpful.
Old 02-23-2013, 03:47 PM   #10
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Original Poster
Rep: Reputation: 17
thank you elesmod, that did the trick!

[SOLVED] ;-)

Thank you all for help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
File associations in Gnome Commander vs. associations in Nautilus taylorkh Linux - Software 0 01-01-2010 05:18 PM
How to change mime associations in firefox gkiagia Linux - Desktop 11 12-07-2006 07:33 AM
File Associations Altec_ Linux - Software 3 02-08-2005 01:43 PM
Setting file associations in Firefox 1.0 (MDK 10.1 Official) Razze Linux - Software 0 12-17-2004 09:51 AM
File Associations gag Linux - Newbie 6 10-15-2003 04:34 PM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration