LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Firefox file associations again (http://www.linuxquestions.org/questions/slackware-14/firefox-file-associations-again-4175450911/)

alekow 02-20-2013 02:19 AM

Firefox file associations again
 
Hi there.
After upgrading to firefox 18 the file associations under "downloads" dialog are wrong again. The workaround from Alien's blog doesn't work anymore. It uses audacious to open directory containing a file, and gimp for pdfs.
Any ideas?

animeresistance 02-20-2013 02:55 AM

Hi ..

Hmmm, i hope this helps, i use the xfce desktop in slackware. When you select a file (for example, pdf file), use right click and then properties, you should see a legend that says "Open with" you can select what application you want to handle the pdf files. I think this should work with KDE desktop, honestly i haven't tried it. With audacious opening directories, that's kinda weird but i think it can be solved with the file association i mentioned before.

Hope this can help you.

Greeting :)

John VV 02-20-2013 03:13 AM

firefox "should" be grabbing the desktop defaults for "opening a file"

set them there .

alekow 02-20-2013 03:38 AM

Quote:

Originally Posted by John VV (Post 4895797)
firefox "should" be grabbing the desktop defaults for "opening a file"

set them there .

KDE, Slackware 14 here. I think it "should" but it does not.

John VV 02-20-2013 04:02 AM

Slack 14 ? i do not know
but it dose on kde4 running on opensuse12.2

and the now current firefox is 19.0
18.0.2 was updated today
19 did reset pdf's to use the NEW "display in firefox"
they added a pdf reader to the browser

Quote:

the file associations under "downloads" dialog are wrong again.
you are referring to
-- in firefox --

edit > preferences
then the "applications" tab
---------
Right ?

alekow 02-20-2013 04:16 PM

I ment Tools > Downloads or Ctrl+Shift+Y. Try right clicking on a downloaded file and choose Open or Open folder

John VV 02-20-2013 04:29 PM

so the download manager

if ff is set to clear history on shutdown then it will clear

to change from the download manager window to the download manager notification
set that under
edit > preferences
under the "general" tab

uncheck "Show the Downloads window when downloading a file"
and to change the "ask" option
check "Always ask me where to save files "

qweasd 02-21-2013 07:48 PM

I don't know about Firefox, but I seem to be experiencing this with icecat. For me, rebuilding with GIO support made it possible to write sane settings in
Code:

~/.local/share/applications/mimeapps.list
May be your Firefox is also somehow defaulting to settings in
Code:

/usr/share/applications/mimeinfo.cache

elesmod 02-22-2013 07:17 AM

Hi, alekow :)

In my system Firefox respects the default file manager, which I set using
Code:

exo-preferred-applications
and I don't even have to restart the browser for the change to take effect.

alekow 02-23-2013 03:47 PM

thank you elesmod, that did the trick!

[SOLVED] ;-)

Thank you all for help!


All times are GMT -5. The time now is 12:34 AM.