LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2006, 12:27 AM   #1
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
emerde bug or smth


Ok. So I am using emerde, but also use slackware package management system. I decided to install aMule, but emerde gave me ncurses error. So I decided to install it as slackware package from linuxpackages.net I'm not able to do it because I get this error:
Code:
pkg2por: Loading aMule-2.1.0-i486-1asz's data
pkg2por: Category not found. Skipping
As I understand, this strange pkg2por came from emerde installation. So I can't use neither installpkg nor pkgtool - not able to install anything to my system. Manually installing (./configure, make, make install) also fails when running due to some strange error about libraries not being the same through building. I'm able to build successfully, but not to run.


Talking about package management, checkinstall can't make packages from cvs. It writes smth similar to:
%name-%version-%date.tgz but nothing is being created in the source directory.

Now I'm worried that nothing of these slackpkg,slapt-get or swaret are gonna to work, because all of them use slackware package management system.
 
Old 03-07-2006, 05:38 PM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Original Poster
Rep: Reputation: 53
Bump,bump.
 
Old 03-07-2006, 05:54 PM   #3
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Tried 'pkg2por CADB'?
 
Old 03-08-2006, 12:08 AM   #4
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Original Poster
Rep: Reputation: 53
Thanks. I needed to read faq before posting but I was very frustrated that emerde messed my packagement system.

#pkg2por CADB didn't fix installpkg. I have investigated that installpkg doesn't work only with certain packages from linuxpackages.net. Official packages are accepted. So I reinstalled pkgtools. However, I don't know if it won't mess my emerde installation.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternate Emerde Download Location Orkie Slackware 2 04-06-2005 09:14 AM
Emerde sethgeekx86 Slackware 6 12-11-2004 07:13 PM
man -t <smth> | lpr problem with iso8859-2 juras Linux - General 1 09-15-2004 06:11 AM
Free86 bug or nVidia bug?? ProtoformX Linux - Software 2 05-12-2004 03:38 AM
Emerde, Portage For Slackware DarkSpy Slackware 14 10-21-2003 09:19 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration