LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   emerde bug or smth (http://www.linuxquestions.org/questions/slackware-14/emerde-bug-or-smth-422354/)

Alien_Hominid 03-06-2006 11:27 PM

emerde bug or smth
 
Ok. So I am using emerde, but also use slackware package management system. I decided to install aMule, but emerde gave me ncurses error. So I decided to install it as slackware package from linuxpackages.net I'm not able to do it because I get this error:
Code:

pkg2por: Loading aMule-2.1.0-i486-1asz's data
pkg2por: Category not found. Skipping

As I understand, this strange pkg2por came from emerde installation. So I can't use neither installpkg nor pkgtool - not able to install anything to my system. Manually installing (./configure, make, make install) also fails when running due to some strange error about libraries not being the same through building. I'm able to build successfully, but not to run.


Talking about package management, checkinstall can't make packages from cvs. It writes smth similar to:
%name-%version-%date.tgz but nothing is being created in the source directory.

Now I'm worried that nothing of these slackpkg,slapt-get or swaret are gonna to work, because all of them use slackware package management system.

Alien_Hominid 03-07-2006 04:38 PM

Bump,bump.

mdarby 03-07-2006 04:54 PM

Tried 'pkg2por CADB'?

Alien_Hominid 03-07-2006 11:08 PM

Thanks. I needed to read faq before posting but I was very frustrated that emerde messed my packagement system.

#pkg2por CADB didn't fix installpkg. I have investigated that installpkg doesn't work only with certain packages from linuxpackages.net. Official packages are accepted. So I reinstalled pkgtools. However, I don't know if it won't mess my emerde installation.

Thanks.


All times are GMT -5. The time now is 11:37 PM.