LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2012, 08:34 AM   #1
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Rep: Reputation: Disabled
Audio Not Working on Lenovo X120e


Hello,

Just setting up a new Slackware distro after a few years on OS X (plus I was on Ubunutu before that, so I'm not sure that really counts as Linux experience), and I'm having some issues getting the sound working on my new Lenovo.

As far as I can tell, the sound card is an ATI Conexant CX20582, and it is detected by alsaconf. After going through that process, I open up alsamixer, and the sound card is there, under the name HDA ATI SB. It gives me a master volume which I can control (i.e. set the volume on), as well as two other "settings," S/PDIF and S/PDIF Default PCM, both of which are set to 00 and neither of which I alter in anyway. If I open the generic Mixer program that is under Multimedia in XFCE, it comes up with the exact same situation in the GUI that alsamixer has.

Neither the headphones or speakers are working, and although I haven't bothered to check the microphones (I don't care about them), I can if necessary. I'm also more than happy to provide the alsa log files, if I knew where they were...

Thanks a lot for any help in advance...
 
Old 04-09-2012, 06:44 PM   #2
Grischuna
Member
 
Registered: Mar 2009
Distribution: Slackware64 14.0 multilib
Posts: 44

Rep: Reputation: 0
Quote:
Originally Posted by Malacoda93 View Post
Hello,

Just setting up a new Slackware distro after a few years on OS X (plus I was on Ubunutu before that, so I'm not sure that really counts as Linux experience), and I'm having some issues getting the sound working on my new Lenovo.

As far as I can tell, the sound card is an ATI Conexant CX20582, and it is detected by alsaconf. After going through that process, I open up alsamixer, and the sound card is there, under the name HDA ATI SB. It gives me a master volume which I can control (i.e. set the volume on), as well as two other "settings," S/PDIF and S/PDIF Default PCM, both of which are set to 00 and neither of which I alter in anyway. If I open the generic Mixer program that is under Multimedia in XFCE, it comes up with the exact same situation in the GUI that alsamixer has.

Neither the headphones or speakers are working, and although I haven't bothered to check the microphones (I don't care about them), I can if necessary. I'm also more than happy to provide the alsa log files, if I knew where they were...

Thanks a lot for any help in advance...
Hello,

If you can see the 'PCM' option in AlsaMixer, increase it to about 50%. Also do the same for the 'Master'. Exit the AlsaMixer and save it with the following command:

Code:
bash-4.2# alsactl store
At least on my laptop I have 'no' sound with PCM at zero.

Cheers
 
Old 04-09-2012, 07:45 PM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
The postings I have seen about audio on the Lenovo X120e suggest that:
1.) Run a kernel >=2.6.38.2 (If you have installed Slackware 13.37, then there is a 2.6.38.4 kernel in the /testing/packages directory)
2.) Provide an option to the snd-hda-intel kernel module so that the HDMI audio is not seen as the primary device. You can do this by creating a file in /etc/modprobe.d. As root, run this command.
Code:
echo "options snd-hda-intel index=1" > /etc/modprobe.d/snd-hda-intel.conf
It is probably easiest just to reboot for this change to take effect.
 
1 members found this post helpful.
Old 04-10-2012, 07:31 AM   #4
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
The postings I have seen about audio on the Lenovo X120e suggest that:
1.) Run a kernel >=2.6.38.2 (If you have installed Slackware 13.37, then there is a 2.6.38.4 kernel in the /testing/packages directory)
2.) Provide an option to the snd-hda-intel kernel module so that the HDMI audio is not seen as the primary device. You can do this by creating a file in /etc/modprobe.d. As root, run this command.
Code:
echo "options snd-hda-intel index=1" > /etc/modprobe.d/snd-hda-intel.conf
It is probably easiest just to reboot for this change to take effect.
That fixed it right up. Thanks alot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Natty 64 internal mic not working on lenovo x120e mightymiff Linux - Newbie 7 03-26-2012 06:15 PM
GRUB2 installed from Linux Mint Debian xfce onto ThinkPad x120e not working aetherian Linux - Newbie 3 02-24-2012 07:14 PM
[SOLVED] Video driver on Lenovo X120e, slackware 13.37 wilson47 Linux - Laptop and Netbook 8 12-07-2011 10:55 PM
sound card order on lenovo x120e, HDMI vs sound card npdawson Slackware 15 05-15-2011 06:46 PM
Lenovo R60 Audio Problem !! arunabh_biswas Linux - Laptop and Netbook 6 08-28-2008 09:05 AM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration