LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Audio Not Working on Lenovo X120e (http://www.linuxquestions.org/questions/slackware-14/audio-not-working-on-lenovo-x120e-938883/)

Malacoda93 04-09-2012 08:34 AM

Audio Not Working on Lenovo X120e
 
Hello,

Just setting up a new Slackware distro after a few years on OS X (plus I was on Ubunutu before that, so I'm not sure that really counts as Linux experience), and I'm having some issues getting the sound working on my new Lenovo.

As far as I can tell, the sound card is an ATI Conexant CX20582, and it is detected by alsaconf. After going through that process, I open up alsamixer, and the sound card is there, under the name HDA ATI SB. It gives me a master volume which I can control (i.e. set the volume on), as well as two other "settings," S/PDIF and S/PDIF Default PCM, both of which are set to 00 and neither of which I alter in anyway. If I open the generic Mixer program that is under Multimedia in XFCE, it comes up with the exact same situation in the GUI that alsamixer has.

Neither the headphones or speakers are working, and although I haven't bothered to check the microphones (I don't care about them), I can if necessary. I'm also more than happy to provide the alsa log files, if I knew where they were...

Thanks a lot for any help in advance...

Grischuna 04-09-2012 06:44 PM

Quote:

Originally Posted by Malacoda93 (Post 4648318)
Hello,

Just setting up a new Slackware distro after a few years on OS X (plus I was on Ubunutu before that, so I'm not sure that really counts as Linux experience), and I'm having some issues getting the sound working on my new Lenovo.

As far as I can tell, the sound card is an ATI Conexant CX20582, and it is detected by alsaconf. After going through that process, I open up alsamixer, and the sound card is there, under the name HDA ATI SB. It gives me a master volume which I can control (i.e. set the volume on), as well as two other "settings," S/PDIF and S/PDIF Default PCM, both of which are set to 00 and neither of which I alter in anyway. If I open the generic Mixer program that is under Multimedia in XFCE, it comes up with the exact same situation in the GUI that alsamixer has.

Neither the headphones or speakers are working, and although I haven't bothered to check the microphones (I don't care about them), I can if necessary. I'm also more than happy to provide the alsa log files, if I knew where they were...

Thanks a lot for any help in advance...

Hello,

If you can see the 'PCM' option in AlsaMixer, increase it to about 50%. Also do the same for the 'Master'. Exit the AlsaMixer and save it with the following command:

Code:

bash-4.2# alsactl store
At least on my laptop I have 'no' sound with PCM at zero.

Cheers

allend 04-09-2012 07:45 PM

The postings I have seen about audio on the Lenovo X120e suggest that:
1.) Run a kernel >=2.6.38.2 (If you have installed Slackware 13.37, then there is a 2.6.38.4 kernel in the /testing/packages directory)
2.) Provide an option to the snd-hda-intel kernel module so that the HDMI audio is not seen as the primary device. You can do this by creating a file in /etc/modprobe.d. As root, run this command.
Code:

echo "options snd-hda-intel index=1" > /etc/modprobe.d/snd-hda-intel.conf
It is probably easiest just to reboot for this change to take effect.

Malacoda93 04-10-2012 07:31 AM

Quote:

Originally Posted by allend (Post 4648809)
The postings I have seen about audio on the Lenovo X120e suggest that:
1.) Run a kernel >=2.6.38.2 (If you have installed Slackware 13.37, then there is a 2.6.38.4 kernel in the /testing/packages directory)
2.) Provide an option to the snd-hda-intel kernel module so that the HDMI audio is not seen as the primary device. You can do this by creating a file in /etc/modprobe.d. As root, run this command.
Code:

echo "options snd-hda-intel index=1" > /etc/modprobe.d/snd-hda-intel.conf
It is probably easiest just to reboot for this change to take effect.

That fixed it right up. Thanks alot.


All times are GMT -5. The time now is 10:34 PM.