LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-21-2011, 12:59 AM   #1
mightymiff
LQ Newbie
 
Registered: Jul 2011
Posts: 2

Rep: Reputation: Disabled
Ubuntu Natty 64 internal mic not working on lenovo x120e


Alright, I'm new to linux, I've googled for days, but I can't for the life of me get my internal mic working. It doesn't register sound in the sound preferences menu, it is not muted.

I have the x120e with the E-350. New install of Ubuntu 11.04 64-bit.

Where to start?

Thanks for the help.
 
Old 07-21-2011, 09:29 AM   #2
alfredo10
Member
 
Registered: Sep 2010
Location: Algarve
Distribution: Linux Multiboot
Posts: 277

Rep: Reputation: 14
Hi!
First I would try: Terminal:
Code:
alsamixer
hit F6, choose sound card and adjust channels.
alfredo

Edit:
Terminal
Quote:
cat /proc/asound/card0/codec#* | grep Codec
should show the card.
If not: some commands need root rights - it depends on the distribution, then you must
run:
"sudo cat /proc/asound/card0/codec#* | grep Codec" without " "

Last edited by alfredo10; 07-21-2011 at 09:35 AM. Reason: Addition
 
Old 07-21-2011, 11:58 AM   #3
mightymiff
LQ Newbie
 
Registered: Jul 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi alfredo, thanks for taking the time to reply.

Codec is: ATI 6xx HDMI

alsamixer is displaying 3 possible sound cards, like this:
0 HD-Audio Generic
1 HDA ATI SB
29 ThinkPad Console Audio

Only HDA ATI SB displays any controls.
I hit F5 to display all controls. I maxed all of them including L R Capture to 100<>100.
Analog Mic Boost up to 40db.

The first time I opened sound preferences after this I noticed some movement on the input level meter. It seemed to climb and drop a bit before climbing to max. It stopped moving after that, and now I'm not sure if it is at 0 or 100. In any case, I have played around with the capture toggle (trying various levels and mic boost db levels) and my skype test call is still silent and the sound recording will not begin recording, leading me to believe I have not fixed my mic.

Something I did incorrectly or something else to try? Thanks...
 
Old 07-21-2011, 12:48 PM   #4
alfredo10
Member
 
Registered: Sep 2010
Location: Algarve
Distribution: Linux Multiboot
Posts: 277

Rep: Reputation: 14
Hi!
Next idea:
Code:
pavucontrol
I suppose it is not installed, but you will get a hint (like "sudo apt-get install pavucontrol").
When you start it, it is possible that you get an error message - ignore that and go on.
alfredo
 
Old 07-21-2011, 12:51 PM   #5
yodabug
LQ Newbie
 
Registered: Jun 2011
Location: Ottawa
Distribution: Started out with lubuntu-morphed into xubuntu
Posts: 8

Rep: Reputation: Disabled
Not sure if this will help or not but I think it might.

https://help.ubuntu.com/community/HdaIntelSoundHowto

There is a ton of information in that thread and links to more.

Good Luck.
 
Old 07-21-2011, 12:55 PM   #6
yodabug
LQ Newbie
 
Registered: Jun 2011
Location: Ottawa
Distribution: Started out with lubuntu-morphed into xubuntu
Posts: 8

Rep: Reputation: Disabled
Or, more to the point:

http://crunchbanglinux.org/forums/to...nd-working-in/

Good Luck again. I really have no idea's, just pretty good search results:-)

Cheers!
 
Old 12-20-2011, 01:35 AM   #7
barmaglot
LQ Newbie
 
Registered: Dec 2011
Posts: 1

Rep: Reputation: Disabled
Solved for Linux Mint (Ubuntu derivative) by updating to the latest ALSA drivers from Ubuntu Audio Dev team.

Code:
sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-2.6.38-8-generic
replace the kernel version in the last comand with yours.
 
Old 03-26-2012, 07:15 PM   #8
jmlm_1970
Member
 
Registered: Nov 2010
Location: Aveiro, Portugal, Europe
Posts: 38
Blog Entries: 1

Rep: Reputation: 1
The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internal Laptop Mic Not Working - Fujitsu Lifebook A6110 sstoveld Linux - Laptop and Netbook 1 03-26-2012 08:14 PM
sound card order on lenovo x120e, HDMI vs sound card npdawson Slackware 15 05-15-2011 07:46 PM
[UBUNTU] Internal mic doesn't work on easynote TR87 gullge Linux - Laptop and Netbook 2 09-12-2010 12:15 AM
Problem with 3G/HDMA internal broadband on Lenovo G560 in Ubuntu test009 Linux - Laptop and Netbook 11 06-10-2010 06:09 AM
lenovo s10e internal microphone doesnt work (ubuntu remix 9.04 ) mahmoudspeedo Linux - Hardware 2 09-16-2009 05:06 AM


All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration