LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Closed Thread
 
Search this Thread
Old 03-23-2006, 07:25 AM   #76
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65

Cool. Keep on pluggin'. And if you just use 'make xconfig', 'make', ans 'make modules_install', it will be a much shorter recompile after the first long one.(It's what I do for minor tweaks.)
 
Old 03-23-2006, 01:10 PM   #77
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
ok

here's the latest, I think I'm setup with DRI ? not sure.

**don't anyone use what I'm doing until CW says so as I'm new OKAY **

1. to use ATI i can only get them to install on kernel version 2.6.10 or earlier. nothing later. when installing on aything later during install of drivers, it gives errors.
2. i'm using ati drivers at the site right now, used openorg drivers; filename fglrx_6_8_0-8.23.7-1.i386.rpm

3. then went to shilo's post "this is how..." and followed his directions to the letter; except i didnt modprobe agp, chipset as I tried and said not found. but config_agp=y in kernel config that i made for 2.6.10

4. after installing ati i ran the new command for these drivers "aticonfig --initial"

5. then i ran aticonfig --help to see options.

6. then i ran "aticonfig --initial --input=/etc/X11/xorg.conf" so it uses my xorg, i got this from the help file.

7. then i used "aticonfig --resolution=1024x768" as the default install of the drivers is way too high of resolution and i'm half blind and mostly stupid

8. reboot, no problems.

9. I get this output now when i run "glxgears" and got this output:

bash-3.00# glxgears
15116 frames in 5.0 seconds = 3023.200 FPS
16070 frames in 5.0 seconds = 3214.000 FPS
16170 frames in 5.0 seconds = 3234.000 FPS
20217 frames in 5.0 seconds = 4043.400 FPS
15059 frames in 5.0 seconds = 3011.800 FPS
16174 frames in 5.0 seconds = 3234.800 FPS
16173 frames in 5.0 seconds = 3234.600 FPS
16173 frames in 5.0 seconds = 3234.600 FPS

I believe this is good? What do you think.

Oh I'm only getting 60hz sent to my monitor and screen flickers. Have not played with this yet.

It appears that I have to input alot of strings for resolutioin, etc into the aticonfi in console. there is no fglrxconfig anymore in this ati driver.
 
Old 03-23-2006, 01:52 PM   #78
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Cool. You got it to work.

Don't know about screen flicker, but I can set mine in KDE with the display properties(I mostly use a laptop, so 60hz is fine.)
 
Old 03-23-2006, 02:34 PM   #79
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
I printed out "aticonfig --help" so I could tweak and play

There are alot of options that can/not be set.

I'm loading in Unreal Tournament 2004; that will be my true judge how these drivers work. Takes a long time install, 6 cd's .
 
Old 03-23-2006, 03:14 PM   #80
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
No luck for UT.

my var/log shows DRI fails initially, but then I can see that it's calling for the ATI drivers, they load fine.

then i get this successful message:

(II) fglrx(0): DRI initialization successfull!
(II) fglrx(0): front overlay: 0xb10a7000
(II) fglrx(0): back overlay: 0xb12b4000
(II) fglrx(0): video overlay: 0xb14c1000
(II) fglrx(0): FBADPhys: 0xb0000000 FBMappedSize: 0x00954000
(II) fglrx(0): Splitting WC range: base: 0xb0000000, size: 0x954000
(II) fglrx(0): Splitting WC range: base: 0xb0800000, size: 0x154000
(II) fglrx(0): Splitting WC range: base: 0xb0900000, size: 0x54000
(II) fglrx(0): Splitting WC range: base: 0xb0940000, size: 0x14000
(==) fglrx(0): Write-combining range (0xb0950000,0x4000)
(==) fglrx(0): Write-combining range (0xb0940000,0x14000)
(==) fglrx(0): Write-combining range (0xb0900000,0x54000)
(==) fglrx(0): Write-combining range (0xb0800000,0x154000)
(==) fglrx(0): Write-combining range (0xb0000000,0x954000)
(II) fglrx(0): FBMM initialized for area (0,0)-(1600,1528)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1600,1200) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor (scanline 1200)
(II) fglrx(0): Largest offscreen area available: 1600 x 320
(WW) fglrx(0): Option "(null)" is not used
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Solid Lines
Dashed Lines
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): X context handle = 0x00000001
(II) fglrx(0): [DRI] installation complete
(II) fglrx(0): Direct rendering enabled
(II) Loading extension FGLRXEXTENSION

But the game is giving me this error:

Log: OpenGL: Failed to get a multisample GL context
Log: OpenGL: Forcibly disabled pixel shaders.
Log: OpenGL: Forcibly disabled render-to-texture.

I suspect? but not sure it's somehting I have to tweak in my aticonfig.

There is no more flgrxonfig anymore to walk you thru. Really weird now.
 
Old 03-23-2006, 08:09 PM   #81
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Anybody with ATI experience? This poor young feller is having a TIME!
 
Old 03-24-2006, 06:15 AM   #82
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Well, I decided to restore the pc from an image of Mepis on this desktop pc; and launch Unreal Tournament 2004 and see the log file there.

For the record, I get the same exact errors in Mepis when I launch the game that I noted previously. However the game does run in Mepis and not in slackware, not yet I'll get it tho.

But I do have the direct rendering in slackware and learend to compile new kernel. Thank you so much CW.
 
Old 03-24-2006, 07:48 AM   #83
CrEsPo
Member
 
Registered: Apr 2005
Location: Canada
Distribution: Slackware 12
Posts: 184

Rep: Reputation: 30
I installed the ATi drivers and I'm running 1152x864, but it seems my Hz was set lower. I set my Hz in my xorg.conf to 75.0-75.0 to force 75, but it still seems to be around 60 Hz. Any help appreciated in getting higher Hz .

I'm installing a game (ET) right now to test because glxgears seems good. If it works, I'll post how I installed the drivers for you Old_Fogie so maybe they will work for yourself.

Code:
[~]$ glxgears
39375 frames in 5.0 seconds = 7875.000 FPS
41911 frames in 5.0 seconds = 8382.200 FPS
41911 frames in 5.0 seconds = 8382.200 FPS
41903 frames in 5.0 seconds = 8380.600 FPS
41915 frames in 5.0 seconds = 8383.000 FPS
[~]
 
Old 03-24-2006, 08:04 PM   #84
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
OMG OMG OMG I GOT IT!!!!!!! I GOT IT!!!

I just installed fglrx_6_8_0-8.19.10-1.i386.rpm.

Converted it to tgz and followed Shilo's install info.

Except I did not manually load the agp stuff he mentions.

Rebooted, I could not run glxgears, i get could not open display (null).

Launched unreal tournament 2004 and it worked.

200 FPS with all details of the game on high in single player mode.

I never ever could get that in windows.

Opened up console and ran glxgears and got 4000 fps with about a 4" diagonal window.

Weird.

I think my error may have been that I never added this to my fstab as ATI says to do in their readme file: (somehting to do with posix memory)

tmpfs /dev/shm tmpfs defaults 0 0

I chose this driver version becuase it has "fglrxconfig" that has a walk thru kind of like when you run "xorgconfig". The newer driver version doesnt do that.

GLXINFO in console now reports that I have DRI enabled.

I saved the entire console history of how I converted to tgz and the commands i used to install and what I input thru "fglrxconfig" if any wants me to post the session. I am going to save it for myself just in case.

WOOHOO...Unreal Tournament 2004 on Slackware. Fogie for the win
 
Old 03-24-2006, 10:19 PM   #85
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Quote:
Originally Posted by CrEsPo
I installed the ATi drivers and I'm running 1152x864, but it seems my Hz was set lower. I set my Hz in my xorg.conf to 75.0-75.0 to force 75, but it still seems to be around 60 Hz. Any help appreciated in getting higher Hz .[~][/code]

with these drivers, and my horizontal at 50-90 and vertical at 50-160 my monitor is telling me that it is receiving 85 hz, and it is flicker free.

what version kernel and ATI drivers are you using. I'd be interested to see how you configured the ATI card via the console aticonfig and each paramater; and where you find that these settings are getting saved to on your hard drive with these new drivers as I couldnt get it to write to my xorg.conf file.

if you want to email me directly it's fine.
 
Old 03-25-2006, 12:11 AM   #86
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Hey, Fogie, can you consolidate all you did to get your ATI card working? I'll add it to the top post here...

GREAT TO HEAR!!!
 
Old 03-25-2006, 12:24 AM   #87
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
I sure can and will do, it's the least I can do
 
Old 03-25-2006, 01:28 AM   #88
CrEsPo
Member
 
Registered: Apr 2005
Location: Canada
Distribution: Slackware 12
Posts: 184

Rep: Reputation: 30
It was a success for me also . Initially failed, but changed a setting and it worked. Was actually the setting you removed. Here's what I did:

-----

1. Downloaded latest drivers
ati-driver-installer-8.23.7-i386.run
fglrx_6_8_0-8.23.7-1.i386.rpm

2. Ran the installation package using automatic installation after using "chmod +x" on it

3. Ran aticonfig --initial

4. Added the following into the Module section
Code:
# This loads the DRI module
        Load  "dri
5. Added the following into the DRI section
Code:
Mode         0666
6. Changed my VideoRam under device to the amount of my video card

7. Added the following to /etc/fstab
Code:
tmpfs /dev/shm tmpfs defaults 0 0
8. Mounted it
Code:
mount /dev/shm
9. Made sure it mounted
Code:
mount | grep "shm"
-----

After doing all that I got Enemy Territory up and running. Pretty much followed the first post in this topic with some added tidbits. Thanks for the post, this is the first time I got the ATi drivers working in Linux .
 
Old 03-25-2006, 01:44 AM   #89
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
yeah woot good for you.

altho i think you misunderstoood me tho.

i did NOT have that line in my /etc/fstab and ATI wants it so like you I added it and then success.

i went in to an image that i have of mepis when loaded on this pc and i opened the mepis' fstab file and it was there.

so debian/mepis put's that line in and slackware does not. this is apparently something that may need to be stickied here in the forums that POSIX shared memory is needed.

i too put all my install stuff into an email and sent it off to CWWilson a few minutes ago.

it's kind of long but is step by step as I copied my console as I went along.

You say you did this:

"Ran the installation package using automatic installation after using "chmod +x" on it"

hahahah i'm so noob...i didn't know you could that..I did it the long and hard way but I'm up. But I'm gonna make a note of that for later when I try the later versions of the driver out.

question: when you run that "aticonfig --initial" and then "aticonfig" you do not get a walk thru wizard like you do when you run "xorgconfig" in console right. ATI got rid of that wizard in the 20 series drivers right? Or did I miss reading how to get that wizard back. if it's gone i hope they bring it back.
 
Old 03-25-2006, 09:24 AM   #90
CrEsPo
Member
 
Registered: Apr 2005
Location: Canada
Distribution: Slackware 12
Posts: 184

Rep: Reputation: 30
Quote:
Originally Posted by Old_Fogie
question: when you run that "aticonfig --initial" and then "aticonfig" you do not get a walk thru wizard like you do when you run "xorgconfig" in console right. ATI got rid of that wizard in the 20 series drivers right? Or did I miss reading how to get that wizard back. if it's gone i hope they bring it back.
You don't need to run it twice. When you run "aticonfig --initial" it will add a couple things to your current xorg.conf . Once done that you make a couple tweaks to your xorg.conf .

There is no wizard, it's gone. It's all automatic now with aticonfig.

Quote:
ATI Initial Configuration:
--initial
Generate a default ATI device section in the configuration file which
is capable of loading the fglrx driver.
--initial=dual-head
Same as '--initial' but generate a basic dual head configuration file.
 
  


Closed Thread

Tags
3d, acceleration, ati, enabling, fglrx, glx, intel, nvidia, s3, savage, slackware, via, video, x11, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enabling hardware acceleration PennyroyalFrog Linux - Newbie 5 02-26-2010 11:21 AM
xorg-x11 7.0 and exa acceleration jtshaw Linux - Software 0 12-19-2005 07:42 AM
3d acceleration and X11 bspus Linux - Newbie 3 09-06-2005 06:05 AM
Problem Enabling 3D Hardware acceleration. mir_sheely Linux - Hardware 0 06-14-2004 12:37 PM
Audigy Sound card and enabling 3D acceleration for GeoForce3 ti 500 heavyarmor4ever Linux - Newbie 1 01-03-2003 09:27 PM


All times are GMT -5. The time now is 05:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration