LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2004, 11:58 PM   #1
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Rep: Reputation: 15
Strange re-login behavior


I have Mandrake 9.2 set to auto login into my account on boot-up. However, if I have to manually logout for whatever reason, I get to the login screen showing me the various users to log in, which desktop, etc.

Recently I did a clean reinstall of 9.2. Again, I chose to auto login @ bootup. However, now when I do a logout, instead of going to the login screen, it just logs me right back in again. Almost like the effect you'd get if the computer did a restart when you actually tried to execute a shutdown.

What's going on?
 
Old 07-19-2004, 02:33 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Is it possible that you forgot to create any extra users and therefore there are no other accounts for you to log into?
 
Old 07-19-2004, 07:24 AM   #3
wdwd
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Rep: Reputation: 0
I had to turn auto login off to make mine stop doing that.
 
Old 07-19-2004, 08:27 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
I did find one other thing. Apparently there are two ways to autologin. The Mandrake way and the KDE way. Maybe you should check both of them to see if one is overriding the other.

Last edited by adz; 07-19-2004 at 08:28 AM.
 
Old 07-19-2004, 08:30 AM   #5
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
There aren't any other users. Just mine and root. But that is the strange part. My previous install of Linux had the same config - just mine and root. It was also set to autologin, and it did that fine. But if I then logged out, I'd get the typical login screen. Whereas now it just logs itself right back in.

Quote:
Originally posted by adz
I did find one other thing. Apparently there are two ways to autologin. THe Kandrake way and the KDE way. Maybe you should check both of them to see if one is overriding the other.
Where did you find these two ways? The only autologin I found was going through "Configure your computer" under the "Boot" section.
 
Old 07-19-2004, 09:47 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
The KDE method is in the Login Manager section of KDE Control Centre and the Mandrake method is in the Boot section of Mandrake Control Centre. Before you ask me a whole bunch of details about this, let it be known that I use neither Mandrake nor KDE. This was something I found on the web in my travels.

Check both of those places and see if there's some conflict.
 
Old 07-19-2004, 05:16 PM   #7
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
I found both sections, but both seem to be okay. I will play around a bit and see if I can get this to work. What's baffling is that I didn't do any of this on my previous install. Yet it worked as I described above.
 
Old 07-19-2004, 06:58 PM   #8
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Maybe you should try wdwd's suggestion. Turn auto-login off, optionally reboot, then turn it back on again. Maybe Mandrake is a little confused, and sometimes that shakes something loose. Or maybe you updated something (via the security updates) that wasn't there during your last install, that "broke" auto-login just a little.
 
Old 07-19-2004, 07:48 PM   #9
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Well maybe try KDE's autlogin instead. That may work as you wished.
 
Old 07-19-2004, 11:20 PM   #10
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by motub
Maybe you should try wdwd's suggestion. Turn auto-login off, optionally reboot, then turn it back on again. Maybe Mandrake is a little confused, and sometimes that shakes something loose. Or maybe you updated something (via the security updates) that wasn't there during your last install, that "broke" auto-login just a little.
Yeah, I can see if that helps things! Maybe it does need to be shaken loose!

Quote:
Originally posted by adz
Well maybe try KDE's autlogin instead. That may work as you wished.
From what I could tell, KDE showed autologin enabled. Perhaps as you said earlier, I need to disable this one and see if the Mandrake Control Center still shows it enabled. That could be the cause as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange VSFTP Login Behavior clinger Linux - Networking 0 01-30-2005 06:49 PM
Very Strange Behavior raysr Mandriva 4 08-31-2004 02:06 PM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 02:42 PM
strange behavior abhijit Linux - General 3 07-09-2003 11:25 PM
strange java behavior neo77777 Linux - General 7 06-21-2002 01:36 AM


All times are GMT -5. The time now is 08:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration