LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
Password
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.

Notices



Reply
 
Search this Thread
Old 03-18-2009, 12:31 PM   #16
mikese
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Rep: Reputation: 0

Just got CUPS working on debian after moving from SuSE thanks to the how to haven't been able to print for a few days we have way to much to print and have a pallet of copy paper that just came in.

Last edited by XavierP; 07-24-2009 at 09:25 AM. Reason: Superfluous Advertising Removed
 
Old 06-17-2009, 04:42 PM   #17
mikese
LQ Newbie
 
Registered: Mar 2009
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by busbarn View Post
I know that Ubuntu uses users differently. It may work if you use the sudo command. Just a thought.
Thats all we use in our office as for our printers they are all networked but one is broke some one was filling a stapler over it and dropped staples into it. You can imagine what that's done to it's printing capabilities.

Last edited by XavierP; 07-24-2009 at 09:25 AM. Reason: Superfluous Advertising Removed
 
Old 04-20-2010, 09:25 PM   #18
chrischantrill
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Rep: Reputation: 0
Remote Printing Ubuntu with Client and Server

Here's my experience setting up a Ubuntu client to print to a printer on another Ubuntu box:

Printer server (IP 192.168.1.6) is Ubuntu Karmic 9.10 with HP 5550 on USB port:
Printer client is Ubuntu Karmic 9.10.

Modifications to etc/cups/cupsd.conf on Server box:

1. Adding "ServerName 192.168.1.6" doesn't seem to make any difference.

2. In the Listen section you must add "Listen server-ip" after "Listen localhost:631":

Code:
# Only listen for connection from the local machine.
  Listen localhost:631
  Listen 192.168.1.6
  Listen /var/run/cups/cups.sock
3. You must add "Allow" for subnet in Location section:

Code:
# Restrict access to the server...
<Location />
  Order allow,deny
  Allow From 192.168.1.* 
</Location>
Restart CUPS after making changes to cupsd.conf on the Server box.

I found that you must add a /etc/cups/client.conf file on the Client box to point to the Server box:

Code:
# Servername
ServerName 192.168.1.6
Restart CUPS after saving /etc/cups/client.conf on the Client box.

Now, if you try to print from an application in the Client box, the printer should appear in the Print dialog box. No need to Add Printer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Setting up a PDF printer in CUPS (in my case in Slackware) Tinkster LinuxAnswers Discussion 7 11-18-2008 03:31 AM
Help setting up printer using cups jbraum Linux - Networking 1 11-19-2005 05:32 PM
Setting up HP printer with CUPS tuxedo-notebook Linux - Hardware 3 03-31-2005 09:12 PM
setting up a printer with cups on RH7 for windows with samba TreeHugger Linux - Networking 2 11-11-2004 12:31 PM
Setting Up My HP Printer With CUPS AFI_Flame Linux - Newbie 15 07-22-2004 11:02 AM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration