LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
Password
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.

Notices

Reply
 
Search this Thread
Old 07-04-2005, 11:11 AM   #1
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Rep: Reputation: 30
Post DISCUSSION: Setting Up a Network Printer using CUPS


This thread is to discuss the article titled: Setting Up a Network Printer using CUPS
 
Old 07-19-2005, 07:01 PM   #2
dom3lmr
LQ Newbie
 
Registered: Jun 2004
Location: London, UK
Distribution: Knoppix 3.2 - Debian GNU/Linux
Posts: 3

Rep: Reputation: 0
Yep, that looks very cool: a nice succinct howto I am bound to say! But then there are the obscure hiddens and gotchas like: what do you put in the printer URI if you are using a multi-function printer e.g.: HP Officejet R45 that uses hpoj?

Also you refer to the ipp printer path as ipp://server_ip_address/printer/printer_name which unfortunately is not necessarily always the case. Is that printer singular or printers plural and does that have to match the <Location /Printers>tag in the cupsd.conf file?

I am afraid that I am defeated by it all!

Code:
Unable to connect to IPP host
 
Old 07-20-2005, 09:22 AM   #3
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
Good question! Since I don't have a multi-function printer to test, I can offer a big I don't know. My apologies.

However, I do know that the "printer" is singular and the printer_name needs to match the cupsd.conf file on the server machine. I got most of my info from this CUPS System Amdministrator's Guide. That may give you some more info for a muliuse printer.
 
Old 07-25-2005, 02:51 PM   #4
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Rep: Reputation: 30
Good info... but

After installing CUPS, /etc/rc.d/rc.cups is not executable by default.
One needs to "chmod +x /etc/rc.d/rc.cups" then execute it.

Once it is changed to executable, it will start at boot.
If it is not chmodded, you cannot run "/etc/rc.d/rc.cups start" like the tutorial says.
Just a FYI.
 
Old 09-04-2005, 09:05 AM   #5
wylie1001
Member
 
Registered: Jul 2002
Location: USA
Distribution: Slackware 10.2
Posts: 53

Rep: Reputation: 15
Wink

Hello all,
This is good info as in most of LQ. I have a printer it is an HP photosmart 2710 with a network connection sitting on my network with an ip of xxx.x.xx.xxx . I have spent numerous hours trying to get it to work. This printer is not connected to any computer on my network. I have cups installed nothing special there. I also removed LPRNG this program conflicts with cups. In cups set up your printer and set it to Device URI: socket://xxx.xx.x.xxx the ip of the printer also set it for the default printer and mine worked like a champ. After doing hours of reading and hunting I could not find info for stand alone printers on a network. I also used the web browser to set up the printer on cups using http://127.0.0.1:631 use your root account and password and configure the printer. Also start up /etc/rc.d/rc.cups . I wanted to share this because printers have been a real sore spot for me for the past years using Linux.
Rick
 
Old 09-07-2005, 10:53 AM   #6
ylikone
Member
 
Registered: Dec 2004
Location: Ontario, Canada
Distribution: ArchLinux, VectorLinux, Ubuntu, Debian, Linspire
Posts: 66

Rep: Reputation: 15
Talking

I have been running an HP Photosmart 8450 as a stand-alone networked printer... and having no problems printing to it with both my windows and Linux computers.

As a "for example", here are the approximate steps I took to make it work...

-----

Go to

http://sourceforge.net/project/showf...group_id=16846

and download / install the latest hpijs and hplip.

Use the command "hp-makeuri" to get a Device URI. Make sure to specify the IP address of the printer you want to setup.

Go to

http://www.cups.org/

and download / install the latest cups, if your distro does not already have it setup. Next, go to

http://www.linuxprinting.org/printer_list.cgi?make=HP

and download the appropriate .ppd file for your printer and copy it to /usr/share/cups/model.

Load up a web browser as root and go to

http://127.0.0.1:631/

You should now see the cups web interface. Go to add a new printer... when you get to the Device URI field, enter the string given previously by the "hp-makeuri" command, which should look something like

hp:/net/Photosmart_8400_series?ip=192.168.0.20

Print a test page and see if it works.
 
Old 09-04-2006, 12:10 PM   #7
mitchell1000
LQ Newbie
 
Registered: Feb 2004
Posts: 2

Rep: Reputation: 0
Very nice article on cups setup.

One error

the ip address of the printer is

ipp://192.168.1.55:631/printers/printer_name

notice that you need the :631 port number
as well as
printers not "printer"

with this correction, the "how to" above for cups works!

Mitchell
 
Old 09-13-2006, 06:56 AM   #8
tagore
LQ Newbie
 
Registered: Feb 2006
Posts: 3

Rep: Reputation: 0
Extension: mail pdf-Output to user

This howto is great, thanks.

A usefull extension in a LAN-Enviroment could be to mail pdf-output to the user. (mutt can send multipart-mail in batchmode.)


/usr/lib/cups/backend/pdf:
...
if [ "$2" != "" ]; then
mutt -n -a $OUTPUTFILENAME -s "pdf distilled by cups" $2 < /dev/null
fi
rm $OUTPUTFILENAME
 
Old 12-02-2006, 10:39 AM   #9
halw
Member
 
Registered: May 2006
Location: Michigan
Distribution: Ubuntu 10.04, Mepis 8.5, Mepis 11
Posts: 31

Rep: Reputation: 15
This procedure does not work for me. When attempting to 'add printer' using localhost:631 am asked to enter User Name and Password for CUPS. Have tried Administrator(root) and password for host and user id & password for client.

Client system is Kubuntu 6.06.
 
Old 12-19-2006, 02:58 AM   #10
pietie
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by halw
This procedure does not work for me. When attempting to 'add printer' using localhost:631 am asked to enter User Name and Password for CUPS. Have tried Administrator(root) and password for host and user id & password for client.

Client system is Kubuntu 6.06.
neither for me well the root + root passwd... I am running SuSE 10.1
 
Old 01-17-2007, 07:20 PM   #11
busbarn
Member
 
Registered: Feb 2002
Location: Denver, CO US
Distribution: Arch
Posts: 453

Original Poster
Rep: Reputation: 30
I know that Ubuntu uses users differently. It may work if you use the sudo command. Just a thought.
 
Old 12-13-2007, 03:50 PM   #12
fbufkin
LQ Newbie
 
Registered: Nov 2005
Distribution: SuSE 9.1
Posts: 10

Rep: Reputation: 0
This was most helpful to me. I've had networking to Windows printers and to Linux printers from windows down for some time, but this was the first time I have tried networking printers in a Linux only network. I hit one stumbling block not mentioned, if you are running Firestarter or another "firewall" program, be sure and tell it you have to have port 631 open. Took me a couple of hours of work to figure out what the problem was.
 
Old 01-29-2008, 12:19 AM   #13
romulas
LQ Newbie
 
Registered: Jan 2008
Location: Idaho
Distribution: Fedora Core
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by ylikone View Post
You should now see the cups web interface. Go to add a new printer... when you get to the Device URI field, enter the string given previously by the "hp-makeuri" command, which should look something like

hp:/net/Photosmart_8400_series?ip=192.168.0.20

Print a test page and see if it works.
Hey that "hp-makeuri" is an awesome command! Thanks ylikone!
 
Old 02-16-2009, 11:02 AM   #14
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 301

Rep: Reputation: 32
Thumbs up Thank you so much!

I've just wasted two days trying to get this to work and finally found your post! I only had to change a couple things and it works like a charm!

Thank you, thank you, thank you!
 
Old 03-03-2009, 04:36 PM   #15
Bill-3
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
Additional settings to try......

Hi,

I followed the above thread and comments - but no joy.

My problem was with the server. The printers I'd set up (different
dpis) were visible from the client but the client couldn't print
to the printers. I'd get error messages.

I changed a few more settings and lo and behold.... there was joy.

These were:

#To listen to all hosts on your subnet - not just the server....
From Listen localhost:631 to Listen *:631

#To allow other hosts on the subnet to access the server....
Allow from @LOCAL

#To broadcast to other hosts on the subnet from the server....
BrowseAddress @LOCAL

# @LOCAL eliminates the need to know other client addresses on the lan.
# Probably quite useful in the case of DHCP.

b.

Last edited by Bill-3; 03-03-2009 at 04:46 PM. Reason: Adding additional information
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Setting up a PDF printer in CUPS (in my case in Slackware) Tinkster LinuxAnswers Discussion 7 11-18-2008 02:31 AM
Help setting up printer using cups jbraum Linux - Networking 1 11-19-2005 04:32 PM
Setting up HP printer with CUPS tuxedo-notebook Linux - Hardware 3 03-31-2005 08:12 PM
setting up a printer with cups on RH7 for windows with samba TreeHugger Linux - Networking 2 11-11-2004 11:31 AM
Setting Up My HP Printer With CUPS AFI_Flame Linux - Newbie 15 07-22-2004 10:02 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration