LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   LinuxAnswers Discussion (http://www.linuxquestions.org/questions/linuxanswers-discussion-27/)
-   -   DISCUSSION: Setting Up a Network Printer using CUPS (http://www.linuxquestions.org/questions/linuxanswers-discussion-27/discussion-setting-up-a-network-printer-using-cups-339904/)

busbarn 07-04-2005 12:11 PM

DISCUSSION: Setting Up a Network Printer using CUPS
 
This thread is to discuss the article titled: Setting Up a Network Printer using CUPS

dom3lmr 07-19-2005 08:01 PM

Yep, that looks very cool: a nice succinct howto I am bound to say! But then there are the obscure hiddens and gotchas like: what do you put in the printer URI if you are using a multi-function printer e.g.: HP Officejet R45 that uses hpoj?

Also you refer to the ipp printer path as ipp://server_ip_address/printer/printer_name which unfortunately is not necessarily always the case. Is that printer singular or printers plural and does that have to match the <Location /Printers>tag in the cupsd.conf file?

I am afraid that I am defeated by it all! :confused:

Code:

Unable to connect to IPP host

busbarn 07-20-2005 10:22 AM

Good question! Since I don't have a multi-function printer to test, I can offer a big I don't know. My apologies.

However, I do know that the "printer" is singular and the printer_name needs to match the cupsd.conf file on the server machine. I got most of my info from this CUPS System Amdministrator's Guide. That may give you some more info for a muliuse printer.

username17 07-25-2005 03:51 PM

Good info... but

After installing CUPS, /etc/rc.d/rc.cups is not executable by default.
One needs to "chmod +x /etc/rc.d/rc.cups" then execute it.

Once it is changed to executable, it will start at boot.
If it is not chmodded, you cannot run "/etc/rc.d/rc.cups start" like the tutorial says.
Just a FYI.

wylie1001 09-04-2005 10:05 AM

Hello all,
This is good info as in most of LQ. I have a printer it is an HP photosmart 2710 with a network connection sitting on my network with an ip of xxx.x.xx.xxx . I have spent numerous hours trying to get it to work. This printer is not connected to any computer on my network. I have cups installed nothing special there. I also removed LPRNG this program conflicts with cups. In cups set up your printer and set it to Device URI: socket://xxx.xx.x.xxx the ip of the printer also set it for the default printer and mine worked like a champ. After doing hours of reading and hunting I could not find info for stand alone printers on a network. I also used the web browser to set up the printer on cups using http://127.0.0.1:631 use your root account and password and configure the printer. Also start up /etc/rc.d/rc.cups . I wanted to share this because printers have been a real sore spot for me for the past years using Linux.
Rick

ylikone 09-07-2005 11:53 AM

I have been running an HP Photosmart 8450 as a stand-alone networked printer... and having no problems printing to it with both my windows and Linux computers.

As a "for example", here are the approximate steps I took to make it work...

-----

Go to

http://sourceforge.net/project/showf...group_id=16846

and download / install the latest hpijs and hplip.

Use the command "hp-makeuri" to get a Device URI. Make sure to specify the IP address of the printer you want to setup.

Go to

http://www.cups.org/

and download / install the latest cups, if your distro does not already have it setup. Next, go to

http://www.linuxprinting.org/printer_list.cgi?make=HP

and download the appropriate .ppd file for your printer and copy it to /usr/share/cups/model.

Load up a web browser as root and go to

http://127.0.0.1:631/

You should now see the cups web interface. Go to add a new printer... when you get to the Device URI field, enter the string given previously by the "hp-makeuri" command, which should look something like

hp:/net/Photosmart_8400_series?ip=192.168.0.20

Print a test page and see if it works.

mitchell1000 09-04-2006 01:10 PM

Very nice article on cups setup.

One error

the ip address of the printer is

ipp://192.168.1.55:631/printers/printer_name

notice that you need the :631 port number
as well as
printers not "printer"

with this correction, the "how to" above for cups works!

Mitchell

tagore 09-13-2006 07:56 AM

Extension: mail pdf-Output to user
 
This howto is great, thanks.

A usefull extension in a LAN-Enviroment could be to mail pdf-output to the user. (mutt can send multipart-mail in batchmode.)


/usr/lib/cups/backend/pdf:
...
if [ "$2" != "" ]; then
mutt -n -a $OUTPUTFILENAME -s "pdf distilled by cups" $2 < /dev/null
fi
rm $OUTPUTFILENAME

halw 12-02-2006 11:39 AM

This procedure does not work for me. When attempting to 'add printer' using localhost:631 am asked to enter User Name and Password for CUPS. Have tried Administrator(root) and password for host and user id & password for client.

Client system is Kubuntu 6.06.

pietie 12-19-2006 03:58 AM

Quote:

Originally Posted by halw
This procedure does not work for me. When attempting to 'add printer' using localhost:631 am asked to enter User Name and Password for CUPS. Have tried Administrator(root) and password for host and user id & password for client.

Client system is Kubuntu 6.06.

neither for me well the root + root passwd... I am running SuSE 10.1

busbarn 01-17-2007 08:20 PM

I know that Ubuntu uses users differently. It may work if you use the sudo command. Just a thought.

fbufkin 12-13-2007 04:50 PM

This was most helpful to me. I've had networking to Windows printers and to Linux printers from windows down for some time, but this was the first time I have tried networking printers in a Linux only network. I hit one stumbling block not mentioned, if you are running Firestarter or another "firewall" program, be sure and tell it you have to have port 631 open. Took me a couple of hours of work to figure out what the problem was.

romulas 01-29-2008 01:19 AM

Quote:

Originally Posted by ylikone (Post 1840300)
You should now see the cups web interface. Go to add a new printer... when you get to the Device URI field, enter the string given previously by the "hp-makeuri" command, which should look something like

hp:/net/Photosmart_8400_series?ip=192.168.0.20

Print a test page and see if it works.

Hey that "hp-makeuri" is an awesome command! Thanks ylikone!

checkmate3001 02-16-2009 12:02 PM

Thank you so much!
 
I've just wasted two days trying to get this to work and finally found your post! I only had to change a couple things and it works like a charm!

Thank you, thank you, thank you!

Bill-3 03-03-2009 05:36 PM

Additional settings to try......
 
Hi,

I followed the above thread and comments - but no joy.

My problem was with the server. The printers I'd set up (different
dpis) were visible from the client but the client couldn't print
to the printers. I'd get error messages.

I changed a few more settings and lo and behold.... there was joy.

These were:

#To listen to all hosts on your subnet - not just the server....
From Listen localhost:631 to Listen *:631

#To allow other hosts on the subnet to access the server....
Allow from @LOCAL

#To broadcast to other hosts on the subnet from the server....
BrowseAddress @LOCAL

# @LOCAL eliminates the need to know other client addresses on the lan.
# Probably quite useful in the case of DHCP.

b.


All times are GMT -5. The time now is 03:17 PM.