LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-23-2006, 11:26 AM   #1
Abomb
Member
 
Registered: Dec 2005
Location: ~/
Distribution: Ubuntu
Posts: 156

Rep: Reputation: 30
Weird GRUB Issue.


Hey guys,

So I'm dual booting a machine with XP and Ubuntu. However, whenever I just turn on the computer it goes straight to XP but when I reboot or do anything after wards, then the GRUB menu shows up. The main hard drive (windows) is a SATA and the second hard drive (Linux) is an IDE set to slave. Any ideas as to why this would happen?

Thanks guys!
 
Old 11-24-2006, 04:37 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
Do you have the boot order changed in your BIOS? This did some funny things here so that I had to change it to get GRUB working as intended.
 
Old 11-24-2006, 04:43 PM   #3
Abomb
Member
 
Registered: Dec 2005
Location: ~/
Distribution: Ubuntu
Posts: 156

Original Poster
Rep: Reputation: 30
My current boot order is: Floppy, Cd-Rom, then hdd0. I tried changing it to hdd1 but that didn't work. Also I tried changing the setting "Boot Other Device" to enabled and disabled and that didn't seem to work. Should I try setting the IDE driver to master instead of slave?

Thanks for the reply!
 
Old 11-24-2006, 04:52 PM   #4
oldkawE
LQ Newbie
 
Registered: Jul 2005
Location: Maryland
Distribution: Kubuntu Edgy
Posts: 4

Rep: Reputation: 0
I have a similar setup - XP is on a SATA drive and Kubuntu on an IDE drive. I put grub on the IDE drive and boot that drive first (boot order in BIOS). That way if something happens to the Linux drive, I just change the boot order to boot the SATA drive first and windows is none the wiser. The key thing this requires is for grub to make windows think it is on first drive

Here's an excerpt from my menu.lst file in /boot/grub - remember, grub is installed on the IDE drive

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
root (hd1,0)
savedefault
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

That should do it
 
Old 11-24-2006, 05:17 PM   #5
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
I am not sure about master/slave settings -- I can only tell that I have both set to master or "cable select", but both are recognized as masters. My BIOS's boot sequence seems to put IDE (hdc in my setup) higher than SATA (sda). What looks your /boot/grub/devices.map like? It didn't matter how I changed the boot order in my BIOS, Grub set hdc as my first harddisk to hd(0).
No clue about Windows entry
 
Old 11-24-2006, 06:30 PM   #6
Abomb
Member
 
Registered: Dec 2005
Location: ~/
Distribution: Ubuntu
Posts: 156

Original Poster
Rep: Reputation: 30
Thanks for the replies guys!

My /boot/gurb/device.map

Code:
$ cat /boot/grub/device.map 
(hd0)   /dev/hdd
(hd1)   /dev/sda
And from my /boot/grub/menu.lst

Code:
# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title           Microsoft Windows XP Professional
root            (hd1,0)
savedefault
makeactive
map             (hd0) (hd1)
map             (hd1) (hd0)
chainloader     +1
In my BIOS the boot orders only go from hd0 up to like hd3. It's a pretty old motherboard, got it when sata was just starting off. I could have overlooked something in the BIOS but I didn't see anything.

Any idea on how to check what drive GRUB is installed on? It's been awhile since I installed it that I forgot which hard drive it is on (might be the SATA one with Windows on it).

Thanks guys!
 
Old 11-24-2006, 09:02 PM   #7
oldkawE
LQ Newbie
 
Registered: Jul 2005
Location: Maryland
Distribution: Kubuntu Edgy
Posts: 4

Rep: Reputation: 0
You might have hit it with the drives - don't know how old your MB is but mine is a couple years old. My Award BIOS has, under "Advanced BIOS Features" a selection for "Hard Disk Boot Priority" where I could choose between drives or "Bootable Add-in Cards". The first, second, and third boot devices is listed separately on the "Advanced Bios Features" page and only shows Hard drive as a selection separate from optical, floppy, etc.. From my research at the time, it seems most MB's will boot the IDE controllers before any SATA controller (I assume you are using a SATA controller and not a SATA/IDEconverter connected to the IDE controller) but look around for a similar setting.

Your cold boot going to Windows without GRUB suggests your system is booting the SATA drive first unlike for most MB's (and grub is not there). But why your system picks up Grub on a "hot" reboot is inconsistent unless for some reason, it then boots the IDE drive first (Your Grub menu.lst suggests the IDE drive is booted first and that Grub is located on the IDE drive or hd0). I don't know why the boot order would change between a cold boot and a restart but that's the only thing that makes sense to me - maybe it has something to do with the IDE drive being set to slave. If it's the only drive on the controller, use the end connector on the cable and set the drive to cable select or master as suggested. Don't know if any of this helps - good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird no internet issue. Skuggi Suse/Novell 1 06-03-2006 09:27 PM
a weird issue about which jiawj Red Hat 2 04-26-2005 09:06 AM
weird segfault issue FloydMorrison Linux - Software 4 01-28-2005 12:14 AM
Weird apt issue ? frochet Debian 1 12-31-2004 08:39 AM
Weird 2.6 Kernel issue svarreby Fedora 2 02-18-2004 02:15 PM


All times are GMT -5. The time now is 09:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration