LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-10-2004, 09:56 AM   #1
LaoNiu
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian
Posts: 16

Rep: Reputation: 0
setting LOCALE variables in Debian


I d like to know a way for my user whose locale presently shows:

~$ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

to become

:~$ more .i18n
LANGUAGE=en_GB:en_GB.UTF-8:de
LC_ADDRESS=en_GB.UTF-8
LC_COLLATE=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
XIM=scim
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LANG=en_GB.UTF-8
LC_MESSAGES=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_TELEPHONE=en_GB.UTF-8
CONSOLE_NOT_LOCALIZED=yes
LC_MONETARY=en_GB.UTF-8
XIM_PROGRAM=scim
LC_PAPER=en_GB.UTF-8
XMODIFIERS="@im=scim"

I read 'just put it in a '.i18n' file in your homedir , but this is not doing anything for me.
I'm not using ~/.xsession definition files for each user at the moment, and I wish it werent necessary.. Any ideas?

Last edited by LaoNiu; 11-10-2004 at 10:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
Setting locale failed linx win Debian 1 04-02-2005 10:46 AM
locale setting ’ mnaumanca Linux - Software 0 02-18-2005 04:39 PM
Changing locale setting. kponenation Slackware 3 02-17-2005 05:17 PM
[sid] setting locale guldo Debian 3 02-03-2004 09:47 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration