LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-12-2009, 01:51 AM   #1
miaomiaoga
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586 (From Installation of SKYPE)RHEL


I was noticed the below error message when I was installing the SKYPE linux version downloaded from the official web site of SKYPE.

Actually I have already installed the QT4 with the highest version correctly even I can used the QT UI for programming now.

But still I faced the problem of lack of libraries afterwards.

Any suggestions?

[root@IT60 LinuxSoftware]# rpm -ivh skype*.rpm
error: Failed dependencies:
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586
 
Old 11-12-2009, 02:13 AM   #2
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,515

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Since you gave no info about your OS, I can only suggest that if you really want to use skype install the statically linked binary:

http://www.skype.com/go/getskype-linux-beta-static

If you don't want deal with problems like these use free software.

Evo2.
 
Old 11-12-2009, 02:56 AM   #3
miaomiaoga
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Dear evo2, Thanks for your rapidly reply on it.

Actually I'm using the RHEL 5.4 for studying these days.

Redhat Server 5.4

Any suggestions?

Benny
 
Old 11-12-2009, 03:06 AM   #4
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,515

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Quote:
Originally Posted by miaomiaoga View Post
Any suggestions?
Yes. I made two in my last post. I suspect that you will probably be happiest following the first of them... the one with the link.

Edit: Ok, one more suggestion. You could try the Fedora 9 pacakge, on the skype download page, the version of qt that it depends on *may* be old enough.

Evo2.

Last edited by evo2; 11-12-2009 at 03:10 AM. Reason: One more suggestion
 
Old 11-12-2009, 03:26 AM   #5
miaomiaoga
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Woh! Got it!

And it's working fine for the version you provided!

http://www.skype.com/go/getskype-linux-beta-static

This version needn't those QT libraries again? It's running now!

In beofre I was using the version called "skype-2.1.0.47-fc10.i586.rpm" that also downloaded from SKYPE official website.

But it's not working as I mentioned above.

Thanks,evo2, Your version is running fine now.

Thanks for your kindly helps again!

Benny
 
Old 11-12-2009, 05:13 AM   #6
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,515

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Quote:
Originally Posted by miaomiaoga View Post
Woh! Got it!

And it's working fine for the version you provided!

http://www.skype.com/go/getskype-linux-beta-static

This version needn't those QT libraries again?
They are included. That is what statically linked means.

Quote:
It's running now!

In beofre I was using the version called "skype-2.1.0.47-fc10.i586.rpm" that also downloaded from SKYPE official website.

But it's not working as I mentioned above.
That version was compiled to link dynamically, ie at run time, with the libraries that are in Fedora 10.

Quote:
Thanks,evo2, Your version is running fine now.
Thanks for your kindly helps again!
You're welcome for the help. Feel free to click the thumbs up.

Evo2.
 
Old 12-28-2009, 01:07 AM   #7
niwresh
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586... i get this error.. I'm a newbie in linux.. can anyone help me please..
my OS is GNU/linux.. thanks
 
Old 12-28-2009, 01:13 AM   #8
niwresh
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by miaomiaoga View Post
I was noticed the below error message when I was installing the SKYPE linux version downloaded from the official web site of SKYPE.

Actually I have already installed the QT4 with the highest version correctly even I can used the QT UI for programming now.

But still I faced the problem of lack of libraries afterwards.

Any suggestions?

[root@IT60 LinuxSoftware]# rpm -ivh skype*.rpm
error: Failed dependencies:
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586
hi!
we have same problem my OS is GNU/linux
please help me..
email me @ myelmou@yahoo.com wencabiao@gmail.com thank you

Last edited by niwresh; 12-28-2009 at 01:15 AM. Reason: additional info
 
Old 08-28-2010, 08:15 AM   #9
ashokkumar r a
LQ Newbie
 
Registered: Jun 2010
Location: India, Dindigul
Distribution: RHEL
Posts: 1

Rep: Reputation: 0
Smile

yes it's working properly. but why others that means(gtalk,yahoo massanger) should not publish for Linux user. it was very disappointed to me from google and yahoo. But skype good. Thank you for your information....... very kind of your valuable answer.

Last edited by ashokkumar r a; 08-28-2010 at 08:17 AM.
 
  


Reply

Tags
qt4, skype, x11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] skype installation? levian4 Debian 12 10-04-2009 08:29 PM
Skype and QT4 failed dependencies pmujokeri Linux - Distributions 3 05-22-2009 08:17 AM
Conflicts on FC10 for Skype installation threaderslash Linux - Software 2 04-15-2009 10:21 PM
problem installing skype on RHEL 5.3 faristol Red Hat 1 04-08-2009 03:49 PM
Want to install skype on Fedora 8, 500MB needed to download mrpc_cambodia Fedora 4 05-09-2008 07:08 AM


All times are GMT -5. The time now is 09:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration