LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586 (From Installation of SKYPE)RHEL (http://www.linuxquestions.org/questions/linux-software-2/qt4-x11-%3D-4-2-is-needed-by-skype-2-1-0-47-fc10-i586-from-installation-of-skype-rhel-768586/)

miaomiaoga 11-12-2009 01:51 AM

qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586 (From Installation of SKYPE)RHEL
 
I was noticed the below error message when I was installing the SKYPE linux version downloaded from the official web site of SKYPE.

Actually I have already installed the QT4 with the highest version correctly even I can used the QT UI for programming now.

But still I faced the problem of lack of libraries afterwards.

Any suggestions?

[root@IT60 LinuxSoftware]# rpm -ivh skype*.rpm
error: Failed dependencies:
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586

evo2 11-12-2009 02:13 AM

Since you gave no info about your OS, I can only suggest that if you really want to use skype install the statically linked binary:

http://www.skype.com/go/getskype-linux-beta-static

If you don't want deal with problems like these use free software.

Evo2.

miaomiaoga 11-12-2009 02:56 AM

Dear evo2, Thanks for your rapidly reply on it.

Actually I'm using the RHEL 5.4 for studying these days.

Redhat Server 5.4

Any suggestions?

Benny

evo2 11-12-2009 03:06 AM

Quote:

Originally Posted by miaomiaoga (Post 3753889)
Any suggestions?

Yes. I made two in my last post. I suspect that you will probably be happiest following the first of them... the one with the link.

Edit: Ok, one more suggestion. You could try the Fedora 9 pacakge, on the skype download page, the version of qt that it depends on *may* be old enough.

Evo2.

miaomiaoga 11-12-2009 03:26 AM

Woh! Got it!

And it's working fine for the version you provided!

http://www.skype.com/go/getskype-linux-beta-static

This version needn't those QT libraries again? It's running now!

In beofre I was using the version called "skype-2.1.0.47-fc10.i586.rpm" that also downloaded from SKYPE official website.

But it's not working as I mentioned above.

Thanks,evo2, Your version is running fine now. :)

Thanks for your kindly helps again!

Benny

evo2 11-12-2009 05:13 AM

Quote:

Originally Posted by miaomiaoga (Post 3753911)
Woh! Got it!

And it's working fine for the version you provided!

http://www.skype.com/go/getskype-linux-beta-static

This version needn't those QT libraries again?

They are included. That is what statically linked means.

Quote:

It's running now!

In beofre I was using the version called "skype-2.1.0.47-fc10.i586.rpm" that also downloaded from SKYPE official website.

But it's not working as I mentioned above.
That version was compiled to link dynamically, ie at run time, with the libraries that are in Fedora 10.

Quote:

Thanks,evo2, Your version is running fine now. :)
Thanks for your kindly helps again!
You're welcome for the help. Feel free to click the thumbs up.

Evo2.

niwresh 12-28-2009 01:07 AM

qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586... i get this error.. I'm a newbie in linux.. can anyone help me please..
my OS is GNU/linux.. thanks

niwresh 12-28-2009 01:13 AM

Quote:

Originally Posted by miaomiaoga (Post 3753830)
I was noticed the below error message when I was installing the SKYPE linux version downloaded from the official web site of SKYPE.

Actually I have already installed the QT4 with the highest version correctly even I can used the QT UI for programming now.

But still I faced the problem of lack of libraries afterwards.

Any suggestions?

[root@IT60 LinuxSoftware]# rpm -ivh skype*.rpm
error: Failed dependencies:
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586

hi!
we have same problem my OS is GNU/linux
please help me..
email me @ myelmou@yahoo.com wencabiao@gmail.com thank you

ashokkumar r a 08-28-2010 08:15 AM

yes it's working properly. but why others that means(gtalk,yahoo massanger) should not publish for Linux user. it was very disappointed to me from google and yahoo. But skype good. Thank you for your information....... very kind of your valuable answer.


All times are GMT -5. The time now is 04:01 PM.