LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-08-2003, 04:01 PM   #1
zynor
LQ Newbie
 
Registered: Aug 2003
Location: UK
Distribution: Mandrake 9.1
Posts: 10

Rep: Reputation: 0
Python 2.3 upgrade problems


Hi, I'm having a hard time installing the latest version of python on Mandrake 9.1.
I downloaded the src.rpm from www.python.org and done what it said and rebuilt the rpm. But were some errors in the .spec so i fixed it and built the rpms. When i try to install i get:

# rpm -U python2.3-2.3-4pydotorg.i586.rpm
error: failed dependencies:
python-base >= 2.3 is needed by python2.3-2.3-4pydotorg

I can't find a download for python-base on the python site so I'm guessing it's meant to be created by the src.rpm build.
How do i tell it to do that?
 
Old 09-08-2003, 04:25 PM   #2
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Don't use rpm's. They are terrible with dependencies. Compile it from source. Get this file:

http://www.python.org/ftp/python/2.3/Python-2.3.tgz

uncompress it read the readme and there you go. If you are not sure how to install/compile a program, read this useful thread about it:

http://www.linuxquestions.org/questi...threadid=45094

Also, make sure you have use for 2.3 python, cause it's only one month newer then 2.2.3 and there ain't many differences between them .
 
Old 09-08-2003, 05:18 PM   #3
zynor
LQ Newbie
 
Registered: Aug 2003
Location: UK
Distribution: Mandrake 9.1
Posts: 10

Original Poster
Rep: Reputation: 0
I thought about doing that but if i were to, wouldn't i have problems if i need to install rpms that require python 2.3, and i would have both 2.2 and 2.3 installed.

There are quite a few changes in python 2.3 making it worth the hassle i was starting to use it before i switched to Linux.
 
Old 09-08-2003, 05:24 PM   #4
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
MegamanX, the 2.2.3 release is a bugfix to the older 2.2.x branch, while the developers have been putting a lot of work into the new 2.3.x releases. If you check the older releases you'll see 2.3 alphas and 2.2.2 bugfix releases intermixed in release dates as the two branches are worked on side by side.
Just to clear that point up.

zynor, there are 2.3 rpm packages for Mandrake, see the additional sources you can add to Urpmi/RpmDrake via this Easy Urpmi site. However, the most stable way will probably be to do as I plan and wait a few weeks for Mdk 9.2 which already has Python2.3, not to mention a great load of other improvements. I warn you that 9.2 RC1 seems to have a few vital problems with urpmi atm, so wait for the final release if you can.
 
Old 09-08-2003, 05:58 PM   #5
zynor
LQ Newbie
 
Registered: Aug 2003
Location: UK
Distribution: Mandrake 9.1
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks for the advise i think I'll just wait.
 
Old 09-08-2003, 06:24 PM   #6
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Thanks a lot zynor and Proud for the further explanation . I use python very often with pygame and I was pretty satisfied with it's performance that I've never tried to upgrade it myself . Thanks again and good luck zynor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE3.5 Upgrade kdebindings-python dependency errors EclipseAgent Suse/Novell 26 12-27-2005 10:46 AM
problems with Python dratix Ubuntu 3 06-15-2005 10:33 PM
problems with python: what else is new??? mrchaos Linux - Software 4 05-13-2005 03:43 PM
getmail/python 2.4 warning - after upgrade Andy Alkaline Slackware 3 04-13-2005 10:13 AM
Python 2.1 upgrade to 2.3 chris3435 Linux - Software 3 03-23-2004 07:33 AM


All times are GMT -5. The time now is 08:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration