SUSE / openSUSEThis Forum is for the discussion of Suse Linux.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
Ok, for anyone following this, I have to revert back, I installed the kdebindings3-python package, ignoring errors, but I was unable to run the superkaramba configure theme because it said I needed PyQT (guess the PyQT from the 3.5.0-7 package didn't install correctly).
What a pain in the ass..
So I am going to install hplip and kdebindings3 from the SuSE 10 cd and see if it will then let me upgrade (since I did do some supplementary upgrades of KDE).
Great tutorial which you obviously figured out on your own, no thanks to anyone on this forum. So, can you give a brief overview on what you did to upgrade to KDE v3.5?
I didn't think anyone read this, I was using it more as a notebook to revert what i've changed (bwahahha, jk, that just made me feel better about no replies).
I did however see that the kdebindings3-python package was upgraded to 3.5.0-8 from 3.5.0-7 yesterday, but have not yet tried to see if the python-qt has been removed from required or if it works at all.
Currently I have kdebindings3-python 3.4.2-8 and have upgraded everything for KDE to 3.5.0- except the bindings package.
I did all the installs using YaST, and also tried to python package via the RPM and still a no-go.
Now to try to upgrade FROM 3.4.2 to 3.5.0-8 instead of 3.5.0-rc1 to 3.5.0-8 since the RC1 package did not need the python-qt.
I read your thread too. I got the same error about python-qt. I currently have kdebindings3-python-3.5.0-5 installed which is from a few days ago when 3.5 was still a release candidate. The newest version from the gold release is 3.5.0-8 and is identical to 3.5.0-5 until you get to several qt.so files that are missing in the newest version. I don't know if this is a mistake that will be fixed shortly or if they did it on purpose. These things can happen when you're one of the first adopters, you animal.
I just selected "don't upgrade" for the kdebindings3-python package and left it at version 3.5.0-5. I haven't done anything with superkaramba so I don't know if I have the same problems as you. So far, everything with KDE 3.5 is working fine for me but I'm going to keep checking the mirrors for the next week or so to see if the kdebindings package is upgraded/fixed.
Edit: I just reread the last line from you post above and wanted to point out that it isn't that the release candidate didn't need python-qt. The problem is the final version (3.5.0-8) is missing the qt files, which is why you got the dependency error.
Originally posted by mewt Isnt there an rpm for python-qt package since i uninstalled it while trying to upgrade to kde 3.5 and now superkaramba wont work but i cant find a way to install python-qt >3.5.something
The reason you can't find it is because if you check the change log of kdepython3-python you will see after the RC1 release, on Nov 24th you will see that they stripped python-qt although it is still marked as "required" in the dependincies.
As for being able to use SuperKaramba again, you need to remove kdebindings3-python,
remove the hplip (if installed) then go to installation sources and disable the KDE 3.5 Supp source and enable the SuSE 10 cd source (if disabled like I had mine).
Install the kdebindings3-python 3.4.2-8 from the SuSE CD, it may ask you to downgrade another package, go ahead and say yes.
Once done, you can use your SuperKaramba again since PyQT is back (also if you read the 3.5.0-8 check where it says obsoletes, for some reason it says it obsoletes PyQt, PyKDE and a few others).
Originally posted by pilotgi Edit: I just reread the last line from you post above and wanted to point out that it isn't that the release candidate didn't need python-qt. The problem is the final version (3.5.0-8) is missing the qt files, which is why you got the dependency error.
Intrested you say that, because I too noticed the missing files, BUT if you check the "required" in 3.5.0-5 and 3.5.0-8 you will notice that under the "required" section 3.5.0-5 did not require any version of python-qt