LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-21-2004, 03:09 AM   #1
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Rep: Reputation: 15
Problems in K3B


I have K3B and most parts of it work fine: I can successfully burn data and audio CDs without a problem. However, when I try to do a Clone CD, I run into trouble. It will start copying from /mnt/cdrom (DVD rom drive) to an image at first. However I keep getting errors that say "Cannot read source disk" After awhile it will stop. This happens with any CD I try to clone. I am using Fedora Core 1 by the way.
 
Old 02-01-2004, 09:21 PM   #2
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Original Poster
Rep: Reputation: 15
Hmm, I still can't get this to clone CDs. I read somewhere else that cdrecord requires SCSI addressing and that I'd need to emulate SCSI. I did this by modifying my GRUB config file as was told. However, I still cannot copy CDs without it giving the "cannot read source disk" error."
 
Old 02-01-2004, 10:03 PM   #3
Greyweather
Member
 
Registered: Aug 2003
Distribution: Ubuntu 4.10
Posts: 311

Rep: Reputation: 30
I don't know about K3B, but XCDRoast has conflicts with automount. I'm guessing Fedora sets up automount by default, maybe disabling it will remove the conflict.

This is just a shot in the dark. Hopefully someone who uses K3B will have experience fixing this issue.

Edit: After you enabled scsi-emulation did you update the location for the device in your k3b configuration? It'll have a different location as a scsi-emulated device than as a ATAPI device.

Last edited by Greyweather; 02-01-2004 at 10:09 PM.
 
Old 02-01-2004, 10:39 PM   #4
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Original Poster
Rep: Reputation: 15
Hey how do you turn off Automount? I am using KDE by the way.

Thanks.

Also, I have no idea where to specify the new location. I had to add the line hdc=ide-scsi in the config. What would the new device be called and how do I change this in K3B?

Last edited by Jamar; 02-01-2004 at 10:57 PM.
 
Old 02-02-2004, 05:24 AM   #5
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
This is how I got K3b working on Mandrake 9.1:

http://www.linuxquestions.org/questi...r=2#post338886

You might have to make some changes because of Grug vs Lilo, etc. You might also care to read the saga leading up to that post for a bit of background on why I arrived at that solution. Hope this is of some help to you.
 
Old 02-02-2004, 03:48 PM   #6
Jamar
LQ Newbie
 
Registered: Jan 2004
Location: NY
Posts: 22

Original Poster
Rep: Reputation: 15
Almost got it I think..but I can't figure out how to change that driver for the last step in my version of K3B nor how to change the mount points back to their original settings in the control center.
 
Old 02-03-2004, 01:37 AM   #7
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
In K3b, select Settings->Configure K3b and click on Devices. Under Reader, next to Cdrdao driver, click on the setting in the right hand pane. It will turn into a drop-down box. Then click on the drop-down box, select generic-mmc from the list, and click OK.

The easiest way to change the mount points back to their original settings is to edit /etc/fstab with a text editor (you'll need to open it as root).

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.3 + KDE 3.2 + K3b 0.11.4 = PROBLEMS (K3b) svarreby Slackware 2 02-08-2005 10:16 PM
problems installing k3b-mp3 for FC3 and k3b-0.11.18 Rockgod2099 Linux - Software 8 01-09-2005 07:38 PM
K3B problems ksd Slackware 3 01-08-2004 12:23 PM
k3b problems dtheorem Mandriva 1 12-11-2003 01:39 PM
k3b problems the anti-riced Linux - Software 19 06-22-2003 07:47 PM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration