LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-20-2003, 11:21 PM   #1
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Rep: Reputation: 15
Unhappy k3b problems


ok, i think i have k3b installed, i did ./configure, make, and make install. but when i try to run it (logged in as root) by typing k3b in the terminal it says command not found

what am i missing?
 
Old 06-20-2003, 11:38 PM   #2
bling bling
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware/win xp soon to be LFS/win xp
Posts: 95

Rep: Reputation: 15
Did you type it right?
Did you do a CLEAN install?
Do you have all the dependencies?

BTW If you search for winex on freshmeat.net it will show you to a FREE server with it.
 
Old 06-20-2003, 11:42 PM   #3
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
how can i tell if it has all of the dependancies?

type what right?

what do you mean by a clean install, not having installed k3b before?
 
Old 06-20-2003, 11:47 PM   #4
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Type whereis k3b.

My k3b went to /usr/local/kde/bin, so in order to run it I would type /usr/local/kde/bin/k3b, however before doing this you should open a virtual console, su and then /usr/local/kde/bin/k3bsetup to get everything set up for your CD burner. I have changed my bash_profile to include /usr/local/kde/bin as one of my paths.

Good Luck and Enjoy, K3B works wonderfully for me
 
Old 06-20-2003, 11:57 PM   #5
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
ok i ran setup, it all went fine

but when i try to run k3b, it says

mcop warning: user defined signal handler found for SIG_PIPE, overriding
/tmp/mcop-tom is not owned by user
 
Old 06-21-2003, 12:35 AM   #6
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
do
chown tom /tmp/mcomp-tom
as root and you should be fine
 
Old 06-21-2003, 12:38 AM   #7
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
what about installing from an rpm

the k3b website has one for RH8 will that work with RH9?
 
Old 06-21-2003, 01:35 AM   #8
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by neo77777
do
chown tom /tmp/mcomp-tom
as root and you should be fine
ok did this, it said

[root@Linux tom]# chown tom /tmp/mcomp-tom
chown: failed to get attributes of `/tmp/mcomp-tom': No such file or directory


also, i reinstalled it using this different command from the k3b website
Quote:
Q: Everytime K3b starts it asks for K3bSetup to be run although I completed it.

A: Most likely you installed K3b in the wrong directory. All KDE programs are installed in the KDE dirtree (which should be /opt/kde3 but is not on all distros). If you compile K3b from source it defaults to either $KDEDIR or /usr/local (which is strange since /opt/kde3 should be the default; but this is part of the KDE build system). To install in the correct directory you need to specify the prefix to configure like this:

./configure --prefix=/opt/kde3


That will install K3b relative to /opt/kde3.

i installed the RH8 rpm, but that isnt detecting my writer, it says i need to change something for scsi emulation?

so has having 3 different installations royally messed up my system and now i'll never get it working, or is there still hope


now that i think about it........im gonna work on this tomorow, i am tired and im going to bed
 
Old 06-21-2003, 02:05 AM   #9
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
In grub add this lines next to your kernel loading parameters:
Code:
kernel /vmlinuz, etc, etc.
at the end of that line add hd[xx]=ide-scsi. Note that hd[xx] stands for what device your cdwriter actually is. In my case I have hdc=ide-scsi hdd=ide-scsi. My cdwriter and DVD-rom, both are seen by the kernel as SCSI devices (there is nothing wrong with IDE, but until kernel 2.6 in order to burn CD's you would need it)

Now if you wan to enable DMA in the drive(s) open as root the file /etc/rc.d/rc.local and add to end of the file this line

Code:
hdparm -d1 hdc hdd*
*Or whichever your devices are mapped as.
 
Old 06-21-2003, 12:49 PM   #10
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Thetargos
In grub add this lines next to your kernel loading parameters:
Code:
kernel /vmlinuz, etc, etc.
at the end of that line add hd[xx]=ide-scsi. Note that hd[xx] stands for what device your cdwriter actually is. In my case I have hdc=ide-scsi hdd=ide-scsi. My cdwriter and DVD-rom, both are seen by the kernel as SCSI devices (there is nothing wrong with IDE, but until kernel 2.6 in order to burn CD's you would need it)

Now if you wan to enable DMA in the drive(s) open as root the file /etc/rc.d/rc.local and add to end of the file this line

Code:
hdparm -d1 hdc hdd*
*Or whichever your devices are mapped as.
where is grub, i know its my boot loader, but how do i change it
could you explain that a little better, im still pretty new
 
Old 06-21-2003, 03:56 PM   #11
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
Ok, Step by step:

Open a console and change to super user with:
Code:
$ su
password:
#
Notice the change in the prompt symbol form a dollar ($) to a number sighn (#), this # symbol is the root's symbol. Now if you are into X type.

Code:
# gedit /etc/grub.conf
If you are in pure console mode change gedit for vi. Make sure to read vi's manual (#man vi)

Next look for this line:
kernel /vmlinuz-2.4.21-ck1 ro root=LABEL=/ (substitute the acutal number in this example with your version, most likely to be 2.4.20-18.9). After the LABEL=/ expression add a space and then hdc=ide-scsi hdd=ide-scsi (if you have two optic devices connected to your motherboard's second IDE channel) or hdb=ide-scsi if you have your CD-writer sharing IDE with your HDD.

Now to enable DMA support for your devices so you can still watch DVD movies, rip CD's, etc., you will need to edit the file rc.local located in the directory /etc/rc.d/, you would do this, again as root like this:

Code:
# gedit /etc/rc.d/rc.local
Edit the file by entering this line at the very end of it in a single line:

Code:
hdparm -d1 /dev/hdc /dev/hdd
Make sure that these devices are the same as what you entered as the kernel boot parameters (with ide-scsi). The hdparm program will enable DMA to the devices (-d1 flag) even if they use ide-scsi emulation.
 
Old 06-22-2003, 06:40 PM   #12
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
ok i did that /\/\/\ its detecting my cd drives, but its not detecting the writer as a writer is there something i have to add to tell it it's a writer?
 
Old 06-22-2003, 07:15 PM   #13
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
No... there should nothing to configure to make it see your writer. All you need to do is to check where is the actual IDE connection for the writer. If you built the system, (most likely possiblity) remember that Linux uses as nomenclature for the drives the following:
hda = first Device (master) in the first IDE channel and all of its subsequent partitions, hence hda1,2,3...n (this apply only for HDDs)
hdb = second device (slave) in the first IDE channel.
hdc = first device (master) in the secondary IDE channel
hdd = second device (slave) in the secondary IDE channel

Things tend to get tricky when you have and IDE-ATA controller in the PCI bus, depending on your kernel, those channels get mapped BEFORE the on-board ones. So double check that. Also if you in any configuration file added a line as ide-cd, so that module would get loaded, comment that line out (add a # sign before it). If you are still in doubt which are your devices take a look at your /etc/fstab file and follow the symlincs for the CD-rom devices:

Code:
[gianni@Thetargos gianni]$ cd /dev
[gianni@Thetargos dev]$ ls -l cd* *dvd*
lrwxrwxrwx    1 root     root            4 jun 13 01:00 cdrom -> scd0
lrwxrwxrwx    1 root     root            4 jun 13 01:00 cdrom1 -> scd1
brw-rw----    1 root     disk      15,   0 ene 30 04:24 cdu31a
brw-rw----    1 root     disk      24,   0 ene 30 04:24 cdu535
lrwxrwxrwx    1 root     root            4 jun 13 01:00 cdwriter -> scd0
lrwxrwxrwx    1 root     root            8 jun 22 14:26 cdwriter1 -> /dev/sg1
lrwxrwxrwx    1 root     root            4 jun 13 00:59 dvd -> scd1
lrwxrwxrwx    1 root     root            4 jun 13 00:59 rdvd -> scd1
This is my listing of the optics devices and which are the actual devices being utilized by the different symlics. Hope this helps.

Edit: In my output I have actually two devices being mapped to the same physical device: cdrom -> scd0 and cdwrter -> scd0 are linked to the same device (my burner) and the one there saying cdwriter1 -> /dev/sg1 is actually the same physical device as the other two, i.e my burner.

Last edited by Thetargos; 06-22-2003 at 07:19 PM.
 
Old 06-22-2003, 07:18 PM   #14
the anti-riced
Member
 
Registered: May 2003
Location: Tinker AFB, OK
Distribution: Desktop:Windows XP Server:Nothing right now :(
Posts: 131

Original Poster
Rep: Reputation: 15
yes ive built my computer, is there any other way?


this is what mine said

[tom@Linux tom]$ cd /dev
[tom@Linux dev]$ ls -l cd* *dvd*
ls: *dvd*: No such file or directory
lrwxrwxrwx 1 root root 8 Jun 18 19:27 cdrom -> /dev/hdc
lrwxrwxrwx 1 root root 9 Jun 18 19:27 cdrom1 -> /dev/scd0
brw-rw---- 1 root disk 15, 0 Jan 30 05:24 cdu31a
brw-rw---- 1 root disk 24, 0 Jan 30 05:24 cdu535
lrwxrwxrwx 1 root root 8 Jun 22 19:04 cdwriter -> /dev/sg0

Last edited by the anti-riced; 06-22-2003 at 07:20 PM.
 
Old 06-22-2003, 07:20 PM   #15
Thetargos
Senior Member
 
Registered: Mar 2003
Location: Mexico City
Distribution: Fedora, Ubuntu & Mint
Posts: 1,679

Rep: Reputation: 45
What does the command I just posted reports?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.3 + KDE 3.2 + K3b 0.11.4 = PROBLEMS (K3b) svarreby Slackware 2 02-08-2005 10:16 PM
problems installing k3b-mp3 for FC3 and k3b-0.11.18 Rockgod2099 Linux - Software 8 01-09-2005 07:38 PM
Problems with K3b hellblade Linux - Software 5 04-17-2004 07:06 AM
K3B problems ksd Slackware 3 01-08-2004 12:23 PM
k3b problems dtheorem Mandriva 1 12-11-2003 01:39 PM


All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration