LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-07-2005, 09:34 PM   #1
Rockgod2099
Member
 
Registered: Oct 2004
Location: Chicago
Distribution: Fedora Core 2
Posts: 32

Rep: Reputation: 15
problems installing k3b-mp3 for FC3 and k3b-0.11.18


So I upgraded to Fedora Core 3, and was looking foreward to getting K3B working (since I had the dreaded 2.6.8 kernel which it doesn't work on.) I've been able to get k3b installed and working, with the exception of burning audio cd's out of mp3's. I've tried installing the k3b-mp3 plugin. I downloaded the appropriate version from http://rpm.pbone.net/index.php3/stat....i386.rpm.html

I"m running k3b-0.11.18, as it is the most recent version and has everything needed to run on FC3.

When I run the rpm installer this is what I get:

[root@uac-183-77 Guts]# rpm -Uvh k3b-mp3-0.11.18-0.1.3.kde.i386.rpm
warning: k3b-mp3-0.11.18-0.1.3.kde.i386.rpm: V3 DSA signature: NOKEY, key ID ff6382fa
error: Failed dependencies:
k3b = 0:0.11.18 is needed by k3b-mp3-0.11.18-0.1.3.kde
libk3bdevice.so.2 is needed by k3b-mp3-0.11.18-0.1.3.kde
libk3bplugin.so.2 is needed by k3b-mp3-0.11.18-0.1.3.kde

I also tried to get this plug-in installed via yum-

[root@uac-183-77 Guts]# yum install k3b-mp3-0.11.18-0.1.3.kde.i386.rpm
Repository updates-released already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up Repo: xcyb-bleeding
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: livna-stable
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: xcyb-stable
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
livna-stab: ################################################## 121/121
base : ################################################## 2622/2622
updates-re: ################################################## 463/463
xcyb-stabl: ################################################## 11/11
Examining k3b-mp3-0.11.18-0.1.3.kde.i386.rpm: k3b-mp3 - 0.11.18-0.1.3.kde.i386
Marking k3b-mp3-0.11.18-0.1.3.kde.i386.rpm as an update
Marking k3b-mp3-0.11.18-0.1.3.kde.i386.rpm as an update
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package k3b-mp3.i386 0:0.11.18-0.1.3.kde set to be updated
--> Running transaction check
--> Processing Dependency: libk3bplugin.so.2 for package: k3b-mp3
--> Processing Dependency: libk3bdevice.so.2 for package: k3b-mp3
--> Processing Dependency: k3b= 0:0.11.18 for package: k3b-mp3
--> Finished Dependency Resolution
Error: Missing Dependency: libk3bplugin.so.2 is needed by package k3b-mp3
Error: Missing Dependency: libk3bdevice.so.2 is needed by package k3b-mp3
Error: Missing Dependency: k3b is needed by package k3b-mp3

Any ideas people? I know I could use audacity to convert all my files to .wav files, but that's such a hassle, but then again, so is trying to install this plugin!!

Matt
rockgod2099@animail.net
 
Old 01-07-2005, 10:15 PM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Maybe you would have better luck by letting yum decide what version of k3b-mp3 to install.

yum update
yum install k3b
yum install k3b-mp3 or yum install k3b-mp3.i386
 
Old 01-08-2005, 03:11 PM   #3
Rockgod2099
Member
 
Registered: Oct 2004
Location: Chicago
Distribution: Fedora Core 2
Posts: 32

Original Poster
Rep: Reputation: 15
See, I tried that, but it installed k3b-mp3-0.11.14, in other words an older version of it for an older version of k3b. And when I open up k3b-0.11.18 and look at plug-ins it doesn't list k3b-mp3. I could downgrade to k3b-0.11.14, but then it wouldn't be compatible with the 0.6.9 kernel or Fedora core 3.

Matt
 
Old 01-08-2005, 04:23 PM   #4
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
It works for me

# uname -r
2.6.9-1.724_FC3

# rpm -qa | grep k3b
k3b-mp3-0.11.14-0.lvn.1.3
k3b-0.11.14-2
 
Old 01-09-2005, 02:07 PM   #5
Rockgod2099
Member
 
Registered: Oct 2004
Location: Chicago
Distribution: Fedora Core 2
Posts: 32

Original Poster
Rep: Reputation: 15
So I uninstalled k3b with yum remove k3b and when I go to check the kde menu, it's not there. so it seems as though it's uninstalled, but when I run yum install k3b-mp3, it tells me that it can't install cause it conflicts with previously installed versions. Any ideas on how to get the old versions completely gone?

root@uac-183-77 root]# yum install k3b-mp3
Repository updates-released already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up Repo: xcyb-bleeding
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: livna-stable
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: xcyb-stable
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
livna-stab: ################################################## 121/121
base : ################################################## 2622/2622
updates-re: ################################################## 463/463
xcyb-stabl: ################################################## 11/11
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package k3b-mp3.i386 0:0.11.14-0.lvn.1.3 set to be installed
--> Running transaction check
--> Processing Dependency: libk3bcore.so.2 for package: k3b-mp3
--> Processing Dependency: k3b>= 0:0.11 for package: k3b-mp3
--> Processing Dependency: libk3bplugin.so.2 for package: k3b-mp3
--> Processing Dependency: libk3bdevice.so.2 for package: k3b-mp3
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package k3b.i686 0:0.11.18-1.xcyb.fc3 set to be installed
--> Running transaction check

Dependencies Resolved
Transaction Listing:
Install: k3b-mp3.i386 0:0.11.14-0.lvn.1.3

Performing the following to resolve dependencies:
Install: k3b.i686 0:0.11.18-1.xcyb.fc3
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Check Error: file /usr/lib/kde3/libk3bmaddecoder.la conflicts between attempted installs of k3b-0.11.18-1.xcyb.fc3 and k3b-mp3-0.11.14-0.lvn.1.3
file /usr/lib/kde3/libk3bmaddecoder.so conflicts between attempted installs of k3b-0.11.18-1.xcyb.fc3 and k3b-mp3-0.11.14-0.lvn.1.3
 
Old 01-09-2005, 02:13 PM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Try this. Note, the version numbers may be different on your box.
# rpm -qa |grep k3b
k3b-mp3-0.11.14-0.lvn.1.3
k3b-0.11.14-2

# rpm -e k3b-mp3-0.11.14-0.lvn.1.3
# rpm -e k3b-0.11.14-2
 
Old 01-09-2005, 06:11 PM   #7
Rockgod2099
Member
 
Registered: Oct 2004
Location: Chicago
Distribution: Fedora Core 2
Posts: 32

Original Poster
Rep: Reputation: 15
Tried that and it didn't turn out anything back, so I tried putting a space between the | and grep, still no luck

[root@uac-183-77 root]# rpm -qa |grep k3b
[root@uac-183-77 root]# rpm -qa | grep k3b
[root@uac-183-77 root]#
 
Old 01-09-2005, 06:33 PM   #8
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Maybe the command:yum clean would help.
You also could try synaptic to fix broken dependancies.
 
Old 01-09-2005, 06:38 PM   #9
Rockgod2099
Member
 
Registered: Oct 2004
Location: Chicago
Distribution: Fedora Core 2
Posts: 32

Original Poster
Rep: Reputation: 15
Ok so it turned out I had my ect/yum.conf file set to download k3b from 2 seperate repos and that's why I was getting the conflict, so I fixed that and it downloaded fine (see below) however, when I open up k3b and look in the plug-ins section, it doesn't list k3b-mp3. Then Iwhen I try to drag an mp3 to the audio file, the whole program crashes and I get a bug error message, but it won't give me the details of what the bug is. WTF?

MAtt

[root@uac-183-77 root]# yum install k3b-mp3
Repository updates-released already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: livna-stable
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
livna-stab: ################################################## 121/121
updates-re: ################################################## 463/463
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package k3b-mp3.i386 0:0.11.14-0.lvn.1.3 set to be installed
--> Running transaction check
--> Processing Dependency: libk3bcore.so.2 for package: k3b-mp3
--> Processing Dependency: k3b>= 0:0.11 for package: k3b-mp3
--> Processing Dependency: libk3bplugin.so.2 for package: k3b-mp3
--> Processing Dependency: libk3bdevice.so.2 for package: k3b-mp3
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package k3b.i386 0:0.11.14-2 set to be installed
--> Running transaction check

Dependencies Resolved
Transaction Listing:
Install: k3b-mp3.i386 0:0.11.14-0.lvn.1.3

Performing the following to resolve dependencies:
Install: k3b.i386 0:0.11.14-2
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: k3b 100 % done 1/2
/sbin/ldconfig: File /usr/lib/libkdeinit_kprinter.so.#prelink#.TFhpdn is empty,not checked.
Installing: k3b-mp3 100 % done 2/2

Installed: k3b-mp3.i386 0:0.11.14-0.lvn.1.3
Dependency Installed: k3b.i386 0:0.11.14-2
Complete!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC3 - K3b not recognizing mp3s w/ k3b-mp3 installed! Forezt Linux - Software 2 07-25-2006 05:43 PM
K3B problems with .mp3 cerealdaemon Linux - Software 4 08-09-2005 07:16 AM
K3B problems with .mp3 cerealdaemon Linux - Software 2 07-28-2005 01:07 AM
Problems with mp3 support on k3b StarDragon Linux - Software 4 06-02-2005 10:43 AM
FC3 and K3b writing problems smudge|lala Linux - Software 0 02-03-2005 11:28 AM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration