Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-30-2003, 09:31 PM   #1
LQ Newbie
Registered: Sep 2003
Distribution: Red Hat 9, Mandrake 9.2
Posts: 8

Rep: Reputation: 0
Question Problem executing Americas Army armyops

i just installed americas army 1.90.

when i try to execute the armyops file, the AAO logo pops up and dissappears immediatly after. the game itself isn't starting.

i get the following error message in my shell:

Missing symbols - aborting.


Exiting due to error

what does that mean? how do i fix it?

hope somebody can help me, i really like this game.
Old 09-30-2003, 10:50 PM   #2
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
"americas army" has a Linux client?

Old 10-01-2003, 04:37 AM   #3
LQ Newbie
Registered: Oct 2003
Posts: 3

Rep: Reputation: 0
Yep, I got this error when I installed the linux dedicated server:

...can't find data "lan"

..Out of video memory..

when it was supposed to run inside a terminal...

Hope anybody can explain that!


Old 10-25-2003, 06:22 PM   #4
Registered: Sep 2003
Location: Fort worth, TX
Distribution: Debian testing 64bit at home, EL5 32/64bit at work.
Posts: 190

Rep: Reputation: 30
Unhappy I have the exact same error.

I installed the game and tried to start it, but I get this feedback at the command line:

]$ armyops
Missing symbols - aborting.
Exiting due to error

The splash screen comes up but then dies away with the above report at the command line.

My setup: HP Pavilion xt375 (2.2Ghz, P4, 512 RAM) with Mandrake 9.1

Other games play just fine. I rarely go through a week without playing UnrealTournament (v436) or Never Winter Nights.

Any ideas about what's happening?

Old 07-21-2004, 02:59 AM   #5
LQ Newbie
Registered: Jul 2004
Posts: 1
Blog Entries: 2

Rep: Reputation: 0
Missing symbols - aborting fix

My distro is PCLinuxOS. It was forked off of Mandrake 9.2.

When I run: "armyops"
I get this:
"Missing symbols - aborting.
Exiting due to error"

The solution was to run: "LD_PRELOAD=/usr/lib/ /usr/local/games/armyops/armyops"
You may also try this instead: "LD_PRELOAD=/usr/lib/tls/ /usr/local/games/armyops/armyops"

Note: "/usr/local/games/armyops/armyops" is the default install location for the full path to the armyops binary file. If you installed armyops some where else substitute that path. I found my solution at plus a little digging around. I found this forum solution too

Last edited by Visible; 07-21-2004 at 03:25 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Americas Army startup problem ????help glenn69 Linux - Software 0 09-07-2004 08:35 PM
Americas Army - Sound problem - Redaht 9.0 mmurch01 Linux - Software 4 03-27-2004 11:34 AM
Americas Army (ArmyOps) Install-Error :( Archon22 Linux - Games 1 12-05-2003 04:42 PM
Americas Army Sound Problem rmarvin Linux - Games 2 12-02-2003 12:27 PM
Americas Army 1.9 Network problem phinaliumz Linux - Games 9 11-21-2003 03:34 PM

All times are GMT -5. The time now is 11:03 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration